Bug 4625 - wmconfig/fvwm2 problem
wmconfig/fvwm2 problem
Product: Red Hat Linux
Classification: Retired
Component: wmconfig (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Cristian Gafton
Depends On:
  Show dependency treegraph
Reported: 1999-08-20 07:23 EDT by Ian Cameron
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-08-27 18:40:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ian Cameron 1999-08-20 07:23:24 EDT
There seems to be a problem with wmconfig when creating
fvwm2 configs when it scans the /usr/share/gnome/apps

For each subdirectory, wmconfig produces a menu item within
a menu item of the same name with a null Exec command.

wmconfig --output=fvwm2 --rootmenu=RootMenu --no-promote

produces the following:

AddToMenu       RootMenu        "Graphics"      Popup


# Starting configuration for menu "Graphics"
# Icon specification for Apps under "Graphics"
Style   "The GIMP"      MiniIcon        mini-wilbur.xpm
Style   "The GIMP"      Icon    wilbur.xpm
# The menus...
AddToMenu       RootMenu.Graphics       "Graphics"
AddToMenu       RootMenu.Graphics       "Viewers"
Popup   RootMenu.Graphic
# The following is added by package: Electric Eyes
AddToMenu       RootMenu.Graphics       "Electric Eyes"
Exec    ee &
# The following is added by package: GQview
AddToMenu       RootMenu.Graphics       "GQview"
Exec    gqview &
# The following is added by package: Graphics
AddToMenu       RootMenu.Graphics       "Graphics"
Exec    &
# The following is added by package: gimp
AddToMenu       RootMenu.Graphics       "The GIMP
%mini-wilbur.xpm%"    Exec
gimp &
# The following is added by package: xpaint
AddToMenu       RootMenu.Graphics       "xpaint"
Exec    xpaint &

The AddToMenu after the config for GQview illustrates this.
It does not make any difference if you allow promotion.
This problem also seems to show for FVWM95 (what's the
difference anyway?).

I've also noticed that the Settings directory for the Gnome
menus seems to be ignored, but I presume it is meant to be
ignored, as these are Gnome specific (apart from the Imlib
configuration tool perhaps, in which case perhaps the menu
item for this would be better placed elsewhere?).

I've marked this as being i386, but it probably happens on
all platforms.
Comment 1 Cristian Gafton 1999-08-27 18:40:59 EDT
Fixed in wmconfig-0.9.7

Note You need to log in before you can comment on or make changes to this bug.