Bug 462538 - [4.7] scsi_id command outputs an unnecessary error message
[4.7] scsi_id command outputs an unnecessary error message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: udev (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 19:12 EDT by Flavio Leitner
Modified: 2010-10-23 00:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:29:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Leitner 2008-09-16 19:12:12 EDT
Description of Problem:
When booting a system connected with a tape drive whose media not
inserted, scsi_id command fails and outputs the following error message.


     scsi_id[1629]: 1:0:5:0: close failed: No medium found


The udev executes scsi_id command against tape drives (st and nst
devices) since RHEL4.6 because udev rules have been changed at this
update.

Version-Release number of selected component:

 Red Hat Enterprise Linux Version Number: 4
 Release Number: 7
 Architecture: ia64
 Kernel Version: linux-2.6.9-78.EL
 Related Package Version: udev-039-10.22.el4
 Related Middleware / Application: None

Drivers or hardware or architecture dependency:
Tape drives.
This is architecture independent.

How reproducible:
Always.

Step to Reproduce:
Start up the system without tape media inserting.

Actual Results:
scsi_id command fails and outputs unnecessary error message.

Expected Results:
scsi_id command fails but does not output unnecessary error message.

Summary of actions taken to resolve issue:

Location of diagnostic data:

Hardware configuration:

 Model: PRIMEQUEST 580
 CPU Info: Itanium 2(1.6GHz) x4
 Memory Info: 4GB
 Hardware Component Information: None
 Configuration Info: None
 Guest Configuration Info: None

Additional Info:
In the upstream, this message is suppressed by the following patch.

http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=025570aa3e054d92d65f8d2de9f91d202f60c798
Comment 1 RHEL Product and Program Management 2008-09-16 19:40:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Phil Knirsch 2008-09-23 11:41:25 EDT
Proposing for RHEL-4.8 and granting Devel ACK.

Thanks,

Read ya, Phil
Comment 6 errata-xmlrpc 2009-05-18 16:29:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1004.html

Note You need to log in before you can comment on or make changes to this bug.