Bug 462567 - system-config-cluster shows errors while adding "HP ILO Device"
system-config-cluster shows errors while adding "HP ILO Device"
Status: CLOSED DUPLICATE of bug 444597
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4.7
i386 Linux
urgent Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
: 467693 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 01:33 EDT by Winston Li
Modified: 2016-04-26 23:42 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-26 16:11:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
workaround for the problem (fail to add fence device) (2.42 KB, patch)
2008-09-18 04:17 EDT, Binbin Wang
no flags Details | Diff
Patch to fix issue with imports fence device with ssh. (2.54 KB, patch)
2009-01-14 10:41 EST, Shane Bradley
no flags Details | Diff
FenceHandler.py file with patch applied (54.13 KB, application/octet-stream)
2009-01-14 10:42 EST, Shane Bradley
no flags Details
Fixed a control flow issue, this is the latest FenceHandler (54.25 KB, application/octet-stream)
2009-01-19 14:11 EST, Shane Bradley
no flags Details
Fix another instance of ssh call (54.39 KB, application/octet-stream)
2009-01-20 10:43 EST, Shane Bradley
no flags Details

  None (edit)
Description Winston Li 2008-09-17 01:33:53 EDT
Description of problem:
system-config-cluster shows erros while adding ilo fence device. 

Version-Release number of selected component (if applicable):
# rpm -qf /usr/sbin/system-config-cluster 
system-config-cluster-1.0.54-2.0

How reproducible:
Reproducible


Steps to Reproduce:
1. run system-config-cluster
2. Add Fence Device
3. Select "HP ILO Device"  from drop box
4. Fill in the fields and click "OK"
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTabController.py", line 1232, in on_fd_panel_ok
    return_list = self.fence_handler.validate_fencedevice(agent_type, None)
  File "/usr/share/system-config-cluster/FenceHandler.py", line 713, in validate_fencedevice
    returnlist = apply(self.fd_validate[agent_type], args)
  File "/usr/share/system-config-cluster/FenceHandler.py", line 932, in val_ilo_fd
    if self.ilo_ssh.get_active == True:
AttributeError: 'NoneType' object has no attribute 'get_active'


Expected results:
No error

Additional info:
Comment 1 Binbin Wang 2008-09-18 04:17:48 EDT
Created attachment 317044 [details]
workaround for the problem  (fail to add fence device)

The ilo_ssh here is NULL, so it will cause the 'NoneType' error information.

Same problem we can find when add wti, drac fence device.

I don't know why add a "secure" field in RHEL4 Update7. However, it fail to take effect here. And make some troubles.

Do not let the ilo_ssh here to call the get_active function, We can workaround this problem.

Attachment is a patch to workaround the problem.
Comment 2 Shane Bradley 2009-01-14 10:41:28 EST
Created attachment 329013 [details]
Patch to fix issue with imports fence device with ssh. 

Since ssh support is not ready, the scc would not import fence devices with ssh.
Comment 3 Shane Bradley 2009-01-14 10:42:11 EST
Created attachment 329014 [details]
FenceHandler.py file with patch applied
Comment 4 Shane Bradley 2009-01-14 10:42:54 EST
Comment on attachment 329014 [details]
FenceHandler.py file with patch applied

How to install:

Backup orginal
$ mv /usr/share/system-config-cluster/FenceHandler.py
   /usr/share/system-config-cluster/FenceHandler.py.orginal

Copy in the new file
$ cp /root/FenceHandler.py.patchBZ462567
    /usr/share/system-config-cluster/FenceHandler.py

Make sure perms and everything is set. Then run system-config-cluster.
Make sure they verify that cluster.conf is correct and it works as expected.
Comment 5 Shane Bradley 2009-01-14 10:46:38 EST
Comment on attachment 329013 [details]
Patch to fix issue with imports fence device with ssh. 

There was a few missing cases that I added to the patch. This should fix importing and adding fence devices for this issue.
Comment 6 Shane Bradley 2009-01-19 14:11:42 EST
Created attachment 329388 [details]
Fixed a control flow issue, this is the latest FenceHandler 

Tested this FenceHandler.py on RHEL4 scc and it created and opened cluster.conf with fencedevice ilo
Comment 7 Shane Bradley 2009-01-20 10:43:48 EST
Created attachment 329475 [details]
Fix another instance of ssh call
Comment 9 RHEL Product and Program Management 2009-02-24 14:30:25 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 19 Chris Feist 2009-07-29 13:07:18 EDT
Pulling the 4.8.z flag as this won't be fixed until 4.9 at the earliest.
Comment 23 Lon Hohberger 2010-05-11 13:19:38 EDT
*** Bug 467693 has been marked as a duplicate of this bug. ***
Comment 24 Ryan McCabe 2010-10-26 16:11:46 EDT

*** This bug has been marked as a duplicate of bug 444597 ***

Note You need to log in before you can comment on or make changes to this bug.