This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 462605 - kernel updates prevent graphic login
kernel updates prevent graphic login
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
kernel updates prevent graphic login
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 10:07 EDT by antonio montagnani
Modified: 2008-10-07 14:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 14:42:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (99.42 KB, text/plain)
2008-10-02 09:04 EDT, Milos Jakubicek
no flags Details

  None (edit)
Description antonio montagnani 2008-09-17 10:07:08 EDT
Description of problem:
I installed kernel 2.6.27-0.329.rc6.git2.fc10.i686 problem on my
laptop and when I boot in level 5 it freezes at login window, other
kernels boot fine.
In level 3 it starts fine....

Version-Release number of selected component (if applicable):
2.6.27-0.329.rc6.git2.fc10.i686

How reproducible:
Always

Steps to Reproduce:
1.Boot
2.
3.
  
Actual results:
No graphical login

Expected results:
Standard operation

Additional info:
On other computer with nouveau driver it works fine, the affected computer is using i810 driver (!!!!)
Comment 1 antonio montagnani 2008-09-24 10:50:32 EDT
same with recent kernel-2.6.27-0.352.rc7.git1.fc10.i686
Where do I have to dig for better debugging???
Comment 2 antonio montagnani 2008-09-29 18:58:13 EDT
same with recent kernel-2.6.27-0.354.rc7.git1.fc10.i686

I see some flashing (but black) n screen and some HD activity: that's all and I need an hard reboot
Comment 3 antonio montagnani 2008-09-30 09:07:11 EDT
same with kernel-2.6.27-0.370.rc8.fc10.i686....I have not upgraded the  	xorg-x11-drv-i810 due to bug 461772.
Comment 4 antonio montagnani 2008-10-01 01:36:57 EDT
using intel driver with integrated Intel GM965/GL960 graphic chip
Comment 5 Milos Jakubicek 2008-10-02 09:03:01 EDT
I've the same problem with Intel Corporation Mobile 945GM/GMS/GME, but it seems to be related to gdm, after switching to kdm it worked. See the attached log.
Comment 6 Milos Jakubicek 2008-10-02 09:04:23 EDT
Created attachment 319228 [details]
/var/log/messages
Comment 7 Peter Robinson 2008-10-02 09:17:37 EDT
I'll add a me too for this bug. Machine is a eeePC 901 which has the atom chip plus the equivalent g945 graphics
Comment 8 Ray Strode [halfline] 2008-10-02 14:26:54 EDT
Milos,

comment 6 is just gnome-session not being installed but being a requirement of gdm.

There's a Requires: in place for it now, so it should get pulled in with updates.

Alternatively, yum install gnome-session should fix your issue.
Comment 9 antonio montagnani 2008-10-07 14:42:32 EDT
after latest updates, it works

Note You need to log in before you can comment on or make changes to this bug.