Bug 462607 - Firefox no longer launches from other applications
Firefox no longer launches from other applications
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 10:08 EDT by Jeff Burke
Modified: 2009-06-05 09:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-05 09:58:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 456052 None None None Never

  None (edit)
Description Jeff Burke 2008-09-17 10:08:31 EDT
Description of problem:

I am currently running the RHEL5.2 Client. I have pointed my repo file to the internal repo for 5.2-Z. Earlier this week I was notified that a new Firefox was available. Since upgrading I have had intermittent errors when trying to launch browser from other applications. 

Here is the dialog box that appers:

--------------------------------------------------------------------------------
      Close Firefox 

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

--------------------------------------------------------------------------------

Version-Release number of selected component (if applicable):
firefox-3.0.1-1.el5
xulrunner-1.9.0.1-1.el5

How reproducible:
Intermittent

Steps to Reproduce:
1. From thunderbird or xchat try to "open a link" in browser
  
Actual results:
Sometime it works and sometimes it doesn't

Expected results:


Additional info:
Comment 1 Matěj Cepl 2008-09-19 12:18:33 EDT
Is it just that it takes some time for Firefox to start up (and it is not able to get more requests while it starts) or something worse?
Comment 2 Jeff Burke 2008-09-19 12:23:29 EDT
It is worse. I Have firefox up and running and it works for some period of time. Sometime during the day if I then click a link in thunderbird/xchat I will start getting the above message.
Comment 3 Matěj Cepl 2008-09-19 12:53:25 EDT
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=456052) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 4 Martin Stransky 2009-06-05 09:43:49 EDT
It looks like firefox crashes during exist but still exists in sleep state. When this situation happens, can you please attach gdb to running firefox-bin and attach the backtrace here?
Comment 5 Jeff Burke 2009-06-05 09:57:35 EDT
Martin,
    I no longer have this setup. My desktop system has been upgraded to use RHEL5.3-Z. I have not seen it is several months.

Jeff
Comment 6 Martin Stransky 2009-06-05 09:58:45 EDT
Okay, closing.

Note You need to log in before you can comment on or make changes to this bug.