Bug 462612 - rpmdiff complains about suspicious code in debug code
rpmdiff complains about suspicious code in debug code
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ORBit2 (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Winship
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 10:48 EDT by Matthias Clasen
Modified: 2011-10-24 11:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 11:17:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-09-17 10:48:29 EDT
1562  	gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include -I../src/orb -I../include -DORBIT2_INTERNAL_API -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations  -I../linc2/include -I../linc2/include -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include      -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -Werror-implicit-function-declaration -std=gnu89 -c `test -f 'typelib-dump.c' || ech(line truncated)
  1563  /bin/sh ../libtool --mode=link gcc  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -Werror-implicit-function-declaration -std=gnu89   -o typelib-dump  typelib-dump.o ../src/orb/libORBit-2.la -pthread -Wl,--export-dynamic -L/lib -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -ldl -lglib-2.0
  1564  gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -Werror-implicit-function-declaration -std=gnu89 -o .libs/typelib-dump typelib-dump.o -pthread -Wl,--export-dynamic  ../src/orb/.libs/libORBit-2.so -L/lib -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -ldl -lglib-2.0
  1565  typelib-dump.o: In function `dump_tc':
  1566  /builddir/build/BUILD/ORBit2-2.14.3/test/typelib-dump.c:18: warning: memset used with constant zero length parameter; this could be due to transposed parameters
  1567  creating typelib-dump
  1568  source='test1.c' object='test1.o' libtool=no \n
Comment 1 Dan Winship 2011-10-24 11:17:51 EDT
(In reply to comment #0)
>   1565  typelib-dump.o: In function `dump_tc':
>   1566  /builddir/build/BUILD/ORBit2-2.14.3/test/typelib-dump.c:18: warning:
> memset used with constant zero length parameter; this could be due to
> transposed parameters

The warning is wrong; it's not a constant 0, it's a variable that gcc has just figured out will always end up being 0 in this program.

The offending code was removed upstream later on (since it is pointless since the length is always 0), and RHEL 6 has the fixed version.

Note You need to log in before you can comment on or make changes to this bug.