This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 462613 - [855GM] X hangs at startup
[855GM] X hangs at startup
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 10:52 EDT by Patrice Dumas
Modified: 2009-10-15 14:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-15 14:54:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log when things doesn't work (24.88 KB, text/plain)
2008-09-17 10:55 EDT, Patrice Dumas
no flags Details
Xorg.0.log with F-9 xorg-x11-i810 (24.79 KB, text/plain)
2008-09-17 10:56 EDT, Patrice Dumas
no flags Details

  None (edit)
Description Patrice Dumas 2008-09-17 10:52:29 EDT
Description of problem:

X hangs at startup, only the grey screen with little x, no mouse.
When I downgrade to
xorg-x11-drv-i810-2.3.2-2.fc9.i386
things work. A later version worked too, but rawhide mirrors 
only offer the last one these days, so I took F-9 package.
Killing X is not enough to get things back to normal, a reboot
is needed.

With the latest kernel 2.6.27-0.329.rc6.git2.fc10, nothing works.

With kernel-2.6.27-0.323.rc6.fc10.i586 things work.

lspci excerpt:

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-2.4.2-8.fc10.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2008-09-17 10:55:05 EDT
Created attachment 316968 [details]
Xorg.0.log when things doesn't work
Comment 2 Patrice Dumas 2008-09-17 10:56:07 EDT
Created attachment 316971 [details]
Xorg.0.log with F-9 xorg-x11-i810
Comment 3 Patrice Dumas 2008-10-02 07:35:58 EDT
Still not working with kernel-2.6.27-0.372.rc8.fc10.i586 and xorg-x11-drv-i810-2.4.2-9.fc10. This kernel also doesn't work with xorg-x11-drv-i810-2.3.2-2.fc9.i386.
Comment 4 Patrice Dumas 2008-10-02 07:44:09 EDT
The combination kernel-2.6.27-0.323.rc6.fc10.i586 and xorg-x11-drv-i810-2.4.2-9.fc10 doesn't work either.
Comment 5 Patrice Dumas 2008-10-20 08:57:51 EDT
The latest packages in rawhide don't work better. Additionaly some key
combinations now kill X. I have currently reverted to a mix of F9/F10 
packages that work 

xorg-x11-drv-evdev-2.0.6-1.fc9.i386
xorg-x11-drv-i810-2.3.2-2.fc9.i386
xorg-x11-server-Xorg-1.5.0-6.fc10.i386
kernel-2.6.27-0.323.rc6.fc10.i586

I'll wait for some comments to resume testing.
Comment 6 Bug Zapper 2008-11-25 22:07:23 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Vedran Miletić 2009-09-06 03:47:42 EDT
Any changes in current rawhide?
Comment 8 Vedran Miletić 2009-10-15 14:54:07 EDT
Reporter doesn't reply after more than a month, and this bug is too old to be relevant. It has probably been fixed in later releases of intel driver, when bugs that appeared during rewrite were ironed out. Closing.

Note You need to log in before you can comment on or make changes to this bug.