Bug 462667 - Can't rebuild PolicyKit from src.rpm
Can't rebuild PolicyKit from src.rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 21:36 EDT by John Ellson
Modified: 2008-09-18 10:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 10:55:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2008-09-17 21:36:36 EDT
Description of problem:
rebuild fails

Version-Release number of selected component (if applicable):
PolicyKit-0.9-2.fc10.src.rpm 

How reproducible:
100%

Steps to Reproduce:
1.rpmbuild --rebuild PolicyKit-0.9-2.fc10.src.rpm 
2.
3.
  
Actual results:
make[3]: Entering directory `/home/ellson/rpmbuild/BUILD/PolicyKit-0.9/doc/man'
/usr/bin/xsltproc -nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl polkit-auth.xml
I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"
cannot parse http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
make[3]: *** [polkit-auth.1] Error 4
make[3]: Leaving directory `/home/ellson/rpmbuild/BUILD/PolicyKit-0.9/doc/man'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/ellson/rpmbuild/BUILD/PolicyKit-0.9/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ellson/rpmbuild/BUILD/PolicyKit-0.9'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.UkNVOt (%build)


Expected results:
working local builds

Additional info:
Comment 1 Matthias Clasen 2008-09-18 10:26:30 EDT
Your docbook installation is hosed
Comment 2 John Ellson 2008-09-18 10:55:00 EDT
OK, Thanks.  I did a:
    yum reinstall docbook-dtds docbook-simple docbook-utils docbook-slides docbook-utils-pdf docbook-style-xsl docbook-style-dsssl

and the problem has gone.

Note You need to log in before you can comment on or make changes to this bug.