Bug 462670 - PDF: footnotes do not appear when inside itemized or ordered lists
PDF: footnotes do not appear when inside itemized or ordered lists
Status: CLOSED WONTFIX
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Michael Hideo
: Documentation
: 473013 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-18 01:04 EDT by Murray McAllister
Modified: 2015-01-04 17:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 05:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Murray McAllister 2008-09-18 01:04:11 EDT
Description of problem:
footnotes do not appear in PDF when they are inside itemized or ordered lists. 


Version-Release number of selected component (if applicable):
* Red Hat Enterprise Linux Client release 5.2 (Tikanga)
* publican-0.37-0.el5
* fop-0.95-0.2.beta1.rh1.el5
* saxon-6.5.5-1jpp.3.el5
* java-1.5.0-sun-1.5.0.15-1jpp.2.el5
* evince-0.6.0-8.el5
* Firefox 3.0.1 <http://www.mozilla.com/en-US/>

How reproducible:
Always.

Steps to Reproduce:
Create a document with the following:

<section>
<title>
<para>
Hi <footnote><para>this footnote is not in a list</para></footnote>
</para>

<itemizedlist>
<listitem>
<para>
Hi <footnote><para>this is in a list</para></footnote>
</para>
</listitem>
</itemizedlist>

<orderedlist>
<listitem>
<para>
Hi <footnote><para>this is in a list</para></footnote>
</para>
</listitem>
</orderedlist>
  
Actual results:
Footnote for "this footnote is not in a list" appears. There are no footnotes for "this is in a list".

Expected results:
Can has footnote.

Additional info:

* works as expected in HTML and HTML-single (and is strict XHTML 1.0).

* docbook (footnote in a list) is valid according to "/usr/share/publican/xsl/docbook.dtd.xml".
Comment 1 Jeff Fearn 2008-09-18 05:19:11 EDT
This is a known bug in FOP.

https://issues.apache.org/bugzilla/show_bug.cgi?id=37579
Comment 2 Jeff Fearn 2008-11-25 22:38:49 EST
*** Bug 473013 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.