Bug 462701 - NetworkManager-0.7.0-0.11.svn4022.fc9 and onboot devices
NetworkManager-0.7.0-0.11.svn4022.fc9 and onboot devices
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-18 09:48 EDT by Thomas J. Baker
Modified: 2009-02-14 15:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-14 15:14:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages showing nm failure (69.25 KB, text/plain)
2008-10-07 10:21 EDT, Thomas J. Baker
no flags Details

  None (edit)
Description Thomas J. Baker 2008-09-18 09:48:42 EDT
Updated to NetworkManager-0.7.0-0.11.svn4022.fc9 from updates-testing and my dhcp assigned static ip address stopped working at boot and while logged out. After logging in it comes up. This is a yp machine and it needs the network all the time. Reverting to NetworkManager-0.7.0-0.9.4.svn3675.fc9 fixes the problem. 

I think the pertinent error message is this:

Sep 18 08:38:13 raptor NetworkManager: <WARN>  system_settings_get_unmanaged_devices_cb(): system_settings_get_unmanaged_devices_cb: Error getting unmanaged devices from the system settings service: (4) Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Sep 18 08:38:13 raptor NetworkManager: <WARN>  list_connections_cb(): Couldn't retrieve connections: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken..


I notice in koji that there's a newer NM for F10 that may address the problem but it won't build under F9 due to dbus requirements that F9 doesn't provide.
Comment 1 Orion Poplawski 2008-09-29 17:04:16 EDT
I had thought this might be a SELinux issue, but get the same result in permissive mode.
Comment 2 Thomas J. Baker 2008-09-30 17:59:38 EDT
I continue to have this problem with the update that got pushed to Fedora 9. My eth1 interface has a dhcp assigned static address that I want up all the time as this is a yp machine. With onboot=yes and nm_controlled=yes, it doesn't work as described in comment #1. I had to switch to nm_controlled=no for things to work more correctly (autofs needs to be restarted, a services order thing, I guess).
Comment 3 Dan Williams 2008-10-01 09:55:26 EDT
Thomas: the autofs thing should be handled by /etc/NetworkManager/dispatcher.d/05-autofs, which reloads autofs when your connections change.

Could you attach your /etc/sysconfig/network-scripts/ifcfg-* files so I can try to reproduce your issue?
Comment 4 Thomas J. Baker 2008-10-01 10:11:38 EDT
This is my ifcfg-eth1, obfuscated:

# Intel Corporation 82545GM Gigabit Ethernet Controller
DEVICE=eth1
BOOTPROTO=dhcp
HWADDR=<hwaddr>
ONBOOT=yes
DHCP_HOSTNAME=<hostname>
DNS1=<dns1>
DNS2=<dns2>
SEARCH=<search>
NM_CONTROLLED=no
TYPE=Ethernet
USERCTL=no
PEERDNS=yes
IPV6INIT=no

Prior to the update, I had nm_controlled=yes but had to change it to get better results. How is it supposed to work? Can an interface by nm_controlled but be up all the time or should it not be nm_controlled if its supposed to be up all the time?
Comment 5 Orion Poplawski 2008-10-02 13:06:31 EDT
This seems to be a problem that appears with multiple interfaces.  I'm seeing problems when it is eth1 I want to be brought up and not eth0.  Systems with one interface appear to be working.
Comment 6 Dan Williams 2008-10-02 16:02:03 EDT
What are your particular symptoms Orion?  Have you MAC-locked both connection with HWADDR for both?
Comment 7 Orion Poplawski 2008-10-02 16:34:58 EDT
# 3Com Corporation 3c905C-TX/TX-M [Tornado]
DEVICE=eth0
HWADDR=00:06:5B:D6:C1:C4
ONBOOT=no

# 3Com Corporation 3c905C-TX/TX-M [Tornado]
DEVICE=eth1
BOOTPROTO=dhcp
ONBOOT=yes
HWADDR=00:06:5b:e8:5d:7f

(SELinux is in permissive mode, so ignore the avc)

Oct  2 14:25:27 orizaba NetworkManager: <info>  starting...
Oct  2 14:25:27 orizaba NetworkManager: <WARN>  nm_generic_enable_loopback(): error -17 returned from rtnl_addr_add():#012Sucess#012
Oct  2 14:25:27 orizaba NetworkManager: <info>  Found radio killswitch /org/freedesktop/Hal/devices/dell_wlan_switch
Oct  2 14:25:27 orizaba NetworkManager: <info>  eth1: driver is '3c59x'.
Oct  2 14:25:27 orizaba NetworkManager: <info>  Found new Ethernet device 'eth1'.
Oct  2 14:25:27 orizaba NetworkManager: <info>  (eth1): exported as /org/freedesktop/Hal/devices/net_00_06_5b_e8_5d_7f
Oct  2 14:25:27 orizaba NetworkManager: <info>  eth0: driver is '3c59x'.
Oct  2 14:25:27 orizaba NetworkManager: <info>  Found new Ethernet device 'eth0'.
Oct  2 14:25:27 orizaba NetworkManager: <info>  (eth0): exported as /org/freedesktop/Hal/devices/net_00_06_5b_d6_c1_c4
Oct  2 14:25:27 orizaba NetworkManager: <info>  Trying to start the supplicant...
Oct  2 14:25:27 orizaba NetworkManager: <info>  Trying to start the system settings daemon...
Oct  2 14:25:27 orizaba kernel: type=1400 audit(1222979127.799:3): avc:  denied  { read write } for  pid=1971 comm="wpa_supplicant" path="socket:[6202]" dev=sockfs ino=6202 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tclass=tcp_socket
Oct  2 14:25:28 orizaba nm-system-settings: Loaded plugin ifcfg-fedora: (c) 2007 - 2008 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
Oct  2 14:25:28 orizaba nm-system-settings:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-eth1 ...
Oct  2 14:25:28 orizaba NetworkManager: <WARN>  killswitch_getpower_reply(): Error getting killswitch power: dellWirelessCtl returned 4.
Oct  2 14:25:28 orizaba nm-system-settings:    ifcfg-fedora:     read connection 'System eth1'
Oct  2 14:25:28 orizaba nm-system-settings:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
Oct  2 14:25:29 orizaba acpid: client connected from 2011[0:0]
Oct  2 14:25:29 orizaba kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
Oct  2 14:25:30 orizaba kernel: [drm] Initialized drm 1.1.0 20060810
Oct  2 14:25:30 orizaba kernel: [drm] Initialized radeon 1.29.0 20080528 on minor 0
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth1): device state change: 1 -> 2
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth1): bringing up device.
Oct  2 14:25:31 orizaba kernel: eth1:  setting full-duplex.
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth1): preparing device.
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth1): deactivating device.
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth1): carrier now ON (device state 2)
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth1): device state change: 2 -> 3
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth0): device state change: 1 -> 2
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth0): bringing up device.
Oct  2 14:25:31 orizaba kernel: eth0:  setting half-duplex.
Oct  2 14:25:31 orizaba kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth0): preparing device.
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth0): deactivating device.
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth0): carrier now ON (device state 2)
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth0): device state change: 2 -> 3
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth0): carrier now OFF (device state 3)
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth0): device state change: 3 -> 2
Oct  2 14:25:31 orizaba NetworkManager: <info>  (eth0): deactivating device.
Oct  2 14:25:32 orizaba avahi-daemon[1849]: Registering new address record for fe80::206:5bff:fee8:5d7f on eth1.*.
Oct  2 14:25:53 orizaba NetworkManager: <WARN>  system_settings_get_unmanaged_devices_cb(): system_settings_get_unmanaged_devices_cb: Error getting unmanaged devices from the system settings service: (4) Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Oct  2 14:25:53 orizaba NetworkManager: <WARN>  list_connections_cb(): Couldn't retrieve connections: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken..
Comment 8 Thomas J. Baker 2008-10-07 09:55:29 EDT
I'm now running NetworkManager-0.7.0-0.11.svn4022.4.fc9.x86_64, I've switched back to nm_controlled for all devices but am still having problems. At initial boot, the network doesn't come up which causes a cascade of problems. I'll attach the boot log showing the NM errrors. After the system boots, if I restart NetworkManager, then ypbind, then reload autofs, things seem to work OK.
Comment 9 Thomas J. Baker 2008-10-07 10:21:32 EDT
Created attachment 319643 [details]
/var/log/messages showing nm failure
Comment 10 Orion Poplawski 2008-10-07 12:19:25 EDT
NM 0.7.0-0.11.svn4022.4.fc9 (possibly in combination with other updates) is working for me, so I'm getting off this bug.  Thomas seems to be having dbus issues.
Comment 11 Dan Williams 2008-10-10 10:47:51 EDT
Thomas, looks like NM is getting kicked off the bus after DHCP, which I've seen once or twice but haven't been able to track down yet.  That should be a separate bug.

Also, are you running SELinux in enforcing mode Thomas?
Comment 12 Thomas J. Baker 2008-10-10 11:17:09 EDT
Yes, selinux enforcing is on. I can turn it off but I'm first going to try reboot/relabel. I do see some NM related denials in my logs:

[root@raptor audit]# grep -i networkmanager *
audit.log.2:type=ANOM_ABEND msg=audit(1210776764.104:44): auid=4294967295 uid=0 gid=0 ses=4294967295 subj=system_u:system_r:NetworkManager_t:s0 pid=2693 comm="NetworkManager" sig=6
audit.log.2:type=AVC msg=audit(1212066191.166:5): avc:  denied  { getattr } for  pid=2697 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=363 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
audit.log.2:type=SYSCALL msg=audit(1212066191.166:5): arch=c000003e syscall=4 success=no exit=-13 a0=3d8be5bce5 a1=7fff3f46bad0 a2=7fff3f46bad0 a3=318b567a70 items=0 ppid=1 pid=2697 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)
audit.log.2:type=AVC msg=audit(1212157718.063:5): avc:  denied  { getattr } for  pid=2724 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=363 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
audit.log.2:type=SYSCALL msg=audit(1212157718.063:5): arch=c000003e syscall=4 success=no exit=-13 a0=3d8be5bce5 a1=7fff877acc20 a2=7fff877acc20 a3=318b567a70 items=0 ppid=1 pid=2724 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)
audit.log.2:type=AVC msg=audit(1212410399.087:5): avc:  denied  { getattr } for  pid=2691 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=363 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
audit.log.2:type=SYSCALL msg=audit(1212410399.087:5): arch=c000003e syscall=4 success=no exit=-13 a0=3d8be5bce5 a1=7fff806a9b20 a2=7fff806a9b20 a3=318b567a70 items=0 ppid=1 pid=2691 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)
audit.log.2:type=AVC msg=audit(1212493734.964:5): avc:  denied  { getattr } for  pid=2760 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=363 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
audit.log.2:type=SYSCALL msg=audit(1212493734.964:5): arch=c000003e syscall=4 success=no exit=-13 a0=3d8be5bce5 a1=7fffc27e2c50 a2=7fffc27e2c50 a3=318b567a70 items=0 ppid=1 pid=2760 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)
audit.log.2:type=AVC msg=audit(1212496208.590:5): avc:  denied  { getattr } for  pid=2690 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=363 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
audit.log.2:type=SYSCALL msg=audit(1212496208.590:5): arch=c000003e syscall=4 success=no exit=-13 a0=3d8be5bce5 a1=7fff322ea760 a2=7fff322ea760 a3=318b567a70 items=0 ppid=1 pid=2690 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)
audit.log.2:type=AVC msg=audit(1212693256.925:5): avc:  denied  { getattr } for  pid=2686 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=363 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
audit.log.2:type=SYSCALL msg=audit(1212693256.925:5): arch=c000003e syscall=4 success=no exit=-13 a0=3d8be5bce5 a1=7fffeb2806f0 a2=7fffeb2806f0 a3=318b567a70 items=0 ppid=1 pid=2686 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)
audit.log.2:type=AVC msg=audit(1213362425.485:5): avc:  denied  { getattr } for  pid=2665 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=365 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
audit.log.2:type=SYSCALL msg=audit(1213362425.485:5): arch=c000003e syscall=4 success=no exit=-13 a0=3d8be5bce5 a1=7fffabfb4420 a2=7fffabfb4420 a3=318b567a70 items=0 ppid=1 pid=2665 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)
audit.log.2:type=AVC msg=audit(1213816804.331:5): avc:  denied  { getattr } for  pid=2652 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=366 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
audit.log.2:type=SYSCALL msg=audit(1213816804.331:5): arch=c000003e syscall=4 success=no exit=-13 a0=7f5ea6aebce5 a1=7fffaf64dac0 a2=7fffaf64dac0 a3=318b567a70 items=0 ppid=1 pid=2652 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)
audit.log.2:type=AVC msg=audit(1214253568.578:5): avc:  denied  { getattr } for  pid=2673 comm="nm-system-setti" path="/dev/root" dev=tmpfs ino=365 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
audit.log.2:type=SYSCALL msg=audit(1214253568.578:5): arch=c000003e syscall=4 success=no exit=-13 a0=345865bce5 a1=7fffea1fa670 a2=7fffea1fa670 a3=318b567a70 items=0 ppid=1 pid=2673 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null)
[root@raptor audit]#
Comment 13 Dan Williams 2008-10-13 15:05:40 EDT
So if the nm-system-settings service can't start, then NM isn't going to know that your devices aren't supposed to be managed by NM.  We'll need a policy update here I think.
Comment 14 Dan Williams 2008-10-19 22:58:58 EDT
What selinux-policy package version do you have installed?
Comment 15 Thomas J. Baker 2008-10-20 08:44:11 EDT
raptor> rpm -qa | grep selinux
selinux-policy-3.3.1-99.fc9.noarch
selinux-policy-devel-3.3.1-99.fc9.noarch
libselinux-2.0.67-4.fc9.x86_64
libselinux-python-2.0.67-4.fc9.x86_64
libselinux-2.0.67-4.fc9.i386
selinux-policy-targeted-3.3.1-99.fc9.noarch
raptor>
Comment 16 Dan Williams 2009-02-14 15:14:28 EST
This should be fixed in latest F9 policy updates; please reopen if it's not.  Latest policy should be 3.3.1-121.fc9

Note You need to log in before you can comment on or make changes to this bug.