Bug 462822 - switchspell.so incorrectly marked execstack
switchspell.so incorrectly marked execstack
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: purple-plugin_pack (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Ignacio Vazquez-Abrams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 03:03 EDT by Benjamin Lewis
Modified: 2008-12-02 20:17 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 20:10:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Lewis 2008-09-19 03:03:14 EDT
Description of problem:
The switchspell.so module is incorrectly marked as requiring an executable stack

Version-Release number of selected component (if applicable):
purple-plugin_pack-pidgin-2.3.0-1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. yum install purple-plugin_pack-pidgin
2. load pidgin
3. notice AVC denial
  
Actual results:
There is an AVC denial from SELinux (if the "execstack" bool is set) and the module does not load (all others do, however)

Expected results:
No denial, module loads and SElinux and friends are happy

Additional info:
The library does not need an executable stack and so has been marked in error
Comment 1 Fedora Update System 2008-10-09 09:21:41 EDT
purple-plugin_pack-2.4.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/purple-plugin_pack-2.4.0-1.fc9
Comment 2 Fedora Update System 2008-10-09 09:21:43 EDT
purple-plugin_pack-2.4.0-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/purple-plugin_pack-2.4.0-1.fc8
Comment 3 Fedora Update System 2008-10-15 22:01:13 EDT
purple-plugin_pack-2.4.0-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update purple-plugin_pack'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8781
Comment 4 Fedora Update System 2008-10-15 22:06:00 EDT
purple-plugin_pack-2.4.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update purple-plugin_pack'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8821
Comment 5 Fedora Update System 2008-12-02 20:10:44 EST
purple-plugin_pack-2.4.0-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-12-02 20:17:53 EST
purple-plugin_pack-2.4.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.