Bug 462927 - complete lock using VPN (raccoon)
complete lock using VPN (raccoon)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 15:16 EDT by Need Real Name
Modified: 2008-10-14 14:04 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.26.5-45.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 23:35:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-09-19 15:16:42 EDT
I am not sure when this started, but with kernel-2.6.26.3-29.fc9.i686
I get regular locks when stopping/starting VPN (using racoon).

I use the script below to establish VPN link.
The script starts OK.
then, when I ctl-C the script and start same script with different 
network parameters the computer sometimes (1 in 10 tries)
completely locks, even the keyboard keys caps-lock and num-lock 
do not change the keyboard lights.

I used Fedora 6 before - there was no such problem there.
I think this is a kernel problem. racoon is very unlikely to lock the system completely.

Extremely annoying problem.

P.S. vpn script
echo "flush; spdflush;
        spdadd $VIRTUAL_IP_ADDR/24 $RENOTE_NETW any
            -P out ipsec esp/tunnel/$LOCAL_PUBLIC_ADDR-$VSU_ADDR/require ;
        spdadd $RENOTE_NETW $VIRTUAL_IP_ADDR/24 any
            -P in ipsec esp/tunnel/$VSU_ADDR-$LOCAL_PUBLIC_ADDR/require ;" \
        | setkey -c

/sbin/route add -net $RENOTE_NETW gw $VIRTUAL_IP_ADDR
racoon -F -d -d -d
Comment 1 Chuck Ebbert 2008-09-21 13:53:58 EDT
I think this is fixed in 2.6.26.5. Please test 2.6.26.5-45 when it becomes available and report back.
Comment 2 Need Real Name 2008-09-21 14:27:35 EDT
I will try.
Comment 3 Need Real Name 2008-10-09 08:35:42 EDT
I did not have computer lock up since an update to
kernel-2.6.26.5-45.fc9.i686

Note You need to log in before you can comment on or make changes to this bug.