Bug 462969 - [LTC 6.0 FEAT] 201666:ZFCP Performance Statistics - blktrace (userspace part)
[LTC 6.0 FEAT] 201666:ZFCP Performance Statistics - blktrace (userspace part)
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
s390x All
medium Severity high
: rc
: ---
Assigned To: RHEL Product and Program Management
Daniel Riek
:
: 463575 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 18:11 EDT by IBM Bug Proxy
Modified: 2010-06-18 02:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 14:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-19 18:11:30 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:21 EDT
1. Feature Overview:
Feature Id:	[201666]
a. Name of Feature:	ZFCP Performance Statistics - blktrace (userspace part)
b. Feature Description
Adaptation of the platform agnostic parts of the zfcp statistics to the blktrace framework and
integration of these into the blktrace open source project.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Common Code
Delivery Mechanism: Request Red Hat development assistance
Category:	RAS
Request Type:	Package - Feature from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	blktrace-0.99.x

3. Business Case
Serviceability Improvements due to increasing Problem Determination Capabilities

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 IBM Bug Proxy 2008-09-22 05:30:22 EDT
Hi Emily,

the component should be blktrace:
http://git.kernel.dk/?p=blktrace.git;a=summary

IBM System z Developers have done 2 patches will are in progress for upstream
for blktrace, so till then, IBM will attach these patches to this Bugzilla so
that Red Hat applies them to the current blktrace version.

Thank you,
Gonzalo Muelas.
Comment 2 IBM Bug Proxy 2008-09-22 11:40:50 EDT
Hi Gonzalo, there is no blktrace component. I'll move this to distribution for
now as a new package request. Emily
Comment 4 Bill Nottingham 2008-10-02 16:08:44 EDT
*** Bug 463575 has been marked as a duplicate of this bug. ***
Comment 5 Eric Sandeen 2008-10-02 16:33:28 EDT
No attachments so far?  (see comment #1)

If they're upstream, pointers to the git commits would be fine.

Note also that blktrace is in EPEL for RHEL5 already.  I'd be happy to be sure the patches IBM needs make it to the EPEL package for now, as well (once they are upstream).

Thanks,
-Eric
Comment 6 IBM Bug Proxy 2008-10-13 03:10:32 EDT
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:03 EDT
Feature Id:	[201157]
a. Name of Feature:	ZFCP Performance Statistics - blktrace
Adaptation of the platform agnostic parts (if any) of the zfcp statistics to the blktrace framework
and integration of these into the blktrace open source project.


Arch Specificity: Purely Arch Specific Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Request Type:	Kernel - Enhancement from IBM
Sponsor Priority	2
f. Severity: Medium
g. Component Version Target:	2.6.25






*** This bug has been marked as a duplicate of 462969 ***
Comment 7 IBM Bug Proxy 2009-03-04 09:10:42 EST
The code for this feature is upstream accepted with blktrace 1.0.0

When RHEL 6 takes blktrace 1.0.0 or higher this feature is fulfilled
Comment 8 IBM Bug Proxy 2009-03-16 03:51:04 EDT
*** This bug has been marked as a duplicate of bug 48093 ***
Comment 9 IBM Bug Proxy 2009-03-16 03:51:20 EDT
*** Bug 47973 has been marked as a duplicate of this bug. ***
Comment 10 IBM Bug Proxy 2009-05-06 07:21:28 EDT
------- Comment From mgrf@de.ibm.com 2009-05-06 07:12 EDT-------
Hello Red Hat,

We recognized that the upstream revision level of blktrace did not change after accepted commits made it into blktrace.

To ensure the level of blktrace (1.0.0) and commits get included into RHEL 6 that are required to fulfill this feature request
here a list of required commits for reference:

Here's info on the blktrace version needed:
blktrace 1.0.0 with all patches up to January 22, which is (git commit ids):
cdc033a3e6615142697e99b6be43319b8b8233e9
e47ada103e028a691d296d09d0bc673a3af6a3dc
f3db34733e7c8a46e9e26305e424a3ecd49ac06d
d00dcee7f0d77f64c59ee47bfcf09809dad366ff
9638f3909854d936f4a55a48f787364abdbda71f
a22df989ded0fb438dcad77a08c59a1a16b6b849
7ae1d0bfcaaf46102fb747a4a21fcbe0a1887800
0f067275d74a96ca9d574e9912a60bfa81b4df97
ef02006b0131f298595b37afb07562ee50fae5cc
19cfaf3f4d8e53ce43cccd809676f8f2a40f0b34
b3ee499dd143aeaed311bf3bc6d14871168b6657
61165962f86cb2de0b163f6083bff5649f692e91
(end of patches up to January 22)

f547a39d32d514eb7bce82b955193b73e9828c85
(Tom Zanussi fix for race that bit us)

8d388c8ea6a58186bfdf7ca7fc4e1268eced8b14
b5f8804a588fffdea10a0cd46a36fc196acea9f2
(Martin's latest two patches)
Comment 11 Siddharth Nagar 2009-05-29 14:04:39 EDT
This is completed upstream and will be included in 6.0
Comment 12 IBM Bug Proxy 2010-06-18 02:50:04 EDT
------- Comment From mgrf@de.ibm.com 2010-06-18 02:36 EDT-------
This feature is verified with the following bug reported
Sev = high  - fix included - awaiting final verification
LTC 61860   -  RIT675503- ziomon: Remove check for ziorep_config availability

Set this feature to verified - expecting the fix verification not to fail :-).
Thx

Note You need to log in before you can comment on or make changes to this bug.