Bug 463002 - Rebuild of xbae package fails because of wrong %patch line in xbae.spec
Rebuild of xbae package fails because of wrong %patch line in xbae.spec
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xbae (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-20 08:27 EDT by Joachim Frieben
Modified: 2008-09-20 14:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-20 14:00:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2008-09-20 08:27:30 EDT
Description of problem:
Building of xbae-4.60.4-9.fc9 on a current "rawhide" system fails because
of an erroneous %patch line in xbae.spec

Version-Release number of selected component (if applicable):
xbae-4.60.4-9.fc9

How reproducible:
Always

Steps to Reproduce:
1. Execute 'rpmbuild --rebuild xbae-4.60.4-9.fc9.src.rpm
  
Actual results:
Build procedure aborts with the message
Installing xbae-4.60.4-9.fc9.src.rpm
 warning: InstallSourcePackage at: psm.c:248: Header V3 DSA signature:
 NOKEY, key ID 0b86274e
 warning: user mockbuild does not exist - using root
 warning: group mockbuild does not exist - using root
 warning: user mockbuild does not exist - using root
 warning: group mockbuild does not exist - using root
 warning: user mockbuild does not exist - using root
 warning: group mockbuild does not exist - using root
 warning: user mockbuild does not exist - using root
 warning: group mockbuild does not exist - using root
 error: %patch without corresponding "Patch:" tag

Expected results:
Package builds correctly.

Additional info:
After replacing

%prep
%setup -q
%patch -p1
%patch1 -p1 -b .multilib

by

%prep
%setup -q
%patch0 -p1
%patch1 -p1 -b .multilib

the package is rebuilt correctly.
Comment 1 Patrice Dumas 2008-09-20 14:00:42 EDT
Thanks, fixed and rebuilt.

Note You need to log in before you can comment on or make changes to this bug.