Bug 463119 - Update the vsftpd package due to fatal issue with Filezilla when SSL is used
Update the vsftpd package due to fatal issue with Filezilla when SSL is used
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Nagy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-21 18:32 EDT by Martin Nagy
Modified: 2016-07-26 19:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 18:34:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Nagy 2008-09-21 18:32:35 EDT
Cloning for F9.

+++ This bug was initially created as a clone of Bug #462317 +++

Description of problem:

Recent versions of FileZilla do not work with vsftpd when 'FTP over explicit SSL/TLS' is used to connect to the FTP server. The client gives the following error message:

  Status:	Server did not properly shut down TLS connection
  Error:	Could not read from transfer socket: ECONNABORTED - Connection aborted

According to the following pages:

  * http://trac.filezilla-project.org/ticket/3661
  * http://forum.filezilla-project.org/viewtopic.php?f=2&t=7688
  * http://vsftpd.beasts.org/

The issue is caused by the server, which does not seem to follow the standard way of closing the SSL connection.

This issue has been addressed in the 2.0.7 version of vsftpd.

Please update the package.

Affects both fedora releases 8 & 9 (and others possibly).


Version-Release number of selected component (if applicable):
vsftpd-2.0.5-20.fc8
vsftpd.2.0.6-4.fc9
Comment 1 Fedora Update System 2008-09-21 19:35:21 EDT
vsftpd-2.0.6-6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/vsftpd-2.0.6-6.fc9
Comment 2 Martin Nagy 2008-09-21 19:40:43 EDT
The vsftpd package with the fix was submitted to updates-testing. I'd appreciate if you could test it and then add karma if it works for you, so that it can move to the stable repository.
Comment 3 Fedora Update System 2008-09-24 20:13:49 EDT
vsftpd-2.0.6-6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vsftpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8260
Comment 4 Fedora Update System 2008-10-03 18:34:02 EDT
vsftpd-2.0.6-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.