Bug 463156 - using "iscsi ...." from ks without preceding iscsiname fails silently
using "iscsi ...." from ks without preceding iscsiname fails silently
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 07:49 EDT by Hans de Goede
Modified: 2009-02-13 03:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 03:04:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-09-22 07:49:58 EDT
When using a kickstart file for an iscsi install, if you put just an
iscsi --ipaddr=<foo>

Line in kickstart, anaconda won't pick up the iscsi volumes at ip-addr foo, because no initiator name is configured. But instead of complaining about this it continues silently until you try to use the iscsi disk and goes boom then.

It should ofcourse go boom as soon as it fails to successfully execute the iscsi command, or just choose a random initiator name as is done in interactive mode.

This is related to bug 461830, basicly we do not seem to throw an error if something goes wrong with iscsi ever, bad, very bad.
Comment 1 Hans de Goede 2008-09-22 07:50:34 EDT
Re-assigning to myself.
Comment 2 Bug Zapper 2008-11-25 22:10:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Hans de Goede 2009-02-13 03:04:01 EST
This is fixed in anaconda-11.5.0.17, which is now in rawhide, closing.

Note You need to log in before you can comment on or make changes to this bug.