Bug 463166 - crash with modesetting kernel
crash with modesetting kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 09:32 EDT by Matěj Cepl
Modified: 2008-12-02 16:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 16:03:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (17.40 KB, text/plain)
2008-09-22 09:32 EDT, Matěj Cepl
no flags Details
/var/log/dmesg (46.57 KB, text/plain)
2008-09-22 09:33 EDT, Matěj Cepl
no flags Details
/var/log/messages (1.82 MB, text/plain)
2008-09-22 09:37 EDT, Matěj Cepl
no flags Details
functional /var/log/Xorg.0.log (61.97 KB, text/plain)
2008-09-23 04:35 EDT, Matěj Cepl
no flags Details
stdout of dmesg (58.91 KB, text/plain)
2008-09-23 04:35 EDT, Matěj Cepl
no flags Details
/var/log/messages (7.55 MB, text/plain)
2008-09-23 04:40 EDT, Matěj Cepl
no flags Details
/var/log/Xorg.0.log (19.05 KB, text/plain)
2008-09-26 12:33 EDT, Matěj Cepl
no flags Details
/var/log/Xorg.0.log.old (64.48 KB, text/plain)
2008-09-26 12:33 EDT, Matěj Cepl
no flags Details
output of dmesg (66.86 KB, text/plain)
2008-09-26 12:34 EDT, Matěj Cepl
no flags Details
/etc/xorg.conf (852 bytes, text/plain)
2008-09-26 12:34 EDT, Matěj Cepl
no flags Details
/var/log/Xorg.0.log (18.57 KB, text/plain)
2008-10-01 10:18 EDT, Matěj Cepl
no flags Details
/var/log/dmesg (34.60 KB, text/plain)
2008-10-01 10:19 EDT, Matěj Cepl
no flags Details
the real and only /var/log/Xorg.0.log (30.40 KB, text/plain)
2008-10-03 07:44 EDT, Matěj Cepl
no flags Details
/var/log/dmesg (35.69 KB, text/plain)
2008-10-03 08:26 EDT, Matěj Cepl
no flags Details
stdout of dmesg (48.41 KB, text/plain)
2008-10-03 08:27 EDT, Matěj Cepl
no flags Details
right side of the screen isn't (196.03 KB, image/png)
2008-10-03 08:28 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-09-22 09:32:06 EDT
Created attachment 317357 [details]
/var/log/Xorg.0.log

Description of problem:
When starting computer WITHOUT nomodeset, I get constantly (apparently crashing) Xorg server, so I don't get gdm login.

When looking at the Xorg.0.log I see the last lines:

(EE) RADEON(0): Memory manager initialization to (0,0) (1408,0) failed

Fatal server error:
AddScreen/ScreenInit failed for driver 0

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.9.0-14.fc10.x86_64
kernel-2.6.27-0.337.rc6.git5.fc10.x86_64
xorg-x11-server-Xorg-1.5.0-6.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1.reboot computer with rhgb quiet
2.
3.
  
Actual results:
graphical startup and then crash

Expected results:
graphical startup and gdm login screen

Additional info:
Comment 1 Matěj Cepl 2008-09-22 09:33:49 EDT
Created attachment 317358 [details]
/var/log/dmesg
Comment 2 Matěj Cepl 2008-09-22 09:37:39 EDT
Created attachment 317359 [details]
/var/log/messages
Comment 3 Matěj Cepl 2008-09-22 09:38:22 EDT
BTW, I have no xorg.conf
Comment 4 Matěj Cepl 2008-09-23 04:35:26 EDT
Created attachment 317449 [details]
functional /var/log/Xorg.0.log

Following the advice on airlied's journal attaching the results of my attempt:

Functional Xorg.0.log
Comment 5 Matěj Cepl 2008-09-23 04:35:57 EDT
Created attachment 317450 [details]
stdout of dmesg
Comment 6 Matěj Cepl 2008-09-23 04:40:39 EDT
Created attachment 317451 [details]
/var/log/messages
Comment 7 Dave Airlie 2008-09-26 02:40:45 EDT
have you moved the /etc/xorg.conf aside yet?
Comment 8 Matěj Cepl 2008-09-26 12:33:31 EDT
Created attachment 317811 [details]
/var/log/Xorg.0.log
Comment 9 Matěj Cepl 2008-09-26 12:33:54 EDT
Created attachment 317812 [details]
/var/log/Xorg.0.log.old
Comment 10 Matěj Cepl 2008-09-26 12:34:23 EDT
Created attachment 317813 [details]
output of dmesg
Comment 11 Matěj Cepl 2008-09-26 12:34:47 EDT
Created attachment 317814 [details]
/etc/xorg.conf
Comment 12 Matěj Cepl 2008-10-01 10:18:31 EDT
Created attachment 318198 [details]
/var/log/Xorg.0.log

OK, now I swear to *deity* that I have no xorg.conf ;-)

total 84
drwxr-xr-x 2 root root 4096  6. zář 12.13 applnk
drwxr-xr-x 2 root root 4096 10. zář 03.09 fontpath.d
drwxr-xr-x 2 root root 4096 18. čec 19.22 fs
-rwxr-xr-x 1 root root 1052 10. zář 23.44 prefdm
drwxr-xr-x 2 root root 4096 18. čec 19.22 twm
lrwxrwxrwx 1 root root   18 23. říj  2007 X -> ../../usr/bin/Xorg
drwxr-xr-x 3 root root 4096 18. čec 19.22 xdm
drwxr-xr-x 4 root root 4096 30. srp 00.56 xinit
-rw-r--r-- 1 root root  547 25. srp 16.13 Xmodmap
-rw-r--r-- 1 root root 2044 30. zář 23.24 xorg.conf.zip
-rw-r--r-- 1 root root  493 25. srp 16.13 Xresources

It works perfectly in the text mode -- where I get a huge number of columns/rows -- but when switching to X, it crashes.
Comment 13 Matěj Cepl 2008-10-01 10:19:07 EDT
Created attachment 318199 [details]
/var/log/dmesg
Comment 14 Matěj Cepl 2008-10-03 07:44:35 EDT
Created attachment 319350 [details]
the real and only /var/log/Xorg.0.log

So, after really getting rid of all xorg.conf lying around my system (that trap is unbelievable), I got this. Xorg starts with modesetting, but Gnome session is totally frozen and Xorg is in unstoppable state (no idea, what's going on there). So I had to switch back to nomodeset, where I have severely broken X as well. Oh well.
Comment 15 Matěj Cepl 2008-10-03 08:26:54 EDT
Created attachment 319353 [details]
/var/log/dmesg
Comment 16 Matěj Cepl 2008-10-03 08:27:21 EDT
Created attachment 319354 [details]
stdout of dmesg
Comment 17 Matěj Cepl 2008-10-03 08:28:48 EDT
Created attachment 319355 [details]
right side of the screen isn't
Comment 18 Matěj Cepl 2008-10-03 16:22:40 EDT
Might be a duplicate of bug 464853, if I understand the description of the issue there.
Comment 19 Bug Zapper 2008-11-25 22:10:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Jóhann B. Guðmundsson 2008-12-01 06:36:38 EST
There have been bunch of bug fixes

Could you retest with the latest kernel 
( -132 at the time of this writing )

You can get the latest kernel build here
http://koji.fedoraproject.org/koji/buildinfo?buildID=72270 

And with the latest xorg-x11-drv-ati. 
( -60 at the time of this writing )

You can get the latest xorg-x11-drv-ati build here
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

And report back if it either improves or fixes this issue..

Thanks.
Comment 21 Matěj Cepl 2008-12-02 16:03:19 EST
I think this could be closed -- not reproducible anymore and my computer is substantially different anyway.

Note You need to log in before you can comment on or make changes to this bug.