Bug 463178 - [LTC 6.0 FEAT] 201680:Adjust Anaconda Swap recommendations to Linux on System z specifics
[LTC 6.0 FEAT] 201680:Adjust Anaconda Swap recommendations to Linux on System...
Status: CLOSED DUPLICATE of bug 466289
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
s390x All
medium Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
: Reopened
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2008-09-22 10:50 EDT by IBM Bug Proxy
Modified: 2009-09-16 11:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-16 11:02:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 10:50:51 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:21 EDT
1. Feature Overview:
Feature Id:	[201680]
a. Name of Feature:	Adjust Anaconda Swap recommendations to Linux on System z specifics
b. Feature Description
If the configured size of swap is less than the main memory (storage), anaconda shows an information
box stating that this may influence performance and asks whether the user wants to continue or
change the swap configuration. Additionally, the System z specific section 17.14.4 in the RHEL 5.1
Install Guide states rules of thumbs for swap size which seem to have been taken from the
description for the x86  architecture. However, in VM environments, rules for determining the swap
size are not as simple as on x86.
  1) The above mentioned anaconda info box should not appear on s390.
  2) The content of Section 17.14.4 of the RHEL 5.1 Install Guide should be replaced by: 
'Configuring efficient swap space for Linux on System z is a complex task. It very much depends on
the specific environment and should be tuned to the actual system load. Please see the following
resources for more information:
    * Chapter 7 on 'Linux swapping' of the IBM Redbook, Linux on IBM System z: Performance
Measurement and Tuning, IBM Form Number SG24-6926-01, ISBN 0738485586.
[http://www.redbooks.ibm.com/abstracts/sg246926.html]
    * topic 'Linux on System z performance' in the IBM Systems Information Center
[http://publib.boulder.ibm.com/infocenter/systems/index.jsp?topic=/liaag/lcon_Linux_on_System_z_performance.htm]
 
    * webpage on IBM z/VM Performance Considerations for Linux Guests
[http://www.vm.ibm.com/perf/tips/linuxper.html]'

The corresponding architecture specific installation documentation should be updated accordingly.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Both
Affects Installer: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:	Installation
Request Type:	Installer - Enhancement from Distributor
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	n/a

3. Business Case
These changes will improve the installation experience for customers by making the installation
workflow more usable and efficient, which will result in an improvement of the customer satisfaction.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-01 16:34:49 EDT
There's nothing in that recommendation that doesn't apply to any architecture - the need for swap is complex based on the system load no matter what you're running.

Ergo, while we may want to change the defaults in that dialog, I don't think we want to completely redo it just for one architecture (especially to refer to other documentation not shipped with the OS.)
Comment 2 IBM Bug Proxy 2008-10-08 14:30:42 EDT
(In reply to comment #4)
> ------- Comment From notting@redhat.com 2008-10-01 16:34:49 EDT-------
> There's nothing in that recommendation that doesn't apply to any architecture -
> the need for swap is complex based on the system load no matter what you're
> running.
>
> Ergo, while we may want to change the defaults in that dialog, I don't think we
> want to completely redo it just for one architecture (especially to refer to
> other documentation not shipped with the OS.)

This feature request consists of 2 parts: 1) anaconda and 2) documentation.

1) When the user configures less swap space than main memory, the following dialog box pops up:

???????????????????????????????????????????????????????????????????????????????????? Partitioning Warning ????????????????????????????????????????????????????????????????????????????????????
???                 ???                                        ???                 ???
???        Device   ??? The following warnings exist with      ???  Mount Point    ???
??? VG VolGroup00   ??? your requested partition scheme.       ???               ??? ???
??? LV LogVol00     ???                                        ???  /            ??? ???
??? LV LogVolSwap   ??? You have allocated less swap space     ???               ??? ???
??? /dev/dasda      ??? (512M) than available RAM (1008M) on   ???               ??? ???
???   dasda1        ??? your system.  This could negatively    ???  /boot        ??? ???
???   dasda2        ??? impact performance.                    ???               ??? ???
???                 ???                                        ???               ??? ???
???                 ??? Would you like to continue with your   ???               ??? ???
???                 ??? requested partitioning scheme?         ???               ??? ???
???                 ???                                        ???               ??? ???
???                 ???       ?????????????????????            ??????????????????        ???                 ???
???      ?????????????????????   ??????       ??? Yes ???            ??? No ???        ??? ????????????????????????        ???
???      ??? New ???   ??????       ?????????????????????            ??????????????????        ??? ??? Back ???        ???
???      ?????????????????????   ??????                                        ??? ????????????????????????        ???
???                 ???                                        ???                 ???
???                 ??????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????                 ???
?????????????????????????????????????????????????????????                                          ???????????????????????????????????????????????????

This also happens for smaller z/VM guests with only 512MB of main memory and e.g. configuring 492MB of swap space.

The problem here is, that the dialog implies the user would need at least as much swap space as main memory. This is misleading and might result in erroneous user choice during configuration and in turn user frustration. Especially on System z, where a z/VM guest or LPAR image might have several gigabytes of main memory, we do not want to imply that the user should configure at least that much swap space.

Therefore, we would like this dialog box not to appear on s390 (or at least not with the current content implying misleading configuration hints). This is just a simple architecture dependent ifdef and no complete redo. We do not intend to modify any dialog defaults nor reference documentation in the dialog.

2) In the architecture dependent parts of the installation guide, section 17.4.4 [1] for System z recommends the same rules of thumb as for x86 in section 4.18.4 [2]. Those rules hardly apply for System z and are hence misleading.

Therefore, we suggest replacing the current content (or at least the misleading rules of thumb for calculating the amount of swap space by equation) of section 17.4.4. This part of the documentation is already architecture dependent anyway and should match the corresponding architecture as well as possible. Other section(s) of the install guide such as 21.2.4 [3] or 22.6 [4] already contain references to URLs external to the document itself, so referencing very helpful existing documentation for swap sizing on System z in the install guide seems possible. The redbook might even be shipped as PDF on the DVD with the OS.

[1]http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Installation_Guide/s2-diskpartrecommend-s390.html
[2]http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Installation_Guide/s2-diskpartrecommend-x86.html
[3]http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Installation_Guide/ch21s02s04.html
[4]http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Installation_Guide/s1-s390info-addnetdevice.html
Comment 3 Bill Nottingham 2008-10-08 14:34:14 EDT
(In reply to comment #2)
> The problem here is, that the dialog implies the user would need at least as
> much swap space as main memory. This is misleading and might result in
> erroneous user choice during configuration and in turn user frustration.
> Especially on System z, where a z/VM guest or LPAR image might have several
> gigabytes of main memory, we do not want to imply that the user should
> configure at least that much swap space.

There's *nothing* architecture-specific about this (after all, most other
architectures have at least several gigabytes of main memory.) Ergo,
ifdefing out the dialog for s390 makes no sense.

> 2) In the architecture dependent parts of the installation guide, section
> 17.4.4 [1] for System z recommends the same rules of thumb as for x86 in
> section 4.18.4 [2]. Those rules hardly apply for System z and are hence
> misleading.

I've yet to see why they are wrong for s390 in a way that they
wouldn't be wrong for other architectures.
Comment 4 IBM Bug Proxy 2008-10-10 08:40:43 EDT
(In reply to comment #6)
> ------- Comment From notting@redhat.com 2008-10-08 14:34:14 EDT-------
> (In reply to comment #2)
> > Especially on System z, where a z/VM guest or LPAR image might have several
> > gigabytes of main memory, we do not want to imply that the user should
> > configure at least that much swap space.
>
> There's *nothing* architecture-specific about this (after all, most other
> architectures have at least several gigabytes of main memory.) Ergo,
> ifdefing out the dialog for s390 makes no sense.

You are right in saying that other architectures nowadays also have gigabytes of main memory. However, on System z it is not just one z/VM guest or LPAR image having that much memory but hundreds or tens thereof respectively due to massive virtualization not (yet) being used that aggressively on other architectures.

> > 2) In the architecture dependent parts of the installation guide, section
> > 17.4.4 [1] for System z recommends the same rules of thumb as for x86 in
> > section 4.18.4 [2]. Those rules hardly apply for System z and are hence
> > misleading.
>
> I've yet to see why they are wrong for s390 in a way that they
> wouldn't be wrong for other architectures.

I don't know details about swap size recommendations for other architectures, but for System z they fill more than the entire Chapter 7 on 'Linux swapping' of the IBM Redbook [1] since a lot of factors have to be taken into account including massive virtualization with many guests. Please read this chapter and see how it does not match the current corresponding section of the RHEL installation guide.

Especially one part directly contradicts:
"The suggestion that swap space should be twice the memory size of a Linux machine should not apply to a z/VM Linux guest." [1],sec.7.8,p.95

[1] Linux on IBM System z: Performance Measurement and Tuning, IBM Form Number SG24-6926-01, ISBN 0738485586. [http://www.redbooks.ibm.com/abstracts/sg246926.html]
Comment 5 Bill Nottingham 2008-10-10 09:59:35 EDT
We're currently working on changing the guidelines overall - see bug 466289 for details. I suspect we'll work towards something architecture-neutral that makes more sense, as 2xmemory really doesn't make sense anywhere these days.
Comment 6 IBM Bug Proxy 2008-11-04 12:03:39 EST
Pursuing further in https://bugzilla.redhat.com/show_bug.cgi?id=466289 as mentioned in comment #8 by notting@redhat.com.
Comment 7 John Jarvis 2009-09-16 11:02:32 EDT
reopening and dup'ing to BZ 466289 so IBM gets updates.
Comment 8 John Jarvis 2009-09-16 11:02:53 EDT

*** This bug has been marked as a duplicate of bug 466289 ***

Note You need to log in before you can comment on or make changes to this bug.