Bug 463209 - Installer prints "chown: `root:apache` : invalid group"
Installer prints "chown: `root:apache` : invalid group"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Steve Salevan
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2008-09-22 12:00 EDT by Justin Sherrill
Modified: 2009-09-10 16:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:28:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-09-22 12:00:29 EDT
In 5.3 run the installer on a fresh system and you get the message 

Installer prints "chown: `root:apache` : invalid group"

Not sure what it's trying to chown, but apache hasn't been installed yet, so that group wouldn't exist.
Comment 1 Justin Sherrill 2008-09-22 12:01:02 EDT
Note, i was using iso Satellite-5.3.0-RHEL5-re20080919.1-i386-embedded-oracle.iso
Comment 2 Devan Goodwin 2008-09-24 16:12:07 EDT
Fixed in git revision bd321d5fa17cc3794eba3c56ff065acb12329124 and svn revision 177262.

Removed the permissions setting. Instead updated the proxy packages to use the
correct permissions for /var/log/rhn. About 4 packages claim ownership to the
dir and suspect these were setting it wrong. Turns out they're not supposed to
be getting installed on a satellite anyhow so hopefully directory permissions
will be healthily set by the spacewalk-backend rpms.

Waiting for next respin to mark on_qa.
Comment 3 Steve Salevan 2008-12-12 14:36:03 EST
Installer does not print this message upon the installation of the re20081128.0-i386 ISO.  Moving to VERIFIED.
Comment 4 Brandon Perkins 2009-09-10 16:28:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.