Bug 463230 - RFE: CRM #1375564 'Cyrus database backup and checkpoint features not well documented'
RFE: CRM #1375564 'Cyrus database backup and checkpoint features not well doc...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cyrus-imapd (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Michal Hlavinka
BaseOS QE
: Documentation
Depends On: 246473
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 12:56 EDT by Daniel Riek
Modified: 2013-04-12 15:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 14:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1120 normal SHIPPED_LIVE cyrus-imapd bug fix update 2009-06-22 14:16:17 EDT

  None (edit)
Comment 1 Ivana Varekova 2008-11-13 07:28:57 EST
cyrus.conf.5 is part of cyrus-imapd package -> changing the component name.
Comment 4 RHEL Product and Program Management 2009-03-12 10:38:42 EDT
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 5 Michal Hlavinka 2009-03-13 08:54:00 EDT
I'm still trying to get some answers, but there are no sources. Actual result:

> o Listing of database files "checkpointed"

Checkpointed are these databases (under dbdir=/var/lib/imap):
quotas.db
tls_sessions.db
deliver.db
statuschache.db
annotations.db
mailboxes.db
ptclient/ptscache.db

> o Description of checkpoint format
> - "ls /var/lib/imap" suggest two sets of checkpoint database are retained.

I don't completely understand this question??? AFAIK there are two types of databases (depends on backends).


> - Description of checkpoint configuration options, if any, to control checkpoint sets

only configuration option for checkpoint is interval of checkpoints.

/etc/cyrus.conf : checkpoint ..... period=30


> o Checkpointed image backup requirements

Not exactly sure what you mean here. AFAIK you only need the database in
db.backup{1,2} - it's rotated.

> o Appropriate cross-references to utilities used to determine
> database corrution requiring recovery proceadure

I'm not sure there really exists such a thing despite the list archives. Cyrus runs a -r when it starts to verify the database. So it seems, it's regular job when starting cyrus. /etc/cyrus.conf

START {
  # do not delete this entry!
  recover       cmd="ctl_cyrusdb -r"


> o Appropriate recovery procedure when invocation 
> with "-r" vs. "-r -x' is required. 

I think -x is needed only for debugging purposes. I wasn't able to find/get any info about this. Only someone used '-r -x' when only '-r' hanged.
Comment 14 errata-xmlrpc 2009-06-22 14:16:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1120.html

Note You need to log in before you can comment on or make changes to this bug.