Bug 463282 - [LTC 6.0 FEAT] 201167:Linux to add Call Home data
[LTC 6.0 FEAT] 201167:Linux to add Call Home data
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.0
Assigned To: Dan Horák
Yulia Kopkova
: FutureFeature, OtherQA
Depends On: 486222
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-22 16:11 EDT by IBM Bug Proxy
Modified: 2010-11-15 09:44 EST (History)
7 users (show)

See Also:
Fixed In Version: s390utils-1.8.2-3.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:44:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Initscript (2.14 KB, text/plain)
2009-09-22 05:38 EDT, Dan Horák
no flags Details
config file (111 bytes, text/plain)
2009-09-22 05:39 EDT, Dan Horák
no flags Details

  None (edit)
Description IBM Bug Proxy 2008-09-22 16:11:03 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:24 EDT
1. Feature Overview:
Feature Id:	[201167]
a. Name of Feature:	Linux to add Call Home data
b. Feature Description
The sclp_cpi sysfs interface allows the association of a set of descriptive data called 'Control
Program Identification' (CPI) with an operating system instance (currently LPAR only). This
information is not persistent and has to be set once per IPL. CPI data will be visible at the
HMC/SE. CPI information is also referred to as 'Call Home data' in some contexts.  CPI information
could previously be set by loading the sclp_cpi kernel module. This item implements a new CPI
interface in sysfs which complements the existing one. The new interface was included in Linux 
kernel 2.6.25.  These sysfs-attributes can be used to specify the CPI information locally:
/sys/firmware/cpi/system_name   String: arbitrary, user-specified system name (e.g. LPAR12) 
/sys/firmware/cpi/sysplex_name String: arbitrary, user-specified sysplex name (e.g. SYSPLEX1)   
/sys/firmware/cpi/system_type    	String: operating system type identifier - must be 'LINUX '  
/sys/firmware/cpi/system_level Hex: operating system version information, should be 
0x0000000000aabbcc, where aa=kernel version, bb=kernel patch level, cc=kernel sublevel.  Example:
Linux kernel 2.6.26 -> 0x000000000002061a  
Once all attributes are filled, write an arbitrary string to this attribute to finalize the data
(i.e. to send it to the SE):  
/sys/firmware/cpi/system_set    Distributor installation/setup tools need to be changed to provide
users with the ability:  'to specify whether they want to set this data  'to enter the actual data
values (only 'system_name' and 'sysplex_name', since 'system_type' and 'system_level' should be set
automaticly by the system)    

Using a distributor specific mechanism (e.g. init script), this information needs to be passed to
the sclp_cpi  sysfs interface during IPL, depending on the configuration.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Core Kernel: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:	zSeries
Request Type:	Driver - Feature from IBM
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	n/a

3. Business Case
RAS Improvement by decreasing mean time to resolve problems in case of System Failure.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 IBM Bug Proxy 2009-02-06 07:30:34 EST
Hello Red Hat,

update description for installer/tools:
Description:
The sclp_cpi sysfs interface allows the association of a set of descriptive data called "Control Program Identification" (CPI) with an operating system instance (currently LPAR only). This information is not persistent and has to be set once per IPL. CPI data will be visible at the HMC/SE. CPI information is also referred to as "Call Home data" in some contexts.

The following support is required:
- During each boot, the distribution uses the CPI sysfs interface to automatically set and send CPI information to the SE.
- The user can turn the automatic setting of CPI information at boot time on and off. With no change by the user, this setting is on.
- The user can specify custom values for the "system_name" and "sysplex_name" attributes of the CPI information set at boot time. With no change by the user, these attributes are set to empty strings.
- The "system_type" attribute set during boot must be "LINUX".
- The "system_level" attribute set during boot must be the version of the currently running Linux kernel.

More details under:
???Control program identification??? in latest version of Device Drivers, Features, and Commands at: http://www.ibm.com/developerworks/linux/linux390/development_documentation.html

Thank you for your support,
Gonzalo Muelas Serrano.
Comment 2 IBM Bug Proxy 2009-02-19 08:30:36 EST
This feature is the required installer tools part for the kernel feature:

51753   -  [LTC 6.0 FEAT] Linux to add Call Home data - Kernel Interface [201801]
Comment 3 IBM Bug Proxy 2009-02-19 08:40:28 EST
That is:
51753  - RHBZ 486222  [LTC 6.0 FEAT] Linux to add Call Home data - Kernel Interface [201801]
Comment 4 Dan Horák 2009-05-21 05:50:35 EDT
It can resolved in a multi-distro manner with one config file in /etc/sysconfig and one initscript. I will talk to the s390utils developers about this idea.
Comment 8 Dan Horák 2009-09-22 05:38:39 EDT
Created attachment 362044 [details]
Initscript
Comment 9 Dan Horák 2009-09-22 05:39:02 EDT
Created attachment 362046 [details]
config file
Comment 12 releng-rhel@redhat.com 2009-11-12 02:12:45 EST
Fixed in 's390utils-1.8.2-3.el6'. 's390utils-1.8.2-3.el6' included in compose 'RHEL6.0-20091111.0'.
Moving to ON_QA.
Comment 13 Siddharth Nagar 2010-01-03 17:50:56 EST
IBM:

Can you please confirm that the initscript+config file option resolution provided in comment #8 and comment #9 satisfy this request?
Comment 14 IBM Bug Proxy 2010-01-11 05:30:55 EST
------- Comment From gmuelas@de.ibm.com 2010-01-11 05:29 EDT-------
Yes, we confirm it. Pending test to close it...
Comment 15 IBM Bug Proxy 2010-07-23 05:40:43 EDT
------- Comment From mgrf@de.ibm.com 2010-07-23 05:38 EDT-------
This feature is verified on R6 snapshots
Set feature to "verified"  Thx
Comment 16 releng-rhel@redhat.com 2010-11-15 09:44:17 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.