Bug 463288 - [LTC 6.0 FEAT] 201297:Scalable IPC tunables
[LTC 6.0 FEAT] 201297:Scalable IPC tunables
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
medium Severity medium
: alpha
: 6.0
Assigned To: Kevin W Monroe
Martin Jenner
: FutureFeature, Reopened
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2008-09-22 16:30 EDT by IBM Bug Proxy
Modified: 2010-05-07 17:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 18:29:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 16:30:36 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:25 EDT
1. Feature Overview:
Feature Id:	[201297]
a. Name of Feature:	Scalable IPC tunables
b. Feature Description
In 2.6.24 the IPC id allocation system was reworked to use IDR and replace the array based id
allocator with a dynamic allocator.  Instead of simple, static maximums then for the IPC resource
limits (ie: numbers of shm areas, msg queues and semaphores), a systems initial defaults for these
maximums can be scaled to reflect total system memory without adversely impacting smaller systems. 
This comes 'for free' with a current kernel, but the distro may desire documentation for the system
administrator and test coverage.

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64
ppc64

Arch Specificity: Purely Common Code
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	3rd party code
g. Component Version Target:	2.6.25

3. Business Case
Ease of use and improved performance for autonomic middleware; no sysadmin involvement needed to get
optimal configuration.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Badari Pulavarty, badari@us.ibm.com
Matt Helsley, matthltc@us.ibm.com

IBM Manager:
Pat Gaughen, gaughen@us.ibm.com
Comment 1 Bill Nottingham 2008-10-01 17:04:04 EDT
RHEL 6 will ship with a kernel later than 2.6.25, so this should not be an issue.
Comment 2 Bill Nottingham 2008-10-01 22:09:10 EDT
The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 3 IBM Bug Proxy 2009-03-03 16:21:04 EST
Patches upstream since 2.6.25
No kernel configs required.

The following (already default in mainline) proc values are needed to enable the feature:

/proc/sys/kernel/auto_msgmni contains "1"

There are no libraries required for this feature.
Comment 4 Kevin W Monroe 2009-09-23 18:29:23 EDT
Closing - included in Red Hat Enterprise Linux 6.
Comment 5 IBM Bug Proxy 2010-05-07 17:11:13 EDT
------- Comment From matthltc@us.ibm.com 2010-05-07 17:08 EDT-------
verified for RHEL 6

Note You need to log in before you can comment on or make changes to this bug.