This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 463304 - [LTC 6.0 FEAT] 201381:New inventory module in librtas
[LTC 6.0 FEAT] 201381:New inventory module in librtas
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: librtas (Show other bugs)
6.0
ppc64 All
medium Severity medium
: alpha
: 6.0
Assigned To: Roman Rakus
Release Test Team
: FutureFeature
Depends On:
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-22 17:00 EDT by IBM Bug Proxy
Modified: 2014-01-12 19:07 EST (History)
6 users (show)

See Also:
Fixed In Version: librtas-1.3.4-1.fc12
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 17:10:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 48156 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-09-22 17:00:29 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:27 EDT
1. Feature Overview:
Feature Id:	[201381]
a. Name of Feature:	libofdt package
b. Feature Description
The libofdt package provides an interface to the Open Firmware Device Tree (OFDT) on Power systems.
 This is useful for user-space service and productivity applications that wish to retrieve system
inventory.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Arch Specific Code
Delivery Mechanism: Direct from community
Category:	Power Servicability
Request Type:	Package - New
d. Upstream Acceptance:	Not Started
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	n/a

3. Business Case
libofdt will be used by a number of DLPAR and service packages.  Providing a common mechanism for
these applications to retrieve inventory will improve the quality of those applications, abstract
away the complexity of the device tree, and help to showcase an advantage of Power systems.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Mike Wortman, wortman@us.ibm.com, 512-838-8582

Technical contact(s):
Michael Strosaker, strosake@us.ibm.com
Manish Ahuja, mahuja@us.ibm.com

IBM Manager:
Larry Kessler, lkessler@us.ibm.com
Comment 1 IBM Bug Proxy 2008-09-24 16:41:15 EDT
This will not be a new package, but will be a component of the already-existing
librtas package (since it will mostly be used by applications that already use
librtas anyways).  As the new component will be useful only on Power-based
systems, librtas is a very logical place to include it.

The code is still under development.  When finished, it will be delivered in an
updated version of the librtas package, dowloadable from the usual community
site:  http://librtas.ozlabs.org/.
Comment 2 Bill Nottingham 2008-10-02 11:22:06 EDT
Setting in NEEDINFO, waiting on code release.
Comment 3 IBM Bug Proxy 2009-03-03 15:00:32 EST
This package has been open sourced and provided at:

http://sourceforge.net/project/showfiles.php?group_id=44427&package_id=92526&release_id=219638


Please disregard that last comment - was intended for 48180
Comment 4 IBM Bug Proxy 2009-03-03 19:10:31 EST
The new librtas, version 1.3.4 with the open firmware device tree library, is now provided at:

https://sourceforge.net/project/showfiles.php?group_id=44427&package_id=312572&release_id=665596
Comment 5 IBM Bug Proxy 2009-03-30 12:50:48 EDT
------- Comment From nfont@austin.ibm.com 2009-03-30 12:40 EDT-------
(In reply to comment #11)
> The new librtas, version 1.3.4 with the open firmware device tree library, is
> now provided at:
>
> https://sourceforge.net/project/showfiles.php?group_id=44427&package_id=312572&release_id=665596
>

The official repository of librtas is librtas.ozlabs.org, please pull from there.  I do not know when, how often or who updates the code posted to sourceforge.
Comment 6 Roman Rakus 2009-04-10 04:32:00 EDT
Since libofdt isn't included in librtas (official from librtas.ozlabs.org) setting in NEEDINFO.
And one minor question - Isn't better to do it as separate package?
Comment 7 Roman Rakus 2009-10-01 08:36:30 EDT
Now it is in librtas. Fixed in rawhide librtas-1.3.4-1.fc12
Comment 8 IBM Bug Proxy 2009-12-03 07:00:28 EST
------- Comment From rxaviers@br.ibm.com 2009-12-03 06:57 EDT-------
Hi Roman,

Do you know when is it expected to be in RHEL6? Currently (alpha2 20091124.2), we have librtas-1.3.3-5.el6.ppc64.rpm, which doesn't include libofdt yet.

Thank you,
Comment 9 Roman Rakus 2009-12-03 11:00:28 EST
IIRC it will be in Beta 1, which will be on RHN March 8th.
Comment 10 releng-rhel@redhat.com 2009-12-16 16:50:59 EST
Fixed in 'librtas-1.3.4-1.fc12'. 'librtas-1.3.4-1.1.el6' included in compose 'RHEL6.0-20091216.nightly'.
Moving to ON_QA.
Comment 11 Alexander Todorov 2010-07-13 11:18:37 EDT
RHEL6.0-20100707.4 contains librtas-1.3.4-2.el6 whic hincludes 
/usr/lib64/libofdt.so.1.3.4. Moving to VERIFIED.
Comment 12 releng-rhel@redhat.com 2010-11-10 17:10:16 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.