Bug 463311 - [LTC 6.0 FEAT] 201382:libvpd C interface
[LTC 6.0 FEAT] 201382:libvpd C interface
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ppc64-utils (Show other bugs)
6.0
ppc64 All
medium Severity medium
: alpha
: 6.0
Assigned To: Roman Rakus
Release Test Team
: FutureFeature
Depends On: 526718
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-22 17:10 EDT by IBM Bug Proxy
Modified: 2014-01-12 19:07 EST (History)
9 users (show)

See Also:
Fixed In Version: ppc64-utils-0.14-8.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 526718 (view as bug list)
Environment:
Last Closed: 2010-11-10 17:14:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 17:10:57 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:27 EDT
1. Feature Overview:
Feature Id:	[201382]
a. Name of Feature:	libvpd C interface
b. Feature Description
Addition of a C interface to libvpd, to allow applications written in C to access Vital Product
Data.  The initial version of libvpd only included a C++ interface.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Common Code
Delivery Mechanism: Direct from community
Category:	Power Servicability
Request Type:	Package - Feature from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	n/a

3. Business Case
Enabling more applications the ability to retrieve Vital Product Data will showcase a
differentiating feature of Power systems.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Mike Wortman, wortman@us.ibm.com, 512-838-8582

Technical contact(s):
Michael Strosaker, strosake@us.ibm.com
Michael Mason, masonmik@us.ibm.com

IBM Manager:
Larry Kessler, lkessler@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 11:32:06 EDT
Putting in NEEDINFO pending upstream code release.
Comment 2 IBM Bug Proxy 2008-10-08 19:31:00 EDT
We need to get the lsvpd and libvpd packages in RHEL 6 before we can satisfy this request for a C interface.  They are in Fedora, but not RHEL.  What's the process for getting them in RHEL?
Comment 3 Bill Nottingham 2008-10-09 10:37:48 EDT
Filing this request is a good start. Are these completely ppc64-specific, or do they work on x/zSeries as well?
Comment 4 IBM Bug Proxy 2008-10-09 18:10:25 EDT
(In reply to comment #7)
> ------- Comment From notting@redhat.com 2008-10-09 10:37:48 EDT-------
> Filing this request is a good start. Are these completely ppc64-specific, or do
> they work on x/zSeries as well?
>

They are primarily intended for IBM ppc64 systems, though a subset of the features can be built for xSeries.  I'm not aware that it's ever been built or run on zSeries.
Comment 6 Roman Rakus 2009-10-01 10:29:48 EDT
I have created (cloned thus bug) new bug #526718 for libvpd. I can fix this bug right after #526718 will be fixed.
Comment 8 John Jarvis 2010-01-15 11:08:02 EST
IBM is signed up to test and provide feedback
Comment 9 John Jarvis 2010-01-19 11:03:44 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux major release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux major release.   
While it is a goal to include this enhancement in the next major release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next major release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 10 Roman Rakus 2010-01-22 11:33:13 EST
ppc64-utils now requires libvpd, thus this should be fixed in ppc64-utils-0.14-8.el6
Comment 12 Alexander Todorov 2010-07-13 11:14:18 EDT
ppc64-utils-0.14-9.el6 and libvpd-2.1.1-3.el6 are present in the 0707.4 tree.
ppc64-utils requires libvpd. Moving to VERIFIED.
Comment 13 releng-rhel@redhat.com 2010-11-10 17:14:50 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.