Bug 463317 - [LTC 6.0 FEAT] 201573:Update GDB to version 6.9 or later
[LTC 6.0 FEAT] 201573:Update GDB to version 6.9 or later
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdb (Show other bugs)
6.0
ppc64 All
medium Severity medium
: alpha
: 6.0
Assigned To: Jan Kratochvil
Petr Muller
: FutureFeature, OtherQA
: 463318 463834 (view as bug list)
Depends On:
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-22 17:30 EDT by IBM Bug Proxy
Modified: 2016-09-19 22:04 EDT (History)
7 users (show)

See Also:
Fixed In Version: gdb-7.0.1-23.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:07:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 17:30:43 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:28 EDT
1. Feature Overview:
Feature Id:	[201573]
a. Name of Feature:	Update GDB to version 6.9 or later
b. Feature Description
GDB version 6.9 (or what version after 6.8 turns out to be called) and later will include Python
scripting support which interests us, as well as the async and multi-thread improvements currently
being developed by CodeSourcery.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Both
Affects Toolchain: Yes
Delivery Mechanism: Direct from community
Category:	Toolchain
Request Type:	Package - Update Version
d. Upstream Acceptance:	In Progress
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	3rd party code
g. Component Version Target:	GDB 6.9+

3. Business Case
The Python scripting benefits are described in its own feature request (devtrack 201572), and the
async and multi-thread improvements will be a win for development and RAS of enterprise middleware
applications, which employ heavy multithreading.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Thiago Jung Bauermann, thiagoju@br.ibm.com

IBM Manager:
Alexander Johnson, acjohnso@us.ibm.com
Comment 1 IBM Bug Proxy 2009-03-02 21:01:03 EST
The features described in the business case are present in the Archer code which will ship in Fedora 11, so no patch to be attached here too.
Comment 4 John Jarvis 2009-12-14 09:50:13 EST
IBM is signed up to test and provide feedback.
Comment 6 John Jarvis 2009-12-18 14:41:12 EST
*** Bug 463318 has been marked as a duplicate of this bug. ***
Comment 7 John Jarvis 2009-12-18 14:41:47 EST
*** Bug 463834 has been marked as a duplicate of this bug. ***
Comment 8 IBM Bug Proxy 2009-12-18 14:43:47 EST
Decimal Floating Point support shipped in GDB version 6.8, and is also present in the Archer code which will be used in Fedora 11. Am I right in my assuption that there's no need to post a patch here?
Comment 9 John Jarvis 2009-12-18 14:47:08 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux major release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux major release.   
While it is a goal to include this enhancement in the next major release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next major release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 10 Jan Kratochvil 2010-01-03 12:17:58 EST
(In reply to comment #8)
> Decimal Floating Point support shipped in GDB version 6.8, and is also present
> in the Archer code which will be used in Fedora 11. Am I right in my assuption
> that there's no need to post a patch here?  

Decimal floating point has been verified as working in:
Bug 463834 Comment 4
Comment 11 IBM Bug Proxy 2010-01-11 11:41:00 EST
I opened a specific feature for python because I thought it could give better coverage if we need something for python which for some reason doesn't get into the next gdb version (even though we are striving to get it all upstream). If you think this is not necessary (since 463317 mentions python as well), this can be duped.

Python scripting support is present in the Archer code going into Fedora 11, so I believe I don't need to post patches here...
Comment 16 IBM Bug Proxy 2010-05-07 14:51:48 EDT
------- Comment From bauerman@br.ibm.com 2010-05-07 14:48 EDT-------
Hi,

Verified the feature by checking that RHEL6 includes GDB 7.1.
Comment 17 IBM Bug Proxy 2010-05-07 14:52:16 EDT
------- Comment From bauerman@br.ibm.com 2010-05-07 14:45 EDT-------

Just verified the feature by checking that RHEL6 contains GDB version 7.1, which includes the DFP support.
Comment 19 releng-rhel@redhat.com 2010-07-02 15:07:32 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.
Comment 20 IBM Bug Proxy 2010-11-15 15:25:11 EST
------- Comment From bauerman@br.ibm.com 2010-05-07 14:50 EDT-------

Verified the feature by checking that RHEL6 includes GDB 7.1, which has Python scripting support, plus the archer patch, which adds additional Python hooks.

Note You need to log in before you can comment on or make changes to this bug.