Bug 463319 - [LTC 6.0 FEAT] 201569:Update to latest version of ipmitool
[LTC 6.0 FEAT] 201569:Update to latest version of ipmitool
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipmitool (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Jan Safranek
Martin Cermak
: FutureFeature
Depends On:
Blocks: 356741 511888 511889 511890 511891 512362 512363 512364 554559
  Show dependency treegraph
 
Reported: 2008-09-22 17:30 EDT by IBM Bug Proxy
Modified: 2010-07-02 16:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: ipmitool-1.8.11-4.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:51:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for bug that causes SOL sessions to randomly drop (2.81 KB, text/plain)
2008-12-11 14:10 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2008-09-22 17:30:57 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:28 EDT
1. Feature Overview:
Feature Id:	[201569]
a. Name of Feature:	Update to latest version of ipmitool
b. Feature Description
A new version of ipmitool will be released soon to address the following issues:
- critical bug fixes from previous update.
- documentation update, man page re-write to include all the new functionality and commands in     
 ipmitool
- new command options, e.g. watchdog timer shut-off
- updates to OEM Message catalog with new platform messages.
- SDR/FRU collection fixes/enhancements

2. Feature Details:
Sponsor:	xSeries
Architectures:
x86
x86_64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	xSeries
Request Type:	Driver - Feature from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	1.8.10

3. Business Case
Update ipmitool to the latest release for increased reliability, enhanced support for new IBM
platforms, features needed by customers.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

IBM Manager:
Deneen T. Dock, deneen@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 11:41:18 EDT
This is filed against OpenIPMI, but OpenIPMI has no ipmitool binary.
Comment 2 Chris McDermott 2008-10-02 13:49:59 EDT
In RHEL5 ipmitool was part of the OpenIPMI-tools RPM. I didn't see an OpenIPMI-tools Component in the drop-down menu. Is there another component we should be using?
Comment 3 Bill Nottingham 2008-10-02 13:56:29 EDT
No, I'm just looking in the wrong place. Sorry about that.

Current Fedora releases have OpenIPMI-2.0.14, so this shouldn't be a problem.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 4 IBM Bug Proxy 2008-10-03 12:19:57 EDT
in Red Hat CVS Tree Marking as Accepted
Comment 5 Jan Safranek 2008-10-22 08:38:58 EDT
Just a note: ipmitool now has separate package (ipmitool-1.8.10-2.fc10) and is no longer part of OpenIPMI package.
Comment 6 IBM Bug Proxy 2008-12-11 14:10:54 EST
Created attachment 326652 [details]
Fix for bug that causes SOL sessions to randomly drop



The attached patch fixes a bug that's been lurking for a long time,
first in the lan plugin and then propagated to the lanplus plugin.  If
there are multiple entries on the ipmi_req_entries linked list, and
ipmi_req_remove_entry() is called to remove the first entry, all
additional entries are also removed from the list, causing problems when
those requests complete.  This condition is rather rare but seems to
occur more frequently under high latency conditions on the network.
Comment 7 Jan Safranek 2008-12-15 09:09:45 EST
reopening the bug because of comment #6 needs to be evaluated...

IBM, is the patch upstream?
Comment 8 IBM Bug Proxy 2008-12-15 13:40:58 EST
Patch has been submitted upstream, not committed yet.

http://sourceforge.net/mailarchive/message.php?msg_name=1229021277.25123.70.camel%40w-rmach2.beaverton.ibm.com
Comment 10 John Jarvis 2009-12-16 22:36:48 EST
flipping component to ipmitool based on comment 5
Comment 11 Jan Safranek 2010-01-06 04:45:45 EST
ipmitool-1.8.11 is the latest available upstream version. I don't think there will be new one before RHEL6 Beta.
Comment 16 Martin Cermak 2010-04-13 09:52:11 EDT
=> VERIFIED
Comment 17 IBM Bug Proxy 2010-05-26 17:41:22 EDT
------- Comment From bigmach@us.ibm.com 2010-05-26 17:33 EDT-------
I have verified ipmitool is present and operational.  There was no new upstream version so RHEL6 has ipmitool 1.8.11
Comment 18 releng-rhel@redhat.com 2010-07-02 16:51:28 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.