Bug 46333 - Bad locale file in glibc 2.2.3-12
Summary: Bad locale file in glibc 2.2.3-12
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-27 20:58 UTC by hjl
Modified: 2016-11-24 15:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 19:47:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hjl 2001-06-27 20:58:13 UTC
When I rebuilt glibc 2.2.3-12, I got

locales/zh_HK:85: LC_TIME: unknown character in field `abday'
locales/zh_HK:86: LC_TIME: unknown character in field `abday'
locales/zh_HK:86: LC_TIME: unknown character in field `abday'
locales/zh_HK:87: LC_TIME: unknown character in field `abday'
locales/zh_HK:87: LC_TIME: unknown character in field `abday'
locales/zh_HK:88: LC_TIME: unknown character in field `abday'
locales/zh_HK:91: LC_TIME: unknown character in field `day'
locales/zh_HK:91: LC_TIME: unknown character in field `day'
locales/zh_HK:92: LC_TIME: unknown character in field `day'
locales/zh_HK:92: LC_TIME: unknown character in field `day'
locales/zh_HK:93: LC_TIME: unknown character in field `day'
locales/zh_HK:93: LC_TIME: unknown character in field `day'
locales/zh_HK:94: LC_TIME: unknown character in field `day'
locales/zh_HK:97: LC_TIME: unknown character in field `abmon'
locales/zh_HK:97: LC_TIME: unknown character in field `abmon'
locales/zh_HK:98: LC_TIME: unknown character in field `abmon'
locales/zh_HK:98: LC_TIME: unknown character in field `abmon'
locales/zh_HK:99: LC_TIME: unknown character in field `abmon'
locales/zh_HK:99: LC_TIME: unknown character in field `abmon'
locales/zh_HK:100: LC_TIME: unknown character in field `abmon'
locales/zh_HK:100: LC_TIME: unknown character in field `abmon'
locales/zh_HK:101: LC_TIME: unknown character in field `abmon'
locales/zh_HK:101: LC_TIME: unknown character in field `abmon'
locales/zh_HK:102: LC_TIME: unknown character in field `abmon'
locales/zh_HK:102: LC_TIME: unknown character in field `abmon'
locales/zh_HK:105: LC_TIME: unknown character in field `mon'
locales/zh_HK:105: LC_TIME: unknown character in field `mon'
locales/zh_HK:106: LC_TIME: unknown character in field `mon'
locales/zh_HK:106: LC_TIME: unknown character in field `mon'
locales/zh_HK:107: LC_TIME: unknown character in field `mon'
locales/zh_HK:107: LC_TIME: unknown character in field `mon'
locales/zh_HK:108: LC_TIME: unknown character in field `mon'
locales/zh_HK:108: LC_TIME: unknown character in field `mon'
locales/zh_HK:109: LC_TIME: unknown character in field `mon'
locales/zh_HK:109: LC_TIME: unknown character in field `mon'
locales/zh_HK:110: LC_TIME: unknown character in field `mon'
locales/zh_HK:110: LC_TIME: unknown character in field `mon'
locales/zh_HK:113: LC_TIME: unknown character in field `am_pm'
locales/zh_HK:113: LC_TIME: unknown character in field `am_pm'
locales/zh_HK:119: LC_TIME: unknown character in field `d_t_fmt'
locales/zh_HK:124: LC_TIME: unknown character in field `d_fmt'
locales/zh_HK:129: LC_TIME: unknown character in field `t_fmt'
locales/zh_HK:146: LC_MESSAGES: unknown character in field `yesexpr'
locales/zh_HK:147: LC_MESSAGES: unknown character in field `noexpr'
locales/zh_HK:165: LC_NAME: unknown character in field `name_gen'
locales/zh_HK:166: LC_NAME: unknown character in field `name_mr'
locales/zh_HK:167: LC_NAME: unknown character in field `name_mrs'
locales/zh_HK:168: LC_NAME: unknown character in field `name_miss'
locales/zh_HK:169: LC_NAME: unknown character in field `name_ms'

Comment 1 Jakub Jelinek 2001-06-28 07:04:20 UTC
I know, that's why I fixed it and Ulrich commited the patch.
It is just that I did not want to rebuild glibc before beta1 once more
because of this.

Comment 2 hjl 2001-06-28 16:35:04 UTC
Which change in glibc fixes it?

Comment 3 Jakub Jelinek 2001-06-28 16:36:54 UTC
2001-06-25  Jakub Jelinek  <jakub@redhat.com>

        * SUPPORTED (zh_HK): Update character map name to BIG5-HKSCS.

Comment 4 Glen Foster 2001-07-13 19:47:37 UTC
This defect considered MUST-FIX for Fairfax gold-release.

Comment 5 Jakub Jelinek 2001-07-23 15:09:08 UTC
Fixed since glibc-2.2.3-13.


Note You need to log in before you can comment on or make changes to this bug.