Bug 463352 - Missing deps for xorg-x11-server-debuginfo
Missing deps for xorg-x11-server-debuginfo
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 21:05 EDT by Christopher Beland
Modified: 2014-01-21 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 22:19:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2008-09-22 21:05:22 EDT
I had trouble today upgrading to xorg-x11-server-Xorg-1.5.0-1.fc9.i386.  The underlying problem was that xorg-x11-server-debuginfo is missing some dependencies.  I removed it to allow a smooth upgrade.  For the record, when I do "yum install xorg-x11-server-debuginfo", I get the following errors: 

---> Package xorg-x11-server-debuginfo.i386 0:1.4.99.901-29.20080415.fc9 set to be updated
--> Processing Dependency: libxtrap.so for package: xorg-x11-server-debuginfo
--> Processing Dependency: libdri2.so for package: xorg-x11-server-debuginfo
--> Processing Dependency: libGLcore.so for package: xorg-x11-server-debuginfo
--> Finished Dependency Resolution
xorg-x11-server-debuginfo-1.4.99.901-29.20080415.fc9.i386 from fedora-debuginfo has depsolving problems
  --> Missing Dependency: libdri2.so is needed by package xorg-x11-server-debuginfo-1.4.99.901-29.20080415.fc9.i386 (fedora-debuginfo)
xorg-x11-server-debuginfo-1.4.99.901-29.20080415.fc9.i386 from fedora-debuginfo has depsolving problems
  --> Missing Dependency: libxtrap.so is needed by package xorg-x11-server-debuginfo-1.4.99.901-29.20080415.fc9.i386 (fedora-debuginfo)
xorg-x11-server-debuginfo-1.4.99.901-29.20080415.fc9.i386 from fedora-debuginfo has depsolving problems
  --> Missing Dependency: libGLcore.so is needed by package xorg-x11-server-debuginfo-1.4.99.901-29.20080415.fc9.i386 (fedora-debuginfo)
Error: Missing Dependency: libdri2.so is needed by package xorg-x11-server-debuginfo-1.4.99.901-29.20080415.fc9.i386 (fedora-debuginfo)
Error: Missing Dependency: libGLcore.so is needed by package xorg-x11-server-debuginfo-1.4.99.901-29.20080415.fc9.i386 (fedora-debuginfo)
Error: Missing Dependency: libxtrap.so is needed by package xorg-x11-server-debuginfo-1.4.99.901-29.20080415.fc9.i386 (fedora-debuginfo)
Comment 1 Adam Jackson 2008-09-24 17:32:38 EDT
Those DSOs went away in the new X server.  If the debuginfo is being updated in the same transaction, then the new debuginfo should not depend on those DSOs...

So I claim this is not my bug.  yum perhaps?
Comment 2 James Antill 2008-09-24 17:54:24 EDT
At a guess you don't have the *-debuginfo repos. enabled (probably due to the switch to the newkey repos.).
 So try with --enablerepos=\*-debuginfo ... or change the config. files
Comment 3 Christopher Beland 2008-09-24 20:55:59 EDT
Ah, you are correct.  When I enable updates-newkey-debuginfo, "yum install xorg-x11-server-debuginfo" works correctly.  I was expecting the new config files to configure themselves the same way as the old ones, but they were  configured to the default values.  Which is not a crazy thing to do for a one-time problem like that.

Note You need to log in before you can comment on or make changes to this bug.