Bug 463354 - FEAT: cpuscaling test should be run separately for each cpu
FEAT: cpuscaling test should be run separately for each cpu
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 21:54 EDT by Greg Nichols
Modified: 2014-03-25 20:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:57:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cpuscaling.py patch (15.54 KB, patch)
2008-09-23 12:49 EDT, Greg Nichols
no flags Details | Diff
cpuscaling.py patch (20.64 KB, patch)
2008-10-01 12:24 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2008-09-22 21:54:32 EDT
Description of problem:

The cpuscaling test should be run separately for each cpu.  It should
set governors and speeds for specific cpus, and set task affinity for 
the workload to the cpu under test.

Version-Release number of selected component (if applicable):

HTS 5.2 R18
Comment 1 Greg Nichols 2008-09-23 12:49:05 EDT
Created attachment 317490 [details]
cpuscaling.py patch 


This patch changes cpuscaling test planning to plan a separate test for each cpu.  The test is also changed to test a specific cpu, including the use of task affinity via taskset to insure that the workload is run on the intended cpu.
Comment 2 Greg Nichols 2008-10-01 12:24:35 EDT
Created attachment 318602 [details]
cpuscaling.py patch 


This revised patch changes the planning logic.   A test is scheduled for each cpu if ANY cpu reports can_throttle as True.
Comment 4 Yan Tian 2009-01-01 21:47:25 EST
Verified "hts plan" in hts-5.3-12 setup separately for each cpu, so could run separately by specifying device or UDI for each cpu.
Comment 6 errata-xmlrpc 2009-01-27 17:57:56 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.