Bug 463364 - Can't use "make defconfig" even "make menuconfig"
Can't use "make defconfig" even "make menuconfig"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Martin Jenner
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 22:54 EDT by Nick Cheng
Modified: 2008-10-02 05:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 08:36:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output of "make defconfig" (52.37 KB, application/octet-stream)
2008-09-24 21:50 EDT, Nick Cheng
no flags Details
The output of "make" (5.58 KB, application/octet-stream)
2008-09-24 21:51 EDT, Nick Cheng
no flags Details

  None (edit)
Description Nick Cheng 2008-09-22 22:54:48 EDT
Description of problem:
can't use "make defconfig" even "make menuconfig"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
After execution of "make defconfig", it will output "Can't find default configuration "arch/x86_64/defconfig"!"
Similarly, it will output "No rule to make target `init\main.o`, needed by `init/built-in.o`. Stop.", after execution of "make menuconfig" and sequential "make".
Expected results:


Additional info:
It also happens on RHEL4.5.
Comment 1 Prarit Bhargava 2008-09-23 10:54:02 EDT
1.  grab a source rpm
2.  install source rpm
3.  cd into SPECS dir
4.  execute rpmbuild -bp kernel.spec
5.  cd into BUILD/* dir
6.  execute make oldconfig

WORKSFORME.  NOTABUG.

P.
Comment 2 Nick Cheng 2008-09-24 02:07:00 EDT
Prarit,
My platform is SuperMicro motherboard,model PDSGE, with Intel Celeron D.
I follow the instruction as you suggest except that I indicate the target as i386 or i686 specific.
I always got stuck by arch/i386/mm/pageattr.c, because ther is `__etext' undeclared on line 98 and 133.
No matter what I execute "make defconfig" or "make menuconfig" or "make oldconfig", the outcome is the same.
For your information,

Thanks
Comment 3 Prarit Bhargava 2008-09-24 06:37:02 EDT
Nick, could you attach a full log of what you're doing and the output you're getting?

P.
Comment 4 Nick Cheng 2008-09-24 21:49:12 EDT
Prarit,
After downloading the kernel SRPM, I rebuild and then install it as you known.(This step is not agruable.) 
Sequentially, I execute "make defconfig" and its output is arrached log file.
Then I execute "make" and its output is attached log1 file.
Thanks,
Comment 5 Nick Cheng 2008-09-24 21:50:19 EDT
Created attachment 317645 [details]
The output of "make defconfig"
Comment 6 Nick Cheng 2008-09-24 21:51:20 EDT
Created attachment 317646 [details]
The output of "make"
Comment 7 Prarit Bhargava 2008-09-29 08:21:52 EDT
>Sequentially, I execute "make defconfig" and its output is arrached log file.
>Then I execute "make" and its output is attached log1 file.
>Thanks,

Please see comment #1, step 6.

Thanks,

P.
Comment 8 Nick Cheng 2008-09-29 09:38:16 EDT
You mean I just can only use "make oldconfig".
"make defconfig" is unworkable, right?
"make defconfig" has been a history?
Thanks,
Comment 9 Prarit Bhargava 2008-09-29 10:04:17 EDT
(In reply to comment #8)
> You mean I just can only use "make oldconfig".
> "make defconfig" is unworkable, right?
> "make defconfig" has been a history?
> Thanks,

To be honest, it's been a while since I've tried defconfig.  RH uses a custom .config -- these can be found in the toplevel dir, configs.

P.
Comment 10 Nick Cheng 2008-09-29 22:43:03 EDT
OK.
We are the RH-compatible HW vendor.
Now we get the source code for the chip provider to build the driver floppy.
Because the driver module is too big(over 2MB) to fit in the floppy, the chip vendor asks us to build under the kerenl building by "make defconfig" to reduce the size(I doubt it but it is the only way to do.).
Therefore, that is why I insist to use "make defconfig".
According to your professional experience, what is your comment on the size issue or how to make "make defconfig" work?
Thank you,
Comment 11 Prarit Bhargava 2008-09-30 08:33:35 EDT
(In reply to comment #10)
> OK.
> We are the RH-compatible HW vendor.
> Now we get the source code for the chip provider to build the driver floppy.

Ok.

> Because the driver module is too big(over 2MB) to fit in the floppy, the chip
> vendor asks us to build under the kerenl building by "make defconfig" to reduce
> the size(I doubt it but it is the only way to do.).

The vendor is wrong.  In RH source, do "make menuconfig", followed by make; make modules.

> Therefore, that is why I insist to use "make defconfig".

No.  You definitely do not want that.  "make defconfig" will grab a config file from arch/your_arch/configs.  That does not give you the correct config for RH.

> According to your professional experience, what is your comment on the size
> issue or how to make "make defconfig" work?

The vendor is probably giving you the best advice.

> Thank you,

P.
Comment 12 Prarit Bhargava 2008-09-30 08:36:40 EDT
A fairly comprehensive overview of how to build a custom kernel is here:

http://fedoraproject.org/wiki/Docs/CustomKernel

Note the section titled "Configure Kernel Options"

P.
Comment 13 Nick Cheng 2008-10-02 05:00:37 EDT
I have tried by the document.
It works for "make oldconfig" but still not work for "make defconfig".
I really need that kernel to build my small size driver module.
Any ideas?
Comment 14 Nick Cheng 2008-10-02 05:25:55 EDT
Prarit,
According to comment#11,(In reply to comment #11)
> (In reply to comment #10)
> > OK.
> > We are the RH-compatible HW vendor.
> > Now we get the source code for the chip provider to build the driver floppy.
> 
> Ok.
> 
> > Because the driver module is too big(over 2MB) to fit in the floppy, the chip
> > vendor asks us to build under the kerenl building by "make defconfig" to reduce
> > the size(I doubt it but it is the only way to do.).
> 
> The vendor is wrong.  In RH source, do "make menuconfig", followed by make;
> make modules.
> 
> > Therefore, that is why I insist to use "make defconfig".
> 
> No.  You definitely do not want that.  "make defconfig" will grab a config file
> from arch/your_arch/configs.  That does not give you the correct config for RH.
I made a diff for these two files and got the difference between them.
BTW, you mean the defconfig file is static and it will not be compatible to the HW platform or RH
> 
> > According to your professional experience, what is your comment on the size
> > issue or how to make "make defconfig" work?
> 
> The vendor is probably giving you the best advice.
Which part you mean, size issue?
> 
> > Thank you,
> 
> P.

Note You need to log in before you can comment on or make changes to this bug.