Bug 463367 - [LTC 6.0 FEAT] 201036:Application checkpoint/restart
[LTC 6.0 FEAT] 201036:Application checkpoint/restart
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Jesse Larrew
Red Hat Kernel QE team
: FutureFeature
Depends On:
Blocks: 356741 465490 554559
  Show dependency treegraph
 
Reported: 2008-09-22 23:10 EDT by IBM Bug Proxy
Modified: 2013-01-10 02:57 EST (History)
6 users (show)

See Also:
Fixed In Version: kernel-2.6.32-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:51:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 23:10:29 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:30 EDT
1. Feature Overview:
Feature Id:	[201036]
a. Name of Feature:	Application checkpoint/restart
b. Feature Description
IBM has a non-upstream checkpoint/restart application set (MetaCluster), but seeks to offer this
functionality in a community and distribution acceptable form.  Building on the community
containerization effort (virtualizing resources through namespaces) we will develop basic
checkpoint/restart functionality.  This work is incremental with a goal to have the major API's
defined and upstream in mid-2008, but the overall development continuing into 2009.

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64
ppc64

Arch Specificity: Both
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.28

3. Business Case
This advanced feature and the higher availability it brings enhance the value proposition of linux
for high end users.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Badari Pulavarty, badari@us.ibm.com
Serge Hallyn, sergeh@us.ibm.com

IBM Manager:
Pat Gaughen, gaughen@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 12:24:06 EDT
Do you have a link to the first sets of patches?
Comment 2 IBM Bug Proxy 2008-10-13 18:41:50 EDT
The latest version of the first set of actual checkpoint/restart patches can be found at:

http://lkml.org/lkml/2008/10/8/94

The freezer control group, which is also needed for checkpoint/restart, is in Andrew Morton's -mm tree, and (according to Andrew) likely to be pushed into 2.6.28.  The full patchset is 11 patches posted as two patchsets, the first 5 patches (see https://lists.linux-foundation.org/pipermail/containers/2008-August/012376.html ) and the second 6 patches (see https://lists.linux-foundation.org/pipermail/containers/2008-August/012481.html).

Please let me know if I should post tarballs of the patchsets.
Comment 3 Bill Nottingham 2008-10-13 21:03:43 EDT
Shouldn't be needed as of right now; thanks for the pointer.
Comment 4 IBM Bug Proxy 2008-10-22 13:40:43 EDT
This is just an update to point out that the freezer patchset is in Linus' tree.
Comment 5 IBM Bug Proxy 2009-02-06 10:42:08 EST
The following kernel config variable will need to be set to
enable the freezer, which we need for checkpoint/restart:

CONFIG_CGROUP_FREEZER=y
Comment 7 IBM Bug Proxy 2009-03-02 17:31:19 EST
Freezer is available since before 2.6.29.

To enable it, the kernel must be compiled with CONFIG_CGROUP_FREEZER=y
Comment 8 Bill Nottingham 2009-03-03 17:23:26 EST
The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 10 Mike Gahagan 2010-02-08 15:22:18 EST
I can confirm the freezer cgroup has been added to the 2.6.32 RHEL 6 kernels, is this the only functionality needed to satisfy this feature request?
Comment 11 IBM Bug Proxy 2010-05-04 15:50:50 EDT
------- Comment From sergeh@us.ibm.com 2010-05-04 15:47 EDT-------
Freezer functionality verified.
Comment 12 releng-rhel@redhat.com 2010-07-02 16:51:53 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.