Bug 463393 - [LTC 6.0 FEAT] 200303:ADTools Oprofile Java Profiling Enhancements
[LTC 6.0 FEAT] 200303:ADTools Oprofile Java Profiling Enhancements
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: oprofile (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.0
Assigned To: William Cohen
Petr Muller
: FutureFeature
Depends On: 606308
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-23 00:20 EDT by IBM Bug Proxy
Modified: 2016-09-19 22:04 EDT (History)
4 users (show)

See Also:
Fixed In Version: oprofile-0.9.6-4.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:18:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-23 00:20:22 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 17:35 EDT
1. Feature Overview:
Feature Id:	[200303]
a. Name of Feature:	ADTools  Oprofile Java Profiling Enhancements
b. Feature Description
Oprofile does currently only provide profiling for ELF Files. Therefore Java byte code applications
that are compiled at runtime can not be profiled with Oprofile. Oprofile does not recognize these
compiled classes and does only profiling for Java Compiler/JVM. But for analysis it is important to
know which java classes consume how much cpu time. Oprofile can be enabled to do Java class
profiling by using the information the JVM offers. The Java Virtual Machine provides information
about which class is currently executed.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390 native
s390 compat
s390x

Arch Specificity: Purely Arch Specific Code
Affects Toolchain: Yes
Delivery Mechanism: Direct from community
Category:	zSeries
Request Type:	Other
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	0.9.4 GAed: Oprofile pkg from  http://sourceforge.net/projects/oprofile/

3. Business Case
Enables to monitor/analyze java and system Performance. Allows service and customers to fine tune
Java performance to resolve performance bottlenecks and /or increase system performance and
therefore decrease TCO.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 IBM Bug Proxy 2009-03-02 06:20:52 EST
comes via upstream package, therefore no code attach to feature BZ
set to submitted
Comment 2 IBM Bug Proxy 2009-09-10 01:50:28 EDT
------- Comment From lxie@us.ibm.com 2009-09-10 01:49 EDT-------
Georg,

Should this be accepted? It was marked accepted in the devtrack.

- Linda

> comes via upstream package, therefore no code attach to feature BZ
> set to submitted
>
Comment 3 William Cohen 2009-09-23 11:14:07 EDT
OProfile 0.9.4 and newer have support for Java. The main thing is making sure that the package is built with support. For RHEL 5 some header files needed to be included so that OProfile could be built with the JVMTI support. JVMPI support has been deprecated for over 5 years and will not be support.

Is the existing RHEL-5u4 oprofile-0.9.4-11.el5 java jvmti support sufficient?

If JVMTI support on s390 is sufficient, then this can get a dev ack.
Comment 4 IBM Bug Proxy 2009-09-24 09:30:49 EDT
------- Comment From gmuelas@de.ibm.com 2009-09-24 09:27 EDT-------
(In reply to comment #7)
> OProfile 0.9.4 and newer have support for Java. The main thing is making sure
> that the package is built with support. For RHEL 5 some header files needed to
> be included so that OProfile could be built with the JVMTI support. JVMPI
> support has been deprecated for over 5 years and will not be support.
>
> Is the existing RHEL-5u4 oprofile-0.9.4-11.el5 java jvmti support sufficient?
>
> If JVMTI support on s390 is sufficient, then this can get a dev ack.
>

Yes, OProfile JIT support with JVMTI is sufficient.
Comment 7 IBM Bug Proxy 2010-06-21 09:31:36 EDT
------- Comment From mgrf@de.ibm.com 2010-06-21 09:26 EDT-------
Feature test results in bug report
RHBZ 606308 - oprofile-jit: libjvmti_oprofile.so is not built
that has been flagged DUP to
463223  - [LTC 6.0 FEAT] 200979:Java Support support for OProfile

1.)  Expect fix with with oprofile-0.9.6-6 -> hopefully in snap7

2.) with one issue still in work

===  from RHBZ 463223  ========
William Cohen      2010-06-07 12:09:41 EDT

I tracked the problem down to a missing "-a1" on the %setup. The
oprofile-0.9.6-6 has been built with the fix.

Still need to address the /usr/share/oprofile/stl.pat. The differs between ppc
and ppc64 (same also on s390). This file is part of the oprofile rpm, so one
might make the argument that only one version be installed. However, still
should avoid files that are differ due to arch in /usr/share.
Comment 8 IBM Bug Proxy 2010-08-02 04:00:42 EDT
------- Comment From mgrf@de.ibm.com 2010-08-02 03:50 EDT-------
This feature is verified on R6 snapshots
Set feature to "verified"  Thx
Comment 9 releng-rhel@redhat.com 2010-11-10 16:18:22 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.