Bug 463414 - [ml_IN] some GSUB conjunctions cursoring got failed
[ml_IN] some GSUB conjunctions cursoring got failed
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: fonts-indic (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Rahul Bhalerao
QE Internationalization Bugs
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 05:53 EDT by Jia Dong
Modified: 2010-10-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 08:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jia Dong 2008-09-23 05:53:17 EDT
Description of problem:

URL:http://focus.bne.redhat.com/I18N/IndicTC/lang/ml_IN/font/IndicFontTestCaseGSUB-Malayalam.html

#250 U+0D21 U+0D4D U+0D30 U+0D48 U+0D35 U+0D4D 
#251 U+0D05 U+0D2A U+0D4D U+0D21 U+0D47 U+0D31 U+0D4D U+0D31 U+0D4D 
#252 U+0D05 U+0D2A U+0D4D U+0D17 U+0D4D U+0D30 U+0D47 U+0D21 U+0D4D
#253 U+0D35 U+0D4D U+0D2F U+0D15 U+0D4D U+0D24 U+0D02
#254 U+0D07 U+0D28 U+0D4D U+200D U+0D38 U+0D4D U+0D31 U+0D4D U+0D31 U+0D4B  U+0D33 U+0D4D U+200D 

Left/right and delete cursoring failed in all above cases.
 
Version-Release number of selected component (if applicable):

RHEL-5.2-Client-x86_64  RHEL-5.2-Server-i386.

fonts version: fonts-malayalam-2.3.1-1.el5

How reproducible:

Everytime

Steps to Reproduce:
1.Put cursor into textbox of tested cases
2.Switch left and right button on letters 
3.Move cursor to ahead of the letters,and click delete button
  
Actual results:

    delete letters(delete cursoring)   cross letter(left/right cursoring)
#250      2 clicks                         2 clicks
#251      3 clicks                         3 clicks
#252      3 clicks                         3 clicks
#253      2 clicks                         2 clicks
#254      5 clicks                         5 clicks

Expected results:

  delete letters(delete cursoring)   cross letter(left/right cursoring)
#250      1 clicks                         1 clicks
#251      1 clicks                         1 clicks
#252      1 clicks                         1 clicks
#253      1 clicks                         1 clicks
#254      1 clicks                         1 clicks

Additional info:
#254 U+0D07 U+0D28 U+0D4D U+200D U+0D38 U+0D4D U+0D31 U+0D4D U+0D31 U+0D4B  U+0D33 U+0D4D U+200D

When clicking U+200D,it cannot type a letter which displays correctly.
Comment 1 Rahul Bhalerao 2008-09-23 08:53:24 EDT
There is no reason for delete, or cursoring to complete with one click for these test cases. These are not single syllables, but words comprising of multiple syllables. I am not sure about the necessity of these test cases either. But certainly the cursor behavior is not a bug here.
Comment 2 Lawrence Lim 2008-09-24 02:01:10 EDT
Ah..those special case at the bottom of the page. Can we have the language maintainer let us know the preferred number of clicks? (the string is made of how many chars)
Comment 3 Jia Dong 2008-09-24 08:19:58 EDT
Some additional information:

In ml_IN cases,all backspace clicks on cases can match the number of unicode.


e.g. #249 U+0D39 U+0D4D  
unicode:2
delete:1
left/right cursoring:1
backspace:2

          backspace     unicode
#250      6 clicks        6
#251      9 clicks        9
#252      9 clicks        9
#253      7 clicks        7
#254     13 clicks       13

Every case's delete clicks and cross click is 1 click except those above cases.     

And in other test case,such as as_IN,hi_IN,bn_IN,some long conjunctions(I didn't test all) have 1 delete click and 1 cross click,whatever how many unicode they have.
e.g.
 [bn_IN GUSB] 
#214 U+0995 U+09CD U+099F U+09CD U+09B0
  unicode:5
  delete:1
  left/right cursoring:1
  backspace:5
 [as_IN GUSB]
#139 U+099A U+09CD U+099B U+09CD U+09AC
  unicode:5
  delete:1
  left/right cursoring:1
  backspace:5
 [hi_GUSB]
#1367 U+0939 U+094D U+0937
  unicode:3
  delete:1
  left/right cursoring:1
  backspace:3
Comment 4 Rahul Bhalerao 2008-09-25 02:37:29 EDT
This is still the right behavior. 09CD and 094D are the 'Halant' characters for the respective languages, that works as a joiner for consonants in the conjunct. So as far as you have them between every two consonants, the syllable may keep growing in terms of number of unicode values. Thus they will have only one delete press for the entire syllable and as many backspaces as the number of unicode characters involved.This is not the same case with the test cases present for Malayalam. There they have multiple syllables and thus multiple delete clicks. Backspace is not affected in any case.

Ani, the fedora and gnome coordinator for Malayalam l10n can confirm the correctness of cursor, delete and backspace behavior for the mentioned test cases.

Note You need to log in before you can comment on or make changes to this bug.