Bug 463511 - [RFE] add functionality to specify a build requires package
[RFE] add functionality to specify a build requires package
Status: NEW
Product: Fedora
Classification: Fedora
Component: appliance-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 15:19 EDT by David Huff
Modified: 2015-01-21 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Huff 2008-09-23 15:19:02 EDT
Description of problem:

There are some packages that are required at build time for building the appliance however are not required in the final appliance.  for example lokkit

lokkit is required to disable selinux at build time however is not needed in the finished appliance once selinux is disable.  It just takes up space.


Feature should have the following specifications:

If a package is not specified in KS as to be in the final appliance however its needed for build time the AC should pull in the package at build time and then remove it after the appliace is build, ie post section.

Posable implemtatians could be a command line option:
 
--include-in-build lokkit foobar

or specified in the ks: 

build requires  lokkit >= X.y

or have a separate file that specifies the build requires packages:
 %include build-deps.ks

or hardcoded in to the ac??

or added to the img min script??

comments.....
Comment 1 David Huff 2008-09-23 15:22:21 EDT
related to BZ#460540
Comment 2 Fedora Admin XMLRPC Client 2014-01-12 14:49:46 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.