Bug 463514 - [LTC 6.0 FEAT] 200948:Support the C99 Decimal Floating point Standard extensions.
[LTC 6.0 FEAT] 200948:Support the C99 Decimal Floating point Standard extensi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc (Show other bugs)
6.0
ppc64 All
high Severity high
: alpha
: 6.0
Assigned To: Jakub Jelinek
Michal Nowak
: FutureFeature
Depends On:
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-23 16:00 EDT by IBM Bug Proxy
Modified: 2013-03-07 21:04 EST (History)
6 users (show)

See Also:
Fixed In Version: gcc-4.4.1-22.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:06:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-23 16:00:54 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 17:35 EDT
1. Feature Overview:
Feature Id:	[200948]
a. Name of Feature:	Support the C99 Decimal Floating point Standard extensions.
b. Feature Description
Implement IEEE754R and ISO/IEC JTC1/SC22, TR 24732: Decimal floating point. These specifications
define Hardware/software interchange formats and C99 language extensions for Decimal Floating Point
respectively.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64
s390x

Arch Specificity: Both
Affects Toolchain: Yes
Delivery Mechanism: Direct from community
Category:	Standards/Community
Request Type:	Toolchain - Enhancement from Upstream
d. Upstream Acceptance:	Pending
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	Partial DFP implementation in GCC-4.2 full support should make GCC-4.3.
Performance Assistance:	yes

3. Business Case
Most financial transactions require decimal computation. Supporting the emerging standard for
Decimal Floating Point. Enable more business applications by support a consistent and portable
(cross platform) Decimal computation standard. Provide high performance Decimal computation on
POWER6 systems.

Benefits
Support a wider array of of applications on Linux.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Steven Munroe, sjmunroe@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 14:31:06 EDT
RHEL 6 will include at least gcc-4.3.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 2 John Jarvis 2008-10-28 17:43:17 EDT
Switching Severity from Urgent to High.  Urgent should be reserved for problems that need to be fixed asynch.
Comment 3 IBM Bug Proxy 2009-03-02 18:10:26 EST
Janis has confirmed that the DFP fixes we need are already in svn+ssh://gcc.gnu.org/svn/gcc/branches/redhat/gcc-4_4-branch, which Jakub said would be used for RHEL6/Fedora11, so we seem to be all set wrt to DFP.
Comment 4 IBM Bug Proxy 2009-03-03 15:12:01 EST
*** Bug 48556 has been marked as a duplicate of this bug. ***
Comment 5 releng-rhel@redhat.com 2009-10-29 09:43:51 EDT
Fixed in 'gcc-4.4.1-22.el6', included in compose 'RHEL6.0-20091028.0'.
Moving to ON_QA.
Comment 6 IBM Bug Proxy 2009-11-16 13:40:37 EST
------- Comment From halves@linux.vnet.ibm.com 2009-11-16 13:35 EDT-------
I ran gdb.base/dfp-exprs.exp and gdb.base/dfp-test.exp tests and all pass without errors.

Regards,

Higor
Comment 7 Michal Nowak 2010-04-09 03:43:34 EDT
VERIFIED per comment 6 (verified field set to IBM).
Comment 8 IBM Bug Proxy 2010-05-03 13:43:24 EDT
------- Comment From bergner@vnet.ibm.com 2010-05-03 13:40 EDT-------
Verified in RHEL6 Beta 1.
Comment 9 releng-rhel@redhat.com 2010-07-02 15:06:19 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.