Bug 463589 - kernel oops, ALSA sound/core/pcm_native.c:1947: BUG? (err >= 0)
kernel oops, ALSA sound/core/pcm_native.c:1947: BUG? (err >= 0)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 461153 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 18:59 EDT by sangu
Modified: 2008-12-15 20:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 20:57:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (61.63 KB, text/plain)
2008-09-23 18:59 EDT, sangu
no flags Details
dmesg with kernel-2.6.27.4-58.fc10.i686 (48.59 KB, text/plain)
2008-10-29 11:36 EDT, sangu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 11643 None None None Never

  None (edit)
Description sangu 2008-09-23 18:59:12 EDT
Created attachment 317543 [details]
dmesg

Description of problem:
alsa-lib-1.0.18-6.rc3.fc10.i386
alsa-utils-1.0.18-3.rc3.fc10.i386
pulseaudio-0.9.12-6.fc10.i386
kernel-2.6.27-0.347.rc7.git1.fc10.i686

$ dmesg 
[skip]
ALSA sound/pci/hda/hda_intel.c:1404: azx_pcm_prepare: bufsize=0x10000, format=0x4011
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x4, stream=0x5, channel=0, format=0x4011
ALSA sound/pci/hda/hda_intel.c:1404: azx_pcm_prepare: bufsize=0x10000, format=0x4011
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x4, stream=0x5, channel=0, format=0x4011
hda_codec: num_steps = 0 for NID=0xb (ctl = Mic Playback Volume)
ALSA sound/core/pcm_native.c:1947: BUG? (err >= 0)
Pid: 3436, comm: pulseaudio Tainted: P          2.6.27-0.347.rc7.git1.fc10.i686 #1
 [<f88eb326>] snd_pcm_hw_constraints_complete+0xba/0x271 [snd_pcm]
 [<f88eb540>] snd_pcm_open_substream+0x63/0x9c [snd_pcm]
 [<f88eb622>] snd_pcm_open+0xa9/0x192 [snd_pcm]
 [<c0427d09>] ? default_wake_function+0x0/0xd
 [<f88a819f>] ? snd_lookup_minor_data+0x44/0x4b [snd]
 [<f88eb736>] snd_pcm_capture_open+0x2b/0x2e [snd_pcm]
 [<f88a84ef>] snd_open+0xcc/0x129 [snd]
 [<c04a0764>] chrdev_open+0x12e/0x145
 [<c049c9b3>] __dentry_open+0x15e/0x256
 [<c049cb3c>] nameidata_to_filp+0x24/0x38
 [<c04a0636>] ? chrdev_open+0x0/0x145
 [<c04a6dda>] do_filp_open+0x32b/0x62b
 [<c053900d>] ? _raw_spin_unlock+0x74/0x78
 [<c06e4fef>] ? _spin_unlock+0x22/0x25
 [<c049c772>] do_sys_open+0x47/0xbc
 [<c049c833>] sys_open+0x23/0x2b
 [<c0404d02>] syscall_call+0x7/0xb
 =======================
ALSA sound/core/pcm_native.c:2053: snd_pcm_hw_constraints_complete failed
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x8
ALSA sound/core/pcm_native.c:1947: BUG? (err >= 0)
Pid: 3436, comm: pulseaudio Tainted: P          2.6.27-0.347.rc7.git1.fc10.i686 #1
 [<f88eb326>] snd_pcm_hw_constraints_complete+0xba/0x271 [snd_pcm]
 [<f88eb540>] snd_pcm_open_substream+0x63/0x9c [snd_pcm]
 [<f88eb622>] snd_pcm_open+0xa9/0x192 [snd_pcm]
 [<c0427d09>] ? default_wake_function+0x0/0xd
 [<f88a819f>] ? snd_lookup_minor_data+0x44/0x4b [snd]
 [<f88eb736>] snd_pcm_capture_open+0x2b/0x2e [snd_pcm]
 [<f88a84ef>] snd_open+0xcc/0x129 [snd]
 [<c04a0764>] chrdev_open+0x12e/0x145
 [<c049c9b3>] __dentry_open+0x15e/0x256
 [<c049cb3c>] nameidata_to_filp+0x24/0x38
 [<c04a0636>] ? chrdev_open+0x0/0x145
 [<c04a6dda>] do_filp_open+0x32b/0x62b
 [<c053900d>] ? _raw_spin_unlock+0x74/0x78
 [<c06e4fef>] ? _spin_unlock+0x22/0x25
 [<c049c772>] do_sys_open+0x47/0xbc
 [<c049c833>] sys_open+0x23/0x2b
 [<c0404d02>] syscall_call+0x7/0xb
 =======================
ALSA sound/core/pcm_native.c:2053: snd_pcm_hw_constraints_complete failed
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x8
ALSA sound/core/pcm_native.c:1947: BUG? (err >= 0)
Pid: 3436, comm: pulseaudio Tainted: P          2.6.27-0.347.rc7.git1.fc10.i686 #1
 [<f88eb326>] snd_pcm_hw_constraints_complete+0xba/0x271 [snd_pcm]
 [<f88eb540>] snd_pcm_open_substream+0x63/0x9c [snd_pcm]
 [<f88eb622>] snd_pcm_open+0xa9/0x192 [snd_pcm]
 [<c0427d09>] ? default_wake_function+0x0/0xd
 [<f88a819f>] ? snd_lookup_minor_data+0x44/0x4b [snd]
 [<f88eb736>] snd_pcm_capture_open+0x2b/0x2e [snd_pcm]
 [<f88a84ef>] snd_open+0xcc/0x129 [snd]
 [<c04a0764>] chrdev_open+0x12e/0x145
 [<c049c9b3>] __dentry_open+0x15e/0x256
 [<c049cb3c>] nameidata_to_filp+0x24/0x38
 [<c04a0636>] ? chrdev_open+0x0/0x145
 [<c04a6dda>] do_filp_open+0x32b/0x62b
 [<c053900d>] ? _raw_spin_unlock+0x74/0x78
 [<c06e4fef>] ? _spin_unlock+0x22/0x25
 [<c049c772>] do_sys_open+0x47/0xbc
 [<c049c833>] sys_open+0x23/0x2b
 [<c0404d02>] syscall_call+0x7/0xb
 =======================
ALSA sound/core/pcm_native.c:2053: snd_pcm_hw_constraints_complete failed
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x8
ALSA sound/core/pcm_native.c:1947: BUG? (err >= 0)
Pid: 3436, comm: pulseaudio Tainted: P          2.6.27-0.347.rc7.git1.fc10.i686 #1
 [<f88eb326>] snd_pcm_hw_constraints_complete+0xba/0x271 [snd_pcm]
 [<f88eb540>] snd_pcm_open_substream+0x63/0x9c [snd_pcm]
 [<f88eb622>] snd_pcm_open+0xa9/0x192 [snd_pcm]
 [<c0427d09>] ? default_wake_function+0x0/0xd
 [<f88a819f>] ? snd_lookup_minor_data+0x44/0x4b [snd]
 [<f88eb736>] snd_pcm_capture_open+0x2b/0x2e [snd_pcm]
 [<f88a84ef>] snd_open+0xcc/0x129 [snd]
 [<c04a0764>] chrdev_open+0x12e/0x145
 [<c049c9b3>] __dentry_open+0x15e/0x256
 [<c049cb3c>] nameidata_to_filp+0x24/0x38
 [<c04a0636>] ? chrdev_open+0x0/0x145
 [<c04a6dda>] do_filp_open+0x32b/0x62b
 [<c053900d>] ? _raw_spin_unlock+0x74/0x78
 [<c06e4fef>] ? _spin_unlock+0x22/0x25
 [<c049c772>] do_sys_open+0x47/0xbc
 [<c049c833>] sys_open+0x23/0x2b
 [<c0404d02>] syscall_call+0x7/0xb
 =======================
ALSA sound/core/pcm_native.c:2053: snd_pcm_hw_constraints_complete failed
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x8
ALSA sound/core/pcm_native.c:1947: BUG? (err >= 0)
Pid: 3436, comm: pulseaudio Tainted: P          2.6.27-0.347.rc7.git1.fc10.i686 #1
 [<f88eb326>] snd_pcm_hw_constraints_complete+0xba/0x271 [snd_pcm]
 [<f88eb540>] snd_pcm_open_substream+0x63/0x9c [snd_pcm]
 [<f88eb622>] snd_pcm_open+0xa9/0x192 [snd_pcm]
 [<c0427d09>] ? default_wake_function+0x0/0xd
 [<f88a819f>] ? snd_lookup_minor_data+0x44/0x4b [snd]
 [<f88eb736>] snd_pcm_capture_open+0x2b/0x2e [snd_pcm]
 [<f88a84ef>] snd_open+0xcc/0x129 [snd]
 [<c04a0764>] chrdev_open+0x12e/0x145
 [<c049c9b3>] __dentry_open+0x15e/0x256
 [<c049cb3c>] nameidata_to_filp+0x24/0x38
 [<c04a0636>] ? chrdev_open+0x0/0x145
 [<c04a6dda>] do_filp_open+0x32b/0x62b
 [<c053900d>] ? _raw_spin_unlock+0x74/0x78
 [<c06e4fef>] ? _spin_unlock+0x22/0x25
 [<c049c772>] do_sys_open+0x47/0xbc
 [<c049c833>] sys_open+0x23/0x2b
 [<c0404d02>] syscall_call+0x7/0xb
 =======================
ALSA sound/core/pcm_native.c:2053: snd_pcm_hw_constraints_complete failed
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x8
ALSA sound/core/pcm_native.c:1947: BUG? (err >= 0)
Pid: 3436, comm: pulseaudio Tainted: P          2.6.27-0.347.rc7.git1.fc10.i686 #1
 [<f88eb326>] snd_pcm_hw_constraints_complete+0xba/0x271 [snd_pcm]
 [<f88eb540>] snd_pcm_open_substream+0x63/0x9c [snd_pcm]
 [<f88eb622>] snd_pcm_open+0xa9/0x192 [snd_pcm]
 [<c0427d09>] ? default_wake_function+0x0/0xd
 [<f88a819f>] ? snd_lookup_minor_data+0x44/0x4b [snd]
 [<f88eb736>] snd_pcm_capture_open+0x2b/0x2e [snd_pcm]
 [<f88a84ef>] snd_open+0xcc/0x129 [snd]
 [<c04a0764>] chrdev_open+0x12e/0x145
 [<c049c9b3>] __dentry_open+0x15e/0x256
 [<c049cb3c>] nameidata_to_filp+0x24/0x38
 [<c04a0636>] ? chrdev_open+0x0/0x145
 [<c04a6dda>] do_filp_open+0x32b/0x62b
 [<c053900d>] ? _raw_spin_unlock+0x74/0x78
 [<c06e4fef>] ? _spin_unlock+0x22/0x25
 [<c049c772>] do_sys_open+0x47/0xbc
 [<c049c833>] sys_open+0x23/0x2b
 [<c0404d02>] syscall_call+0x7/0xb
 =======================
ALSA sound/core/pcm_native.c:2053: snd_pcm_hw_constraints_complete failed
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x8
ALSA sound/core/pcm_native.c:1947: BUG? (err >= 0)
Pid: 3436, comm: pulseaudio Tainted: P          2.6.27-0.347.rc7.git1.fc10.i686 #1
 [<f88eb326>] snd_pcm_hw_constraints_complete+0xba/0x271 [snd_pcm]
 [<f88eb540>] snd_pcm_open_substream+0x63/0x9c [snd_pcm]
 [<f88eb622>] snd_pcm_open+0xa9/0x192 [snd_pcm]
 [<c0427d09>] ? default_wake_function+0x0/0xd
 [<f88a819f>] ? snd_lookup_minor_data+0x44/0x4b [snd]
 [<f88eb736>] snd_pcm_capture_open+0x2b/0x2e [snd_pcm]
 [<f88a84ef>] snd_open+0xcc/0x129 [snd]
 [<c04a0764>] chrdev_open+0x12e/0x145
 [<c049c9b3>] __dentry_open+0x15e/0x256
 [<c049cb3c>] nameidata_to_filp+0x24/0x38
 [<c04a0636>] ? chrdev_open+0x0/0x145
 [<c04a6dda>] do_filp_open+0x32b/0x62b
 [<c053900d>] ? _raw_spin_unlock+0x74/0x78
 [<c06e4fef>] ? _spin_unlock+0x22/0x25
 [<c049c772>] do_sys_open+0x47/0xbc
 [<c049c833>] sys_open+0x23/0x2b
 [<c0404d02>] syscall_call+0x7/0xb
 =======================
ALSA sound/core/pcm_native.c:2053: snd_pcm_hw_constraints_complete failed
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x8
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4
hda_codec: num_steps = 0 for NID=0xb (ctl = Mic Playback Volume)

Version-Release number of selected component (if applicable):
2.6.27-0.347.rc7.git1.fc10.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2008-10-24 20:32:23 EDT
http://bugzilla.kernel.org/show_bug.cgi?id=11643#c5
------- Comment  #5 From Takashi Iwai  2008-10-05 02:18:10  [reply] -------

Did you try the latest sound git tree above?
Comment 2 Christopher D. Stover 2008-10-29 10:09:25 EDT
*** Bug 461153 has been marked as a duplicate of this bug. ***
Comment 3 Christopher D. Stover 2008-10-29 10:12:41 EDT
Are you still experiencing this problem with newer kernels Sangu?
Comment 4 sangu 2008-10-29 11:36:51 EDT
Created attachment 321815 [details]
dmesg with kernel-2.6.27.4-58.fc10.i686

(In reply to comment #3)
> Are you still experiencing this problem with newer kernels Sangu?
Yes. this still happens in kernel-2.6.27.4-58.fc10.i686.
Comment 5 Bug Zapper 2008-11-25 22:12:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 sangu 2008-12-15 20:57:39 EST
After installing kernel-2.6.27-44, HDA_Intel always works well.

in kernel package changelog
* Mon Dec 08 2008 Chuck Ebbert <cebbert@redhat.com> 2.6.27.7-139
- ALSA 1.0.18a

Note You need to log in before you can comment on or make changes to this bug.