This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 463597 - [LTC 6.0 FEAT] 201166:Support IPv6 boot/install through yaboot
[LTC 6.0 FEAT] 201166:Support IPv6 boot/install through yaboot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yaboot (Show other bugs)
6.0
ppc64 All
high Severity high
: alpha
: 6.0
Assigned To: Roman Rakus
Release Test Team
: FutureFeature
Depends On:
Blocks: 356741 467426 554559
  Show dependency treegraph
 
Reported: 2008-09-23 22:50 EDT by IBM Bug Proxy
Modified: 2014-01-12 19:07 EST (History)
6 users (show)

See Also:
Fixed In Version: yaboot-1.3.14-17.fc12
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 17:24:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rearrange the code in preparation to fix ipv4 implementation (13.65 KB, text/plain)
2009-03-12 22:31 EDT, IBM Bug Proxy
no flags Details
Fix ipv4 implemention to handle all the arguments properly. (9.75 KB, text/plain)
2009-03-12 22:31 EDT, IBM Bug Proxy
no flags Details
Extract ipv4 functionality to a separate function (2.03 KB, text/plain)
2009-03-12 22:31 EDT, IBM Bug Proxy
no flags Details
Implement ipv6 functionality (4.95 KB, text/plain)
2009-03-12 22:31 EDT, IBM Bug Proxy
no flags Details
Addind speed and duplex didn't help in my blade (5.25 KB, text/plain)
2009-11-17 17:12 EST, IBM Bug Proxy
no flags Details
With SMS, boot proceded further, but died in a odd way (12.66 KB, text/plain)
2009-11-23 22:31 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2008-09-23 22:50:32 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:04 EDT
1. Feature Overview:
Feature Id:	[201166]
a. Name of Feature:	Support IPv6 boot/install through yaboot
b. Feature Description
Add the IPv6 capability to yaboot.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Arch Specific Code
Affects Installer: Yes
Delivery Mechanism: Direct from community
Category:	Device Drivers and IO
Request Type:	Other
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	Code submitted to yaboot community this week.

3. Business Case
The IPv6 boot/install capability is required on all platforms by mid-2008 for government business.

Benefits
This is to enable the IPv6 full support with Linux on Power systems. This capability is required by
all system sold to government by mid-2008.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):
Daisy Chang, daisyc@us.ibm.com
Chandra Seetharaman, chandra.seetharaman@us.ibm.com

IBM Manager:
Wendel Voigt, wvoigt@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 16:16:49 EDT
Placing in NEEDINFO pending upstream code acceptance and release.
Comment 2 IBM Bug Proxy 2008-10-08 15:20:45 EDT
Patches posted to yaboot-dev mailing list on Sep-15:
http://www.nabble.com/-PATCH-0-4--yaboot-tftp-boot-extensions-and-ipv6-support-to19503401.html
Comment 3 IBM Bug Proxy 2008-10-17 08:15:38 EDT
Hello RedHat,

Just wondering about the deadline.

i.e By when this feature has to be available in mainline yaboot to be accepted for RHEL 6 ?

Thanks
Comment 4 Roman Rakus 2008-10-17 08:43:05 EDT
Not in yaboot git HEAD yet.
Comment 5 IBM Bug Proxy 2008-10-17 14:20:58 EDT
Yes, that is the reason I am asking the question.

I am working with the yaboot maintainer, and he wants to know when this needs to be in the HEAD.
Comment 6 Roman Rakus 2008-10-21 08:21:36 EDT
Ah, yes, now I read it over and understand it well (I hope :)). It seems there is no deadline yet.
Comment 7 IBM Bug Proxy 2008-10-23 14:11:20 EDT
*** Bug 39666 has been marked as a duplicate of this bug. ***
Comment 8 IBM Bug Proxy 2009-03-12 22:31:13 EDT
Following are the direct port (to RHEL 5.3 yaboot tree) of the four patches I
submitted to the yaboot-dev mailing list on Sep 15, 2008 to support ipv6 net
boot:
http://www.nabble.com/-PATCH-0-4--yaboot-tftp-boot-extensions-and-ipv6-support-tt19503401.html#a19503401

I am still working with the maintainer to get these into his tree.

ipv6 implementation was done after consultation with the maintainer. He is in
agreement with the implementation.

He has just been very busy
Comment 9 IBM Bug Proxy 2009-03-12 22:31:17 EDT
Created attachment 335043 [details]
rearrange the code in preparation to fix ipv4 implementation


------- Comment (attachment) From sekharan@us.ibm.com 2009-03-12 22:21 EDT-------


There is no functional change in this patch. This is just to prepare the
code for the following patch.

This patch just replaces the arguments "char *dev_name" and "char *file_name"
with "struct boot_fspec_t fspec".
Comment 10 IBM Bug Proxy 2009-03-12 22:31:21 EDT
Created attachment 335044 [details]
Fix ipv4 implemention to handle all the arguments properly.


------- Comment (attachment) From sekharan@us.ibm.com 2009-03-12 22:22 EDT-------


Currently, yaboot works properly when there is a tftp boot server serving
the broadcast requests sent in the network.

If the user specifies siaddr, ciaddr, and other arguments in the command
line, it is not handled appropriately.

This patch changes that behavior and make yaboot work properly in both cases.

The semantics specified in section 4.1 of
http://playground.sun.com/1275/practice/obp-tftp/tftp1_0.pdf is followed.
([bootp,]siaddr,filename,ciaddr,giaddr,bootp-retries,tftp-retries)
Comment 11 IBM Bug Proxy 2009-03-12 22:31:25 EDT
Created attachment 335045 [details]
Extract ipv4 functionality to a separate function


------- Comment (attachment) From sekharan@us.ibm.com 2009-03-12 22:23 EDT-------


This patch just extracts the ipv4 arguments extraction into a separate
function. No functional change.

This is just in preparation for the next patch which adds supports for
ipv6.
Comment 12 IBM Bug Proxy 2009-03-12 22:31:30 EDT
Created attachment 335046 [details]
Implement ipv6 functionality


------- Comment (attachment) From sekharan@us.ibm.com 2009-03-12 22:24 EDT-------


This patch adds support for handling ipv6 boot parameters for POWER
architecture.

This is implementation derived. 

This follows the semantics defined in section 4.3.1 of
http://www.power.org/apps/org/workgroup/parch/download.php/2380/latest
(It is under the Members area of TSC - Platform Architecture committee).
Comment 13 IBM Bug Proxy 2009-07-23 22:20:58 EDT
------- Comment From sekharan@us.ibm.com 2009-07-23 22:14 EDT-------
BTW, 5.4 bugzilla is BZ #50306
Comment 14 IBM Bug Proxy 2009-07-29 13:02:26 EDT
------- Comment From sekharan@us.ibm.com 2009-07-29 12:53 EDT-------
Dear RedHat,

This functionality is not available in Alpha 1.

Will it become available in Beta ?

Just an FYI:

- Tony Breeds (maintainer of yaboot) agreed to accept this set of patches once
he stabilizes his tree.
- This feature is already been accepted in RHEL 5.4 (RedHat BZ bug # 475807, LTC BZ bug # 50306)
Comment 15 Roman Rakus 2009-07-29 13:11:19 EDT
My mistake, going to fix it
Comment 16 Roman Rakus 2009-08-14 10:02:00 EDT
yaboot-1.3.14-17.fc12 was built. IBM can you please check this rpm?
Comment 17 releng-rhel@redhat.com 2009-10-29 09:44:11 EDT
Fixed in 'yaboot-1.3.14-17.fc12'. 'yaboot-1.3.14-19.el6' included in compose 'RHEL6.0-20091028.0'.
Moving to ON_QA.
Comment 18 IBM Bug Proxy 2009-11-13 21:41:16 EST
------- Comment From sekharan@us.ibm.com 2009-11-13 21:34 EDT-------
Tried to test out ipv6 network boot. It failed with "Unable to parse". So, tried to boot with ipv4 syntax and it also failed the same way....
==============

When I try to do netboot (using boot
network1:bootp,10.0.0.242,yaboot_rhel6d,10.0.0.241,10.0.0.1,5,5,255.255.255.0
syntax), RHEL6 fails with the message "Unable to parse" as in
======================================
Welcome to Red Hat Enterprise Linux 6!
Hit <TAB> for boot options
Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-23.el6)
Enter "help" to get some basic usage information
boot: linux
/vmlinuz-2.6.31-33.el6.ppc64: Unable to parse
boot:
/vmlinuz-2.6.31-33.el6.ppc64: Unable to parse
boot:
=======================================

The same yaboot.conf file works with the same yaboot in a local disk.

The same yaboot.conf file goes further
- when I try to boot off of ISCSI storage
or  - when I try to boot off of RHEL 5.4 yaboot,

but fails after reading vmlinuz, saying it is "Not a valid ELF image"

as in
========================================
Welcome to yaboot version 1.3.13 (Red Hat 1.3.13-8.el5)
Enter "help" to get some basic usage information
boot:
* linux
boot:
Please wait, loading kernel...

TFTP BOOT ---------------------------------------------------
Server IP.....................10.0.0.242
Client IP.....................10.0.0.241
Gateway IP....................10.0.0.1
Subnet Mask...................255.255.255.0
( 1  ) Filename.................\vmlinuz-2.6.31-33.el6.ppc64
TFTP Retries..................5
Block Size....................512
FINAL PACKET COUNT = 40921
FINAL FILE SIZE = 20951544  BYTES
/vmlinuz-2.6.31-33.el6.ppc64: Not a valid ELF image
=======================================

So, I wanted to build debug yaboot in RHEL6, but it is also lead to
failure as shown below. I also listed the e2fs devel tools I have
installed.
=======================================
:
:
ld -Ttext 0x200000 -Bstatic  second/crt0.o second/yaboot.o
second/cache.o second/prom.o second/file.o second/partition.o
second/fs.o second/cfg.o second/setjmp.o second/cmdline.o second/fs_of.o
second/fs_iso.o second/iso_util.o lib/nosys.o lib/string.o lib/strtol.o
lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o second/md5.o
second/fs_xfs.o second/fs_reiserfs.o -lext2fs `gcc -m32
-print-libgcc-file-name` -o second/yaboot
ld: skipping incompatible /usr/lib/libext2fs.a when searching for
-lext2fs
ld: cannot find -lext2fs
make: *** [yaboot] Error 1
[root@elm3c241 yaboot-1.3.14]# rpm -qa | grep e2fs
e2fsprogs-libs-1.41.8-5.el6.ppc64
e2fsprogs-1.41.8-5.el6.ppc64
e2fsprogs-devel-1.41.8-5.el6.ppc
[root@elm3c241 yaboot-1.3.14]#
=======================================

Any help ?
Comment 19 IBM Bug Proxy 2009-11-15 18:30:57 EST
------- Comment From tonyb@au1.ibm.com 2009-11-15 18:27 EDT-------
(In reply to comment #28)

> When I try to do netboot (using boot
> network1:bootp,10.0.0.242,yaboot_rhel6d,10.0.0.241,10.0.0.1,5,5,255.255.255.0
>   syntax), RHEL6 fails with the message "Unable to parse" as in
> ======================================
> Welcome to Red Hat Enterprise Linux 6!
> Hit<TAB>  for boot options
> Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-23.el6)
> Enter "help" to get some basic usage information
> boot: linux
> /vmlinuz-2.6.31-33.el6.ppc64: Unable to parse
> boot:
> /vmlinuz-2.6.31-33.el6.ppc64: Unable to parse
> boot:
> =======================================

Please try booting the yaboot.debug (in /usr/lib/yaboot/yaboot.debug)  and send me the logs.
What hardware and firmware versions?

> The same yaboot.conf file works with the same yaboot in a local disk.

Of course.

> The same yaboot.conf file goes further
>      - when I try to boot off of ISCSI storage
> or  - when I try to boot off of RHEL 5.4 yaboot,
>
> but fails after reading vmlinuz, saying it is "Not a valid ELF image"

This make sense the RHEL-6 kernel is relocatable and the yaboot in RHEL-5
doesn't grok the ELF format.

You can "hack it" with something like:

printf "\x02" | dd of=vmlinuz-2.6.31-33.el6.ppc64 conv=notrunc bs=1 seek=17

But it'd clearly be better to fix the RHEL-6 yaboot.

> So, I wanted to build debug yaboot in RHEL6, but it is also lead to
> failure as shown below. I also listed the e2fs devel tools I have
> installed.

There is one pre-built in the yaboot RPM see my first comment.  I figured having
it on the system would lower the barrier to entry for helping me debug yaboot
prolems.

<snip>

> ld: skipping incompatible /usr/lib/libext2fs.a when searching for

You need the 32-bit e2fsprogs-libs (yum install e2fsprogs-libs.ppc) IIRC
Comment 20 IBM Bug Proxy 2009-11-15 19:50:54 EST
------- Comment From tonyb@au1.ibm.com 2009-11-15 19:41 EDT-------
(In reply to comment #28)
> Tried to test out ipv6 network boot. It failed with "Unable to parse". So,
> tried to boot with ipv4 syntax and it also failed the same way....
> ==============
>
> When I try to do netboot (using boot
> network1:bootp,10.0.0.242,yaboot_rhel6d,10.0.0.241,10.0.0.1,5,5,255.255.255.0
>  syntax), RHEL6 fails with the message "Unable to parse" as in

Actually it looks like the code in yaboot doesn't grok the [bootp,] try removing it and see if you can correctly netboot, via IPv4 and IPv6.
Comment 21 IBM Bug Proxy 2009-11-16 19:40:52 EST
------- Comment From sekharan@us.ibm.com 2009-11-16 19:39 EDT-------
> (In reply to comment #28)

>
> Please try booting the yaboot.debug (in /usr/lib/yaboot/yaboot.debug)  and send
> me the logs.
> What hardware and firmware versions?

Firmware version:
==========
Firmware Type                         Build ID             Released       Version
-----------------------------------------------------------------------------------------------------------
Blade Sys Mgmt Processor   	  BOBT001                                3.42
FW/BIOS   	          EA340_101   	  09/15/09        0940
------------------------------------------------------------------------------------------------------------
Hardware VPD:
==========
Product Name  	  JS12/JS22 Express Blade Server, 1-2 dual-core IBM POWER6 CPU(s)
Description  	  JS22 (Type 7998)
Machine Type/Model  	  799861X
Machine Serial No.  	  06145DA
Part Number  	  07P6886
FRU Number  	  44M1502
FRU Serial No.  	  YL10W733600S
Hardware Revision  	  0
Manuf. Date  	  4807
UUID  	  050D 76CC 914A 11D7 8B56 001A 6444 B784
Manufacturer  	  IBM (LW)
Manuf. ID  	  20301
Product ID  	  137
Comment 22 IBM Bug Proxy 2009-11-16 20:51:14 EST
------- Comment From sekharan@us.ibm.com 2009-11-16 20:44 EDT-------
> > The same yaboot.conf file goes further
> >      - when I try to boot off of ISCSI storage
> > or  - when I try to boot off of RHEL 5.4 yaboot,
> >
> > but fails after reading vmlinuz, saying it is "Not a valid ELF image"
>
> This make sense the RHEL-6 kernel is relocatable and the yaboot in RHEL-5
> doesn't grok the ELF format.
>
> You can "hack it" with something like:
>
> printf "\x02" | dd of=vmlinuz-2.6.31-33.el6.ppc64 conv=notrunc bs=1 seek=17
>
> But it'd clearly be better to fix the RHEL-6 yaboot.
>

Nope, this didn't help. It got past that point, but had a firmware crash

------------------------
TFTP BOOT ---------------------------------------------------
Server IP.....................10.0.0.242
Client IP.....................10.0.0.241
Gateway IP....................10.0.0.1
Subnet Mask...................255.255.255.0
( 1  ) Filename.................\vmlinuz-2.6.31-33.el6.ppc64
TFTP Retries..................5
Block Size....................512
FINAL PACKET COUNT = 40921
FINAL FILE SIZE = 20951544  BYTES
Elf64 kernel loaded...
Loading ramdisk...

TFTP BOOT ---------------------------------------------------
Server IP.....................10.0.0.242
Client IP.....................10.0.0.241
Gateway IP....................10.0.0.1
Subnet Mask...................255.255.255.0
( 1  ) Filename.................\initramfs-2.6.31-33.el6.ppc64.img
TFTP Retries..................5
Block Size....................512
FINAL PACKET COUNT = 26735
FINAL FILE SIZE = 13688089  BYTES
ramdisk loaded at 05400000, size: 13367 Kbytes
DEFAULT CATCH!, exception-handler=fff00300
at   %SRR0: 0000000003149780   %SRR1: 8000000000003002
Open Firmware exception handler entered from non-OF code

Client's Fix Pt Regs:
00 03fc7fff200d03ff 00000000019ff940 00000000043ec8a8 fbe1fff8f8010010
04 0000000000000000 0000000000000000 fbe1fff8f8010010 0000000000000000
08 0000000003100000 00000000040efff8 c000000000000000 0000000003d79000
0c 000000000313a964 0000000000000000 0000000000000000 0000000000000000
10 0000000000000000 0000000000000000 0000000000000000 0000000000d0dd19
14 0000000000c00000 0000000005400000 3a94ffffe8780028 0000000003100000
18 0000000000000000 3a94ffffe8780010 0000000003100000 0000000000c39a68
1c 0000000000000000 fffffffffffffffd fbe1fff8f8010010 3a94ffffe8780028
Special Regs:
%IV: 00000300     %CR: 44000040    %XER: 20000000  %DSISR: 08000000
%SRR0: 0000000003149780   %SRR1: 8000000000003002
%LR: 0000000003b2cc0c    %CTR: 03fc7fff200d03ff
%DAR: fbe1fff8f8010010
Virtual PID = 0

Detected bad memory access to address: 00000000801ea503
Package path = /
Return Stack Trace
------------------
c@  - 4fbf08
pfds-next-child  - 51bd10
(poplocals)  - 4fa758
pfds-peer  - 51bec8
(poplocals)  - 4fa758
pfds-search  - 51c1b8
(poplocals)  - 4fa758
hyperboot?  - 51c864
evaluate  - 50a3ec
invalid pointer - 50e74d
invalid pointer - 18
invalid pointer - 18
eval  - 50a4ac
catch  - 4f8fe8
loc-code-checkpoint  - 529d8c
(poplocals)  - 4fa758
log-this-error  - 52a18c
(poplocals)  - 4fa758
logerror-with-debug-info  - 52a3fc
evaluate  - 50a3ec
ofdbg
0 >   ofdbg
0 >   ofdbg
0 >
----------------------------

------- Comment From sekharan@us.ibm.com 2009-11-16 20:48 EDT-------
(In reply to comment #29)

> There is one pre-built in the yaboot RPM see my first comment.  I figured
> having
> it on the system would lower the barrier to entry for helping me debug yaboot
> prolems.
>
> <snip>

Here is the yaboot debug o/p.
------------------------
0 > boot network1:bootp,10.0.0.242,yaboot_rhel6d,10.0.0.241,10.0.0.1,5,5,255.255.255.0

TFTP BOOT ---------------------------------------------------
Server IP.....................10.0.0.242
Client IP.....................10.0.0.241
Gateway IP....................10.0.0.1
Subnet Mask...................255.255.255.0
( 1  ) Filename.................yaboot_rhel6d
TFTP Retries..................5
Block Size....................512
FINAL PACKET COUNT = 880
FINAL FILE SIZE = 450522  BYTES

Elapsed time since release of system processors: 5 mins 21 secs

Adding OF methods...
prom_init - OF interface initialized.
yaboot_start - Malloc buffer allocated at 00300000 (1048576 bytes)
yaboot_start - reloc_offset :  0         (should be 0)
yaboot_start - test_bss     :  0         (should be 0)
yaboot_start - test_data    :  0         (should be 0)
yaboot_start - &test_data   :  00234c9c
yaboot_start - &test_bss    :  00234c98
yaboot_start - linked at    :  0x00200000
yaboot_start - Running on _machine = 4
yaboot_main - /chosen/bootargs =
yaboot_main - /chosen/bootpath = /lhea@23c00100/ethernet@23e00100:bootp,10.0.0.242,yaboot_rhel6d,10.0.0.241,10.0.0.1,5,5,255.255.255.0
parse_device_path - imagepath = /lhea@23c00100/ethernet@23e00100:bootp,10.0.0.242,yaboot_rhel6d,10.0.0.241,10.0.0.1,5,5,255.255.255.0; defdevice <NULL>; defpart -1, deffile
extract_netboot_args - imagepath = /lhea@23c00100/ethernet@23e00100:bootp,10.0.0.242,yaboot_rhel6d,10.0.0.241,10.0.0.1,5,5,255.255.255.0
extract_netboot_args - ipv6 = <0>
extract_netboot_args - siaddr = <10.0.0.242>
extract_netboot_args - file = <yaboot_rhel6d>
extract_netboot_args - ciaddr = <10.0.0.241>
extract_netboot_args - giaddr = <10.0.0.1>
extract_netboot_args - bootp_retries = <5>
extract_netboot_args - tftp_retries = <5>
extract_netboot_args - addl_params = <<NULL>>
extract_netboot_args - dhcpv6 = <<NULL>>
extract_netboot_args - blksize = <<NULL>>
netdev_path_to_dev - path = /lhea@23c00100/ethernet@23e00100:bootp,10.0.0.242,yaboot_rhel6d,10.0.0.241,10.0.0.1,5,5,255.255.255.0
yaboot_main - After parse_device_path: dev=/lhea@23c00100/ethernet@23e00100:, part=-1, file=yaboot_rhel6d
yaboot_main - After path kludgeup: dev=/lhea@23c00100/ethernet@23e00100:, part=-1, file=/etc/yaboot.conf
Try to netboot
Failed to get netinfo data
open_file - dev_path = /lhea@23c00100/ethernet@23e00100:
file_name = /etc/yaboot.conf
partition = -1
open_file - device is a network device
--> of_net_open
of_net_open - dev=/lhea@23c00100/ethernet@23e00100:, part=0x00000000 (-1), file_name=/etc/yaboot.conf
of_net_open - siaddr <10.0.0.242>; filename <\etc\yaboot.conf>; ciaddr <10.0.0.241>; giaddr <10.0.0.1>; ipv6 <0>
of_net_open - Using new tftp style
of_net_open - Opening: "/lhea@23c00100/ethernet@23e00100:10.0.0.242,\etc\yaboot.conf,10.0.0.241,10.0.0.1,5,5,255.255.255.0,"

of_net_open - file->of_device = 01b08e00
prom_claim_chunk - claimed 33554432 at 0x2100000 (0x0)
of_net_open - TFP...

TFTP BOOT ---------------------------------------------------
Server IP.....................10.0.0.242
Client IP.....................10.0.0.241
Gateway IP....................10.0.0.1
Subnet Mask...................255.255.255.0
( 1  ) Filename.................\etc\yaboot.conf
TFTP Retries..................5
Block Size....................512
FINAL PACKET COUNT = 1
FINAL FILE SIZE = 318  BYTES
of_net_open - result: 318
<-- of_net_open - FILE_ERR_OK
Config file read, 318 bytes
--> of_close
of_close - <@01b08e00>
of_close - of_close called
<-- of_close - 0
Resetting image table
ItemA device = <NULL>
ItemB device = <NULL>

ItemA partition = <NULL>
ItemB partition = <NULL>

ItemA default = <NULL>
ItemB default = <NULL>

ItemA timeout = <NULL>
ItemB timeout = <NULL>

ItemA password = <NULL>
ItemB password = <NULL>

ItemA restricted = <NULL>
ItemB restricted = <NULL>

ItemA message = <NULL>
ItemB message = <NULL>

ItemA root = <NULL>
ItemB root = <NULL>

ItemA ramdisk = <NULL>
ItemB ramdisk = <NULL>

ItemA read-only = <NULL>
ItemB read-only = <NULL>

ItemA read-write = <NULL>
ItemB read-write = <NULL>

ItemA append = <NULL>
ItemB append = <NULL>

ItemA initrd = <NULL>
ItemB initrd = <NULL>

ItemA initrd-prompt = <NULL>
ItemB initrd-prompt = <NULL>

ItemA initrd-size = <NULL>
ItemB initrd-size = <NULL>

ItemA pause-after = <NULL>
ItemB pause-after = <NULL>

ItemA pause-message = <NULL>
ItemB pause-message = <NULL>

ItemA init-code = <NULL>
ItemB init-code = <NULL>

ItemA init-message = <NULL>
ItemB init-message = <NULL>

ItemA fgcolor = <NULL>
ItemB fgcolor = <NULL>

ItemA bgcolor = <NULL>
ItemB bgcolor = <NULL>

ItemA ptypewarning = <NULL>
ItemB ptypewarning = <NULL>

load_config_file - Config file successfully parsed, 318 bytes

Welcome to the 64-bit Red Hat Enterprise Linux 6 6.0 installer!
Hit <TAB> for boot options.

Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-23.el6)
Enter "help" to get some basic usage information
boot: linux
parse_device_path - imagepath = /vmlinuz-2.6.31-33.el6.ppc64; defdevice /lhea@23c00100/ethernet@23e00100:; defpart -1, deffile /vmlinux
/vmlinuz-2.6.31-33.el6.ppc64: Unable to parse
boot:
Comment 23 IBM Bug Proxy 2009-11-16 21:00:53 EST
------- Comment From sekharan@us.ibm.com 2009-11-16 20:58 EDT-------
(In reply to comment #29)

>
> > ld: skipping incompatible /usr/lib/libext2fs.a when searching for
>
> You need the 32-bit e2fsprogs-libs (yum install e2fsprogs-libs.ppc) IIRC

Nope. I Installed the rpm but, make with the following message
----------------------
[root@test241 yaboot-1.3.14]# make
ld -Ttext 0x200000 -Bstatic  second/crt0.o second/yaboot.o second/cache.o second/prom.o second/file.o second/partition.o second/fs.o second/cfg.o second/setjmp.o second/cmdline.o second/fs_of.o second/fs_iso.o second/iso_util.o lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o second/md5.o second/fs_xfs.o second/fs_reiserfs.o -lext2fs `gcc -m32 -print-libgcc-file-name` -o second/yaboot
ld: cannot find -lext2fs
make: *** [yaboot] Error 1

----------------------

When I reinstalled e2fsprogs-devel-1.41.8-5.el6.ppc, it fails with the following message
-----------------------
[root@test241 yaboot-1.3.14]# make
ld -Ttext 0x200000 -Bstatic  second/crt0.o second/yaboot.o second/cache.o second/prom.o second/file.o second/partition.o second/fs.o second/cfg.o second/setjmp.o second/cmdline.o second/fs_of.o second/fs_iso.o second/iso_util.o lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o second/md5.o second/fs_xfs.o second/fs_reiserfs.o -lext2fs `gcc -m32 -print-libgcc-file-name` -o second/yaboot
ld: skipping incompatible /usr/lib/libext2fs.a when searching for -lext2fs
ld: cannot find -lext2fs
make: *** [yaboot] Error 1
-----------------------

------- Comment From sekharan@us.ibm.com 2009-11-16 20:59 EDT-------
(In reply to comment #30)
> (In reply to comment #28)
> > Tried to test out ipv6 network boot. It failed with "Unable to parse". So,
> > tried to boot with ipv4 syntax and it also failed the same way....
> > ==============
> >
> > When I try to do netboot (using boot
> > network1:bootp,10.0.0.242,yaboot_rhel6d,10.0.0.241,10.0.0.1,5,5,255.255.255.0
> >  syntax), RHEL6 fails with the message "Unable to parse" as in
>
> Actually it looks like the code in yaboot doesn't grok the [bootp,] try
> removing it and see if you can correctly netboot, via IPv4 and IPv6.

Nope. failed the same way
---------------------------
0 > boot network1:10.0.0.242,yaboot_rhel6,10.0.0.241,10.0.0.1,5,5,255.255.255.0

TFTP BOOT ---------------------------------------------------
Server IP.....................10.0.0.242
Client IP.....................10.0.0.241
Gateway IP....................10.0.0.1
Subnet Mask...................255.255.255.0
( 1  ) Filename.................yaboot_rhel6
TFTP Retries..................5
Block Size....................512
FINAL PACKET COUNT = 388
FINAL FILE SIZE = 198192  BYTES

Elapsed time since release of system processors: 80 mins 48 secs

Try to netboot
Failed to get netinfo data

TFTP BOOT ---------------------------------------------------
Server IP.....................10.0.0.242
Client IP.....................10.0.0.241
Gateway IP....................10.0.0.1
Subnet Mask...................255.255.255.0
( 1  ) Filename.................\etc\yaboot.conf
TFTP Retries..................5
Block Size....................512
FINAL PACKET COUNT = 1
FINAL FILE SIZE = 318  BYTES
Config file read, 318 bytes

Welcome to the 64-bit Red Hat Enterprise Linux 6 6.0 installer!
Hit <TAB> for boot options.

Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-23.el6)
Enter "help" to get some basic usage information
boot: linux
/vmlinuz-2.6.31-33.el6.ppc64: Unable to parse
boot:
Comment 24 IBM Bug Proxy 2009-11-16 21:30:52 EST
------- Comment From tonyb@au1.ibm.com 2009-11-16 21:12 EDT-------
(In reply to comment #33)

<snip>
> Try to netboot
> Failed to get netinfo data

<snip>

Ahh this looks interesting!

I'll see if I can reproduce this bug on my local JS22's

------- Comment From tonyb@au1.ibm.com 2009-11-16 21:15 EDT-------
(In reply to comment #32)

> Nope, this didn't help. It got past that point, but had a firmware crash

Well hand-hacking the kernel was always going to be a problem.  FWIW I will not focus on this
as it's un-supported and was meant as a quick workaround.
Comment 25 IBM Bug Proxy 2009-11-16 22:00:54 EST
------- Comment From tonyb@au1.ibm.com 2009-11-16 21:53 EDT-------
(In reply to comment #36)
> (In reply to comment #33)
>
> <snip>
> > Try to netboot
> > Failed to get netinfo data
>
> <snip>
>
> Ahh this looks interesting!
>
> I'll see if I can reproduce this bug on my local JS22's

Indeed I can reproduce this on my JS22 and it is the root cause of the "unable to parse failure".  I need to determine what the correct solution is.

I can work around this problem by using SMS to boot over the network rather than OF.  I do not know why.
Comment 26 IBM Bug Proxy 2009-11-16 22:30:56 EST
------- Comment From tonyb@au1.ibm.com 2009-11-16 22:29 EDT-------
(In reply to comment #38)

> I can work around this problem by using SMS to boot over the network rather
> than OF.  I do not know why.

Still don't know why but including "speed=auto,duplex=auto" and booting from OF Also works for me.
Comment 27 IBM Bug Proxy 2009-11-17 17:12:06 EST
Created attachment 369970 [details]
Addind speed and duplex didn&apos;t help in my blade


------- Comment on attachment From sekharan@us.ibm.com 2009-11-17 17:02 EDT-------


Added speed=auto and duplex=auto, still see "Failed to get netinfo data" error and 
still fails with "Unable to parse".

Detailed o/p on the attachment.
Comment 28 IBM Bug Proxy 2009-11-18 18:21:13 EST
------- Comment From tonyb@au1.ibm.com 2009-11-18 18:17 EDT-------
(In reply to comment #40)
> Created an attachment (id=49487) [details]
> Addind speed and duplex didn't help in my blade
>
> Added speed=auto and duplex=auto, still see "Failed to get netinfo data" error
> and
> still fails with "Unable to parse".
>
> Detailed o/p on the attachment.

What about SMS?
Comment 29 IBM Bug Proxy 2009-11-23 22:31:09 EST
Created attachment 373333 [details]
With SMS, boot proceded further, but died in a odd way


------- Comment on attachment From sekharan@us.ibm.com 2009-11-23 22:29 EDT-------


(In reply to comment #41)
> (In reply to comment #40)
> > Created an attachment (id=49487) [details] [details]
> > Addind speed and duplex didn't help in my blade
> > 
> > Added speed=auto and duplex=auto, still see "Failed to get netinfo data" error
> > and 
> > still fails with "Unable to parse".
> > 
> > Detailed o/p on the attachment.
> 
> What about SMS?

Went further. but died oddly.

scsi module was not insmodded and hence didn't find the root device, but, printed the different message than the usual "no root found" etc.,
Comment 30 IBM Bug Proxy 2009-11-23 22:41:03 EST
------- Comment From sekharan@us.ibm.com 2009-11-23 22:30 EDT-------
Tony,

I think I should open a separate bug for the yaboot behavior instead of just describing it here.

What do you think ?

------- Comment From tonyb@au1.ibm.com 2009-11-23 22:32 EDT-------
(In reply to comment #43)
> Tony,
>
> I think I should open a separate bug for the yaboot behavior instead of just
> describing it here.
>
> What do you think ?

Yes please Assign it to me, and if possible supply access details to the machine and TFTP server so I can debug it.

Tony.
Comment 31 IBM Bug Proxy 2009-12-01 21:41:21 EST
------- Comment From sekharan@us.ibm.com 2009-12-01 21:31 EDT-------
Tony Breeds suggested to try to netboot ipv6 with the install yaboot, kernel and yaboot from SMS.

ipv4 booting succeeded.

Whereas ipv6 netboot (from SMS) failed
-------------------------------------------
TFTP BOOT ---------------------------------------------------
Server IP.....................fe80:0:0:0:20d:60ff:fe1e:bd0f
Client IP.....................fe80:0:0:0:21a:64ff:fe44:b787
( 1  ) Filename.................yaboot.in
TFTP Retries..................5
Block Size....................512
FINAL PACKET COUNT = 388
FINAL FILE SIZE = 198192  BYTES

Elapsed time since release of system processors: 2 mins 56 secs

Try to netboot
Failed to get netinfo data

TFTP BOOT ---------------------------------------------------
Server IP.....................fe80:0:0:0:20d:60ff:fe1e:bd0f
Client IP.....................fe80:0:0:0:21a:64ff:fe44:b787
( 1  ) Filename.................\etc\yaboot.conf
TFTP Retries..................5
Block Size....................512
FINAL PACKET COUNT = 1
FINAL FILE SIZE = 227  BYTES
Config file read, 227 bytes

Welcome to the 64-bit Red Hat Enterprise Linux 6 6.0 installer!
Hit <TAB> for boot options.

Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-23.el6)
Enter "help" to get some basic usage information
boot:
* linux
boot:
vmlinuz: Unable to parse
boot:
------------------------------------
Comment 32 Roman Rakus 2010-02-05 05:58:31 EST
Can you please post here output from yaboot with debug enabled?
Comment 33 IBM Bug Proxy 2010-02-05 13:00:58 EST
------- Comment From sekharan@us.ibm.com 2010-02-05 12:59 EDT-------
It is already posted above.

Look for yaboot_rhel6d
Comment 34 Roman Rakus 2010-02-08 09:43:34 EST
I'm not sure, but message `Failed to get netinfo data' is probably causing the problems. What boot device are you using during IPV{4,6} booting?
Our working boot-device is:
0 > printenv boot-device 
-------------- Partition: common -------- Signature: 0x70 ---------------
boot-device             
/lhea@23c00200/ethernet@23e00200:speed=auto,duplex=auto,000.000.000.000,,000.000.000.000,000.000.000.000,5,5,000.000.000.000,512
/vdevice/v-scsi@30000002/disk@8100000000000000 
 ok
0 > 

Maybe speed && duplex is helping, but I guess what helps are those NULLs ip addresses.
Comment 35 IBM Bug Proxy 2010-05-11 12:01:08 EDT
------- Comment From sekharan@us.ibm.com 2010-05-11 11:57 EDT-------
Verified that yaboot in RHEL6-snap2 is working on a JS12 system with the install kernel and ramdisk.
Comment 36 Alexander Todorov 2010-07-13 12:09:17 EDT
Moving to VERIFIED as per comment #35
Comment 37 releng-rhel@redhat.com 2010-11-10 17:24:22 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.