Bug 463607 - [LTC 6.0 FEAT] 201176:Merge CTCMPC into CTC device driver for upstream integration
[LTC 6.0 FEAT] 201176:Merge CTCMPC into CTC device driver for upstream integr...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.0
Assigned To: Hans-Joachim Picht
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2008-09-23 23:11 EDT by IBM Bug Proxy
Modified: 2010-06-08 10:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 16:53:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-23 23:11:03 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:05 EDT
1. Feature Overview:
Feature Id:	[201176]
a. Name of Feature:	Merge CTCMPC into CTC device driver for upstream integration
b. Feature Description
Merge CTC & CTCMPC device drivers for continued support for CTCMPC functionality which is needed by
Communication Server for Linux on System z.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	zSeries
Request Type:	Driver - Feature from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.26

3. Business Case
Enables upstream acceptance of ctcmpc, which is a prerequisite to Linux Communication Server Product
that allows customers with old SNA HW & SW connecting to z/OS to migrate to TCP/IP HW while  running
SNA over IP.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-02 16:23:18 EDT
RHEL 6 will include a newer kernel than 2.6.26, so this should not be a problem.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 2 Hans-Joachim Picht 2009-09-22 16:53:04 EDT
Code is included in the rhel6 kernel via upstream. Marked as
CLOSED/CURRENTRELEASE by  Hans-Joachim Picht <hpicht@redhat.com>
Comment 3 IBM Bug Proxy 2010-03-16 09:41:57 EDT
------- Comment From mgrf@de.ibm.com 2010-03-16 09:34 EDT-------
BZ that impacts this feature:
57076   -  RHBZ507211 - need udev rules to automatically load s390 network device drivers for LCS and CTC
Comment 4 IBM Bug Proxy 2010-06-08 10:31:54 EDT
------- Comment From mgrf@de.ibm.com 2010-06-08 10:24 EDT-------
This feature is verified on R6 snapshots with the following bug reported
Set feature to verified
because the severity of the outstanding bug is sev=normal
sev=normal - fix outstanding

LTC 64368   -  RIT951753- [RHEL6.0 Snap4] ctc interface is not available on-boot with ctcm driver

Note You need to log in before you can comment on or make changes to this bug.