Bug 463613 - [LTC 6.0 FEAT] 201194:libhugetlbfs package update
[LTC 6.0 FEAT] 201194:libhugetlbfs package update
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libhugetlbfs (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Nils Philippsen
BaseOS QE - Apps
: FutureFeature
Depends On:
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-23 23:30 EDT by IBM Bug Proxy
Modified: 2010-05-27 04:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: libhugetlbfs-2.6-2.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 04:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-23 23:30:36 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:07 EDT
1. Feature Overview:
Feature Id:	[201194]
a. Name of Feature:	libhugetlbfs package update
b. Feature Description
Place holder for pulling latest version at time of code freeze if any bugfixes/features from
upstream end up being needed.

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64
ppc64

Arch Specificity: Purely Common Code
Delivery Mechanism: Direct from community
Category:	Power
Request Type:	Package - Update Version
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	Latest version
Performance Assistance:	yes

3. Business Case
libhugetlbfs provides substantial performance improvements for certain workloads so it functioning
optimally enables Linux HPC sales that would previously go to other operating systems.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Adam Litke, litke@us.ibm.com
Nishanth Aravamudan, aravam@us.ibm.com

IBM Manager:
Pat Gaughen, gaughen@us.ibm.com
Comment 1 Nils Philippsen 2008-10-30 11:08:48 EDT
Mind that a new version will be pulled at feature freeze, not code freeze (maybe just a matter of nomenclature). Ping me when that version is available.
Comment 2 IBM Bug Proxy 2009-03-02 19:30:29 EST
libhugetlbfs 2.2 should be packaged in Fedora. The three RPMs are

libhugetlbfs
libhugetlbfs-devel
libhugetlbfs-utils

Please pull all three packages. Thanks
Comment 3 Nils Philippsen 2009-03-18 06:15:32 EDT
As version 2.2 is now in Fedora, this should get pulled for RHEL6.
Comment 4 IBM Bug Proxy 2009-09-10 00:00:35 EDT
------- Comment From lxie@us.ibm.com 2009-09-09 23:54 EDT-------
Eric,

We need to keep this bug opened until we test it in rhel6 since this is a rhel6 feature.

------- Comment From lxie@us.ibm.com 2009-09-09 23:57 EDT-------
move to accept based on its external status (Modified)
Comment 5 John Jarvis 2009-10-15 10:59:57 EDT
IBM is signed up to test and provide feedback
Comment 6 releng-rhel@redhat.com 2009-10-30 18:11:34 EDT
Fixed in 'libhugetlbfs-2.6-2.el6', included in compose 'RHEL6.0-20091029.0'.
Moving to ON_QA.
Comment 7 IBM Bug Proxy 2009-11-16 19:20:34 EST
------- Comment From ebmunson@us.ibm.com 2009-11-16 19:13 EDT-------
These are also expected failures, they are testing the old relinking method.  These tests should only be used to determine is the old method works with a particular compiler/binutils combination.  As long as the new linker method worked (and it looks like it did) these errors can be ignored.
Comment 8 IBM Bug Proxy 2010-05-06 11:54:08 EDT
------- Comment From ebmunson@us.ibm.com 2010-05-06 11:46 EDT-------
Verified with RHEL 6 Snap 1.  There is a small problem with the test suite that does not affect the library or any of the utilities.  I will open a separate bu with a patch to fix the issue but this should not stand in the way of the package update.
Comment 9 Radek Bíba 2010-05-27 04:48:04 EDT
Thank you for the verification.

Note You need to log in before you can comment on or make changes to this bug.