Bug 463637 - [LTC 6.0 FEAT] 201260:Emulex 8GB FC Driver Update
[LTC 6.0 FEAT] 201260:Emulex 8GB FC Driver Update
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Tom Coughlan
Barry Donahue
: FutureFeature
Depends On:
Blocks: 534151 356741 554559 555224 555228
  Show dependency treegraph
 
Reported: 2008-09-24 00:30 EDT by IBM Bug Proxy
Modified: 2010-11-15 09:04 EST (History)
4 users (show)

See Also:
Fixed In Version: kernel-2.6.32-14.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:04:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 00:30:40 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:10 EDT
1. Feature Overview:
Feature Id:	[201260]
a. Name of Feature:	Emulex 8GB FC Driver Update
b. Feature Description
This request is to ensure the lpfc driver is updated to support 8GB Emulex FC adapter.

2. Feature Details:
Sponsor:	xSeries
Architectures:
x86
x86_64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Driver - Feature from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	2.6.23.

3. Business Case
We will introduce an 8GB Emulex FC in 2H08.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

IBM Manager:
Julio Alvarez, julioa@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 16:50:58 EDT
RHEL 6 will include at least a 2.6.23 kernel, so this should not be a problem.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 2 IBM Bug Proxy 2008-10-03 12:19:36 EDT
in Red Hat CVS Tree Marking as Accepted
Comment 3 IBM Bug Proxy 2008-10-03 18:30:32 EDT
Yes, since RHEL6 will rebase from a new upstream kernel, whatever lpfc driver version is in that kernel should be sufficient. At this point, I don't believe there are any requirements for features above and beyond what will be upstream when Red Hat the kernel for RHEL6. Thanks.
Comment 5 IBM Bug Proxy 2010-05-24 15:10:51 EDT
------- Comment From rlary@us.ibm.com 2010-05-24 15:05 EDT-------
RHEL6 snap3 contains qla2xxx driver version 8.3.5.7 in kernel 2.6.32-24.el6.ppc64.
This version of lpfc driver supports all current IBM branded Emulex Fibre Channel (2,4,8GB)adapters on Power and Intel cpu architctures.  Driver passed functional verification tests on Power systems with IBM DS4k and DS3k storage systems.

It would be appropriate to risk assume driver support on architectures other than Power based upon sucessful test/verification performed on Power.  This is being requested due to lack of Emulex 8GB Fibre Channel hardware in Beaverton test lab for test with Intel architectures.
Comment 6 IBM Bug Proxy 2010-06-02 14:50:40 EDT
------- Comment From pbogdanovic@us.ibm.com 2010-06-02 14:49 EDT-------
Successfully installed RHEL6 snap4 to SAN disks connected via an Emulex Saturn-X: LightPulse Fibre Channel Host Adapter (Emulex 10N9824) . Able to configure option ROM to boot from SAN. Passed disk i/o stress tests.

filename:       /lib/modules/2.6.32-25.el6.x86_64/kernel/drivers/scsi/lpfc/lpfc.ko
version:        0:8.3.5.7
Comment 7 releng-rhel@redhat.com 2010-11-15 09:04:56 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.