Bug 463651 - [LTC 6.0 FEAT] 201320:IPv6 support in NFS (user space)
[LTC 6.0 FEAT] 201320:IPv6 support in NFS (user space)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Steve Dickson
Jan Ščotka
: FutureFeature
Depends On:
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-24 01:10 EDT by IBM Bug Proxy
Modified: 2010-07-02 15:37 EDT (History)
6 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.0-10.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 01:10:52 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:11 EDT
1. Feature Overview:
Feature Id:	[201320]
a. Name of Feature:	IPv6 support in NFS (user space)
b. Feature Description
To add the support of IPv6 in NFS.  This feature is for user space part. The NFS
commands/tools/utils packages are available since 1.0.10.

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64
ppc64
s390 native
s390 compat
s390x

Arch Specificity: Purely Common Code
Delivery Mechanism: 
Category:	Remote Filesystems
Request Type:	Other
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	3rd party code
g. Component Version Target:	nfs-utils 1.0.10 -> userspace tools

3. Business Case
IPv6 support in NFS is needed for several customers and is required for some government contracts
(all DoD contracts).

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Sarah Wright, sarahw@us.ibm.com, 503-578-5145

Technical contact(s):
Frank Filz, ffilz@us.ibm.com
Varun Chandramohan, varuncha@in.ibm.com

IBM Manager:
Jeffrey Heroux, heroux@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 16:58:56 EDT
We currently ship nfs-utils-1.1.3 in Fedora.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 2 IBM Bug Proxy 2009-01-28 14:00:50 EST
Varun is no longer working on this.
Comment 3 IBM Bug Proxy 2009-02-05 16:00:53 EST
Here is an update from Chuck Lever on the status of NFS support fpor IPv6:

On Jan 28, 2009, at Jan 28, 2009, 2:34 PM, Frank S Filz wrote:
> I'm trying to determine the current status of IPv6 support for NFS.
> I understand support is nearly complete but a few pieces may not be
> quite complete.

You should be able to mount NFSv4 servers from the Linux NFS client in
2.6.28, using the mount.nfs command from the latest nfs-utils.
Callback over IPv6 is supported, and maybe referral too.

With 2.6.30, IPv6 will be supported in all the kernel NFS client and
server components (rpcbind and mountd client, NLM, NSM, NFS client,
and NFSD), though I wager it will need some shake-down time as user
space support for IPv6 is still lagging.

Distributions need to carry the new libtirpc and replace their
portmapper with rpcbind.  Fedora, so far, is the only one that is
doing this, although I think RHEL 6 and the next release of OpenSUSE
will have it too.

The next upstream release of nfs-utils will have showmount and
complete [u]mount.nfs support for IPv6 (necessary for mounting NFSv2/
v3 servers over IPv6, but not sufficient).

I have sm-notify support done, and am working on rpc.statd now for
testing at Connectathon 2009.  This will complete client side support
for NFSv2/v3 over IPv6, and is also necessary but not sufficient for
server side NFSv2/v3 over IPv6.

The next piece is rpc.mountd and exportfs to complete server side IPv6
support, as NFS server access control is IP address-based.  Bull had
something here, but I haven't seen that work, and they've been defunded.

We haven't looked at Kerberos (GSSAPI) yet, but I don't think there
will be significant issues there.  Jeff (cc added) might be looking at
this.

--
Chuck Lever
chuck[dot]lever[at]oracle[dot]com
Comment 4 John Jarvis 2009-10-15 11:00:29 EDT
IBM is signed up to test and provide feedback
Comment 5 releng-rhel@redhat.com 2009-10-30 18:12:55 EDT
Fixed in 'nfs-utils-1.2.0-10.el6', included in compose 'RHEL6.0-20091029.0'.
Moving to ON_QA.
Comment 6 IBM Bug Proxy 2009-11-02 15:00:34 EST
------- Comment From ffilz@us.ibm.com 2009-11-02 14:53 EDT-------
Chuck Lever just posted an update on status:

http://thread.gmane.org/gmane.linux.nfs/29288/focus=29294
Comment 7 IBM Bug Proxy 2009-11-18 08:00:32 EST
Since this has been accepted by Red Hat , moving to Accepted
Comment 8 IBM Bug Proxy 2010-03-04 16:11:09 EST
------- Comment From ffilz@us.ibm.com 2010-03-04 16:04 EDT-------
Status has been upated here:
http://wiki.linux-nfs.org/wiki/index.php/Ipv6PlanningDocument

There is also a pointer to the Connectathon 2010 presentation on IPv6 which may be a bit more up to date than the wiki page.
Comment 10 IBM Bug Proxy 2010-05-28 12:49:50 EDT
------- Comment From ffilz@us.ibm.com 2010-05-28 12:35 EDT-------
This feature has been verified. Only NFS v4 was tested since we didn't have a IPv6 capable NFS v3 server.
Comment 11 releng-rhel@redhat.com 2010-07-02 15:37:24 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.