Bug 463712 - [LTC 6.0 FEAT] 200829:UEFI support - grub
[LTC 6.0 FEAT] 200829:UEFI support - grub
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grub (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Peter Jones
Release Test Team
: FutureFeature
Depends On: 598572
Blocks: 356741 464553 495116 495132 511114 511881 511889 511890 511891 511948 512362 512364 515064 519844 554552 554559 555224 555228
  Show dependency treegraph
 
Reported: 2008-09-24 03:51 EDT by IBM Bug Proxy
Modified: 2010-11-10 15:35 EST (History)
4 users (show)

See Also:
Fixed In Version: grub-0.97-60
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:35:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 03:51:14 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-17 10:34 EDT
1. Feature Overview:
Feature Id:	[200829]
a. Name of Feature:	UEFI support - grub
b. Feature Description
Request full support for UEFI for i386 and x86_64 archs. Requires UEFI
extensions to lilo/grub boot loaders.  Also expect support EFI Variables in
NVRAM exported to the OS, EFI runtime  services. It appears most of the
development for i386 is complete, but needs to be verified. x86_64 support is
being developed by Intel and needs to be submitted upstream.  ia64 has supported
EFI from the beginning.

2. Feature Details:
Sponsor:	xSeries
Architectures:
x86
x86_64

Arch Specificity: Both
Affects Installer: Yes
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	xSeries
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	3rd party code
g. Component Version Target:	grub + UEFI patches

3. Business Case
All upcoming System x hardware will support UEFI-based BIOS. UEFI is projected
to be on system x hardware as soon as 1H 08, which means it would be in test 2H07

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

IBM Manager:
Julio Alvarez, julioa@us.ibm.com
Comment 1 Bill Nottingham 2008-10-03 11:04:22 EDT
This feature exists in the current Fedora beta release.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 2 IBM Bug Proxy 2008-10-03 12:02:42 EDT
in Red Hat CVS Tree Marking as Accepted
Comment 3 John Jarvis 2008-10-28 17:43:29 EDT
Switching Severity from Urgent to High.  Urgent should be reserved for problems that need to be fixed asynch.
Comment 5 IBM Bug Proxy 2010-06-04 14:01:02 EDT
------- Comment From garyhade@us.ibm.com 2010-06-04 13:54 EDT-------
Verification completion depends on resolution of the following issue.

LTC bug 64356 - RIT961823- first boot failure on system with internal USB drive
https://bugzilla.linux.ibm.com/show_bug.cgi?id=64356
Red Hat bug 598572 - first boot failure on system with internal USB drive
https://bugzilla.redhat.com/show_bug.cgi?id=598572
Comment 6 IBM Bug Proxy 2010-07-06 18:20:42 EDT
------- Comment From garyhade@us.ibm.com 2010-07-06 18:12 EDT-------
Verification is still awaiting resolution of the issue mentioned in the previous
comment.  We are waiting to hear the results of the Red Hat engineering
review.
Comment 8 Alexander Todorov 2010-07-13 11:43:00 EDT
IBM,
can you perform the UEFI install/boot test on a system that doesn't have USB disks connected to work around bug #598572 ?
Comment 9 IBM Bug Proxy 2010-07-13 13:10:52 EDT
------- Comment From garyhade@us.ibm.com 2010-07-13 13:00 EDT-------
(In reply to comment #10)
> IBM,
> can you perform the UEFI install/boot test on a system that doesn't have USB
> disks connected to work around bug #598572 ?

Yes, if no internally or externally connected USB drives are
present during the install we do not see the first boot failure.

HOWEVER, as indicated in the bug, if any USB drives are added
following installation (e.g. by someone inserting USB key or
introducing a media tray containing a USB drive) a boot or
reboot will fail.

The workaround you are suggesting would not be reasonable
for systems with internal USB drives because the system
would have to be opened up to remove the USB key prior to
installation and the subsequent replacement of the key
following installation would cause boot/reboot to fail in the
same way it would if an externally connected USB drive
was connected after the install.
Comment 10 Alexander Todorov 2010-07-14 05:44:27 EDT
IBM,
thanks for the update. As per comment #9 I'm moving this bug to VERIFIED.

The remaining issues with internal/external USB drives is in bug #598572. Post all you additional comments there.
Comment 11 IBM Bug Proxy 2010-07-14 16:00:52 EDT
------- Comment From garyhade@us.ibm.com 2010-07-14 15:52 EDT-------
I have been working under the misunderstanding that all bugs reported
against a feature needed to be resolved before the Distro State can be
moved to VERIFIED.  I just found out that a feature can be marked as
VERIFIED before all the open issues reported with respect to it have
been resolved.  So, I am moving this one to VERIFIED before the open
issue I mentioned above is closed.
Comment 12 releng-rhel@redhat.com 2010-11-10 15:35:35 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.