Bug 463799 - [LTC 6.0 FEAT] 201747:Shutdown actions interface (kernel)
[LTC 6.0 FEAT] 201747:Shutdown actions interface (kernel)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: ---
Assigned To: Hans-Joachim Picht
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 515068
  Show dependency treegraph
 
Reported: 2008-09-24 14:50 EDT by IBM Bug Proxy
Modified: 2010-10-21 03:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 06:48:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 14:50:39 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-24 13:51 EDT
1. Feature Overview:
Feature Id:	[201747]
a. Name of Feature:	Shutdown actions interface (kernel)
b. Feature Description
Implement a sysfs interface to associate actions to shutdown triggers.    
Shutdown triggers:
    - reboot
    - halt
    - power off
    - panic.        
Shutdown actions:
    - stop
    - IPL
    - reIPL
    - dump
    - perform VM command

Additional Comments:	This feature has a userspace part, that is 201148 Shutdown actions interface
(userspace)

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	RAS
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.25

3. Business Case
This feature enables a better availability of the system and service actions so that the customer
improve his system reliability and service, in case of, for example, a kernel panics.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-03 11:17:22 EDT
See bug 463824 - is there a reason this can't be done in a generic way?
Comment 2 IBM Bug Proxy 2009-02-05 00:30:32 EST
(In reply to comment #4)
> See bug 463824 - is there a reason this can't be done in a generic way?
>

It cannot be done in a generic way because "ipl", "reipl", "dump dasd and SCSI" and "vm commands" are specific to the System z Arch.
Comment 3 IBM Bug Proxy 2009-03-03 17:31:31 EST
This feature has a required co-feature request to be complete
That is:
48440 ??-?? RHBZ 463806 [LTC 6.0 FEAT] 201748:Shutdown actions interface (userspace)
Comment 4 Hans-Joachim Picht 2009-09-17 06:48:28 EDT
Code is included in the rhel6 kernel via upstream. Marked as CLOSED/CURRENTRELEASE by by Hans-Joachim Picht <hpicht@redhat.com>
Comment 5 IBM Bug Proxy 2010-09-29 08:51:42 EDT
------- Comment From gmuelas@de.ibm.com 2010-09-29 08:45 EDT-------
This feature is still being verified, but we do not expect any issues here and
will be verified before GA.
Comment 6 IBM Bug Proxy 2010-10-21 03:41:44 EDT
------- Comment From mgrf@de.ibm.com 2010-10-21 03:32 EDT-------
This feature is verified on RHEL 6 snapshot -> set to verified

Note You need to log in before you can comment on or make changes to this bug.