Bug 463811 - [LTC 6.0 FEAT] 201753:Provide service levels of HW & Hypervisor in Linux
[LTC 6.0 FEAT] 201753:Provide service levels of HW & Hypervisor in Linux
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: ---
Assigned To: Hans-Joachim Picht
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 465490
  Show dependency treegraph
 
Reported: 2008-09-24 15:10 EDT by IBM Bug Proxy
Modified: 2010-10-25 02:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 10:20:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 15:10:45 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-24 13:51 EDT
1. Feature Overview:
Feature Id:	[201753]
a. Name of Feature:	Provide service levels of HW & Hypervisor in Linux
b. Feature Description
Provide service levels of hardware and zVM service-levels to Linux userspace, in this case, via
/proc/service_levels

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	RAS
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.28

3. Business Case
This feature simplfies problem analysis, reducing service costs and TCO, because every time a
customer reports a problem this information is needed.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 IBM Bug Proxy 2009-03-03 17:10:59 EST
This is accepted with k 2.6.29

comes via upstream
Comment 2 IBM Bug Proxy 2010-09-29 08:51:52 EDT
------- Comment From gmuelas@de.ibm.com 2010-09-29 08:43 EDT-------
This feature is still being verified, but we do not expect any issues here and will be verified before GA.
Comment 3 IBM Bug Proxy 2010-10-25 02:31:24 EDT
------- Comment From mgrf@de.ibm.com 2010-10-25 02:27 EDT-------
This feature is verified on R6 snapshots - set to verified

Note You need to log in before you can comment on or make changes to this bug.