Bug 463832 - [LTC 6.0 FEAT] 201759:Extra kernel parameter for SCSI IPL
[LTC 6.0 FEAT] 201759:Extra kernel parameter for SCSI IPL
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: ---
Assigned To: Hans-Joachim Picht
Martin Jenner
: FutureFeature, OtherQA, Reopened
Depends On:
Blocks: 356741 465491
  Show dependency treegraph
 
Reported: 2008-09-24 16:20 EDT by IBM Bug Proxy
Modified: 2010-10-18 05:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-14 06:19:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 16:20:53 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-24 13:52 EDT
1. Feature Overview:
Feature Id:	[201759]
a. Name of Feature:	Extra kernel parameter for SCSI IPL
b. Feature Description
This features implements the use the 'OS specific data' field of the LPAR SCSI IPL panel to add
extra kernel parameters.  These extra kernel parameters will be appended to the Linux kernel command
line.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.29

3. Business Case
This feature gives the customer improved flexibility when booting from SCSI.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-09-24 16:52:17 EDT
Can you give an example of the usage case for this, and what sort of syntax you're expecting to use (and what you want userspace to do with it?)b
Comment 2 IBM Bug Proxy 2009-03-04 09:01:55 EST
This item has been moved in System z plans.
Therefore it will not be posted for k 2.6.30.

Defer this feature from RHEL 6 to RHEL 6.1
Comment 3 John Jarvis 2009-03-25 12:40:59 EDT
Closing as DEFERRED based on comment 2.
Comment 4 Georg Markgraf 2009-11-03 02:21:02 EST
Re-open feature request for RHEL6
since RHEL 6 will be re-based to k2.6.32 and the code for this feature is accepted upstream with k2.6.32
Comment 5 John Jarvis 2009-11-12 09:11:24 EST
IBM is signed up to test and provide feedback.
Comment 6 Hendrik Brueckner 2009-12-14 06:19:15 EST
The feature is upstream with kernel version 2.6.32:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=684d2fd48e718e70dad21ef7c528649578147e48

Feature is included in the RHEL6 kernel via rebase to 2.6.32. Marked as
CLOSED/CURRENTRELEASE by Hendrik Brueckner <brueckner@redhat.com>.
Comment 7 IBM Bug Proxy 2010-09-29 09:02:09 EDT
------- Comment From gmuelas@de.ibm.com 2010-09-29 08:53 EDT-------
This feature is still being verified, but we do not expect any issues here and
will be verified before GA.
Comment 8 IBM Bug Proxy 2010-10-18 05:40:40 EDT
------- Comment From mgrf@de.ibm.com 2010-10-18 05:31 EDT-------
This feature is verified to 75% on R6 snapshots
-> remaining tests require bug fix, that is planned for z.stream update

LTC 67541 - RH637087 - Kernel Memory dump to a FCP device fails with panic [rhel-6.0.z]

Set feature to verified - with problem identified
-> fix will be verified as fix verification (not feature test)

Note You need to log in before you can comment on or make changes to this bug.