Bug 463835 - [LTC 6.0 FEAT] 201206:Update OpenHPI to 2.12.1 (at a minimum) for RHEL6
[LTC 6.0 FEAT] 201206:Update OpenHPI to 2.12.1 (at a minimum) for RHEL6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openhpi (Show other bugs)
6.0
All All
medium Severity medium
: alpha
: 6.0
Assigned To: Dan Horák
Yulia Kopkova
: FutureFeature, OtherQA
Depends On:
Blocks: 356741 554559 555224 555228
  Show dependency treegraph
 
Reported: 2008-09-24 16:40 EDT by IBM Bug Proxy
Modified: 2010-11-15 09:33 EST (History)
8 users (show)

See Also:
Fixed In Version: openhpi-2.14.0-4.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:33:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 16:40:41 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-24 13:52 EDT
1. Feature Overview:
Feature Id:	[201206]
a. Name of Feature:	Update OpenHPI to 2.10.1 (or later) for RHEL6
b. Feature Description
OpenHPI is an open source implementation of the Hardware Platform Interface (HPI) set forth by the
Service Availability Forum.

2. Feature Details:
Sponsor:	LTC Systems Mgt
Architectures:
x86
x86_64
ppc64

Arch Specificity: Purely Common Code
Delivery Mechanism: Direct from community
Category:	Systems management
Request Type:	Package - Version Update
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	OpenHPI 2.10.2 is already available from http://openhpi.org

3. Business Case
OpenHPI 2.10.1 contains the implementation of the new SAF HPI B.02.01 specification. This contains
new APIs  for resource management, plus diagnostics and firmeware update management.  The SAF HPI
B.02.01 (OpenHPI 2.10) is backwards compatible with SAF HPI B.01.01 (OpenHPI 2.8).

Benefits
The complete list of bugs and features, along with their summary, for each OpenHPI release since 2.4
is available at http://www.openhpi.org/News

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Sarah Wright, sarahw@us.ibm.com, 503-578-5145

Technical contact(s):
Mark Brown, bmark@us.ibm.com
Renier Morales, renierm@us.ibm.com

IBM Manager:
Jeffrey Heroux, heroux@us.ibm.com
Comment 1 Bill Nottingham 2008-09-24 16:50:34 EDT
Should be already done in the development tree.
Comment 2 Bill Nottingham 2008-10-03 13:52:21 EDT
The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 3 John Jarvis 2009-03-02 13:56:36 EST
Modifying title to request latest version to meet IBM requirements.
Comment 4 John Jarvis 2009-10-15 11:00:54 EDT
IBM is signed up to test and provide feedback
Comment 5 releng-rhel@redhat.com 2009-10-30 18:13:11 EDT
Fixed in 'openhpi-2.14.0-4.el6', included in compose 'RHEL6.0-20091029.0'.
Moving to ON_QA.
Comment 6 releng-rhel@redhat.com 2010-11-15 09:33:38 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.