Bug 463886 - transmission extremely slow, seemingly due to beagle
transmission extremely slow, seemingly due to beagle
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 01:45 EDT by James Antill
Modified: 2013-03-13 01:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 11:06:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-09-25 01:45:02 EDT
Description of problem:
 I ran transmission for the first time in a while today and added a torrent, clicking the Add button took a _long_ time, as did a couple of the next operations before the torrent started.
 I iniitally assumed this was some weird DNS thing, but then when I went to add another torrent the same thing happened ... at which point I started an strace and got a neverending stream of:

connect(59, {sa_family=AF_FILE, path="/home/james/.beagle/socket"}, 110) = -1 EAGAIN (Resource temporarily unavailable)
nanosleep({0, 200000000}, NULL)         = 0
connect(59, {sa_family=AF_FILE, path="/home/james/.beagle/socket"}, 110) = -1 EAGAIN (Resource temporarily unavailable)
nanosleep({0, 200000000}, NULL)         = 0
connect(59, {sa_family=AF_FILE, path="/home/james/.beagle/socket"}, 110) = -1 EAGAIN (Resource temporarily unavailable)

...given how much I use beagle I just did: rm ~/.beagle/socket ... at which point transmission started responding instantly.

Version-Release number of selected component (if applicable):
transmission.x86_64                     1.33-1.fc9                     installed
Comment 1 Denis Leroy 2008-09-28 10:39:01 EDT
Pretty odd, I can't reproduce. I have the socket beagle file too, and beagle uninstalled, yet the problem doesn't occur for me. Sounds like something went haywire in your setup, like some zombie process holding to the socket ?

What is the output of "sudo lsof | grep beagle" ?
Comment 2 James Antill 2008-09-28 16:02:51 EDT
 Well I think I've upgraded beagle since logging this, but:

% lsof | fgrep beagle | wc -l  
1338

...is that normal? You really want all of that?
Comment 3 Rahul Sundaram 2009-06-03 06:23:28 EDT
James Antill,

Do you still see this problem?
Comment 4 James Antill 2009-06-03 09:50:16 EDT
No, and this is on Fedora 10, but then a quick ps shows that I'm not running beagle either.
Comment 5 Rahul Sundaram 2009-06-03 11:06:25 EDT
I am going to close this for now. If you find any issues, feel free to report them back.

Note You need to log in before you can comment on or make changes to this bug.