Bug 46391 - case-sensitive tag handling in links
case-sensitive tag handling in links
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: links (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-28 08:30 EDT by Ed McKenzie
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 11:03:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-06-28 08:30:59 EDT
links doesn't deal well with html tags when the begin and /end tags 
have different case.  To wit,

http://oss.sgi.com/projects/xfs/ml.html

looks alot different in links than in lynx.  Reading the page source 
shows that the <B> tags are ended with </b> tags ...
Comment 1 Brian Brock 2003-10-13 16:56:56 EDT
I currently see broken html like this:

<pre>

<a href="mail_archive/200007/threads.html"<B>
               July 2000
               </b></a>

</pre>

The only error I currently see is due to non-standard html, not links misparsing
valid html.  Without the a href tag, the text is properly bold'ed.

Also checked behavior with elinks and lynx.

Change state to needinfo, please provide more details if you still see the same bug.

Note You need to log in before you can comment on or make changes to this bug.