Bug 463916 - ipmitool reports bad value for POH counter with FSC RX200S3/TX150S6
ipmitool reports bad value for POH counter with FSC RX200S3/TX150S6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Safranek
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 08:26 EDT by Laurent Jean-Rigaud
Modified: 2009-05-18 16:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:08:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add minuters per counter management in ipmitool chassis poh (748 bytes, patch)
2008-10-21 06:54 EDT, Laurent Jean-Rigaud
no flags Details | Diff

  None (edit)
Description Laurent Jean-Rigaud 2008-09-25 08:26:07 EDT
Description of problem:

ipmitool reports bad value for POH counter under FSC TX150S6 / RX200S3
Don't know if it's sofware or hardware problem.

Version-Release number of selected component (if applicable):
OpenIPMI-1.4.14-1.4E.20 (tested under x86_64 and i386)

How reproducible:

# ipmitool chassis poh
POH Counter  : 880239 hours total (36676 days, 15 hours)

-> should be less for this new machine :-)

 
Additional info:

try last ipmitool-1.8.9 and got same result. Maybe bug in last FSC BMC (the problem does not accure on TX150S4).
Comment 1 Laurent Jean-Rigaud 2008-10-06 07:05:31 EDT
TX200S3 is set as certified (https://hardware.redhat.com/show.cgi?id=213841). 

So is OpenIPMI tested during certification process ??
Comment 2 Laurent Jean-Rigaud 2008-10-08 10:41:47 EDT
FSC TX200S3 updated with last Bios/iRMC FW.
Read POH every minutes -> counter get one hour every 5-6 minutes...

Starting log /tmp/poh-9660.log at mer oct  8 16:26:47 CEST 2008
POH Counter  : 107735 hours total (4488 days, 23 hours)
mer oct  8 16:26:50 CEST 2008: Wait 1 minute...
POH Counter  : 107736 hours total (4489 days, 0 hours)
mer oct  8 16:27:50 CEST 2008: Wait 1 minute...
POH Counter  : 107736 hours total (4489 days, 0 hours)
mer oct  8 16:28:50 CEST 2008: Wait 1 minute...
POH Counter  : 107736 hours total (4489 days, 0 hours)
mer oct  8 16:29:51 CEST 2008: Wait 1 minute...
Get Chassis Power-On-Hours failed: Unspecified error
mer oct  8 16:30:57 CEST 2008: Wait 1 minute...
POH Counter  : 107736 hours total (4489 days, 0 hours)
mer oct  8 16:31:57 CEST 2008: Wait 1 minute...
Get Chassis Power-On-Hours failed: Unspecified error
mer oct  8 16:32:57 CEST 2008: Wait 1 minute...
POH Counter  : 107737 hours total (4489 days, 1 hours)
mer oct  8 16:33:57 CEST 2008: Wait 1 minute...
POH Counter  : 107737 hours total (4489 days, 1 hours)
mer oct  8 16:34:58 CEST 2008: Wait 1 minute...
POH Counter  : 107737 hours total (4489 days, 1 hours)
mer oct  8 16:35:58 CEST 2008: Wait 1 minute...
POH Counter  : 107737 hours total (4489 days, 1 hours)
mer oct  8 16:37:01 CEST 2008: Wait 1 minute...
POH Counter  : 107738 hours total (4489 days, 2 hours)
mer oct  8 16:38:02 CEST 2008: Wait 1 minute...
Comment 3 Laurent Jean-Rigaud 2008-10-20 04:36:31 EDT
According to FSC support, the POH counter increments every 5 minutes so the value returned by ipmitool is false.

Btw the IPMI specification document available on Intel website (http://www.intel.com/design/servers/ipmi/spec.htm) describe a PoH counter incremented every minutes.

So who's wrong ?
Comment 4 Laurent Jean-Rigaud 2008-10-21 06:52:58 EDT
Problem seems to be OpenIPMI. 

According to IPMI specification (available on Intel site), the poh command returns 6 bytes :
  - completion code (1B)
  - minutes per count (1B)
  - counter (4B)

The 'minutes per count' is not managed in OpenIPMI (and also in ipmiutil, FreeIPMI).

So impitool must be patched to display correct value...

example:
# ipmitool -v -I open raw 0x0 0xf
RAW REQ (channel=0x0 netfn=0x0 lun=0x0 cmd=0xf data_len=0)
RAW RSP (5 bytes)
 05 3d b3 01 00

-> minutes per count : 05
-> counter : 0x01b33d -> 111421

Counter should be 111421 / (60 / 5 ) -> 9285.083 hours

Patched ipmitool provides :
# ipmitool -I open chassis poh
POH Counter  : 9285 hours total (386 days, 21 hours)

Better than before ;-)
Comment 5 Laurent Jean-Rigaud 2008-10-21 06:54:35 EDT
Created attachment 321002 [details]
Add minuters per counter management in ipmitool chassis poh

Tested with OpenIPMI 1.1.14 & 2.0.6
Comment 6 Jan Safranek 2008-10-24 04:55:01 EDT
This should be fixed with planned rebase to ipmtiool-1.8.10 in RHEL 4.8 update (bug #454833).
Comment 8 Laurent Jean-Rigaud 2008-10-27 05:09:46 EDT
Right, ipmitool 1.8.10 take care of minutes per count in source code.
Comment 12 errata-xmlrpc 2009-05-18 16:08:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0964.html

Note You need to log in before you can comment on or make changes to this bug.