Bug 46392 - quote in filename
Summary: quote in filename
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: safedelete   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: bero
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-28 12:39 UTC by filos2
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 15:27:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description filos2 2001-06-28 12:39:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
safedelete crashes when trying to delete files that have a quote character
in their name.  E.G. trying to delete a file called mark.o'brien results in
the error
messages:

sh: -c: line 1: unexpected EOF while looking for matching `''
sh: -c: line 2: syntax error: unexpected end of file
sh: -c: line 1: unexpected EOF while looking for matching `''
sh: -c: line 2: syntax error: unexpected end of file


How reproducible:
Always

Steps to Reproduce:
1. safedelete file'name.txt

	

Actual Results:  sh: -c: line 1: unexpected EOF while looking for matching
`''
sh: -c: line 2: syntax error: unexpected end of file
sh: -c: line 1: unexpected EOF while looking for matching `''
sh: -c: line 2: syntax error: unexpected end of file


Expected Results:  The file should have been "safedeleted"

Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-01-18 18:33:55 UTC
Since Powertools has been discontinued, the official fix is the removal of the
package. Sorry.


Note You need to log in before you can comment on or make changes to this bug.